The default bug view has changed. See this FAQ.

Save As PDF freezes the application

RESOLVED FIXED in Firefox 14

Status

Fennec Graveyard
General
--
critical
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Andreea Pod, Assigned: Margaret)

Tracking

({hang, regression})

Firefox 12
Firefox 14
ARM
Android
hang, regression

Details

(Whiteboard: [fennec 11.0b5][fennec 12.0b5])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 602316 [details]
log

Mozilla/5.0 (Android; Linux armv7l;rv:11.0) Gecko/11.0 Firefox/11.0 Fennec/11.0  (29-02-2012)
Device: Asus EEE Transformers (Android 3.1)

Steps to reproduce:
1. go to about:blank
2. tap on menu and chose Save As PDF

Expected results:
- a white blank page should be saved and the application should work properly 

Actual results:
- Fennec freezes after saving the page.

Note: 
- sometimes the application is not responding even after kill.
(Reporter)

Updated

5 years ago
status-firefox11: --- → affected
status-firefox12: --- → unaffected
status-firefox13: --- → unaffected
Whiteboard: [fennec 11.0b5]

Comment 1

5 years ago
This also reproduces on normal pages like nytimes.com so it's not related to about:blank only.
Summary: Save As PDF on about:blank freezes the application → Save As PDF freezes the application
Whiteboard: [fennec 11.0b5] → [fennec 11.0b5][fennec 12.0b5]
I'm seeing this in current Fenne12b too, so setting status-firefox12 to affected.

Fwiw, this makes 'Save As PDF' unusable for me and causes Fennec to hang so shouldn't this block XUL Fennec?
Severity: major → critical
tracking-fennec: --- → ?
status-firefox12: unaffected → affected
Keywords: hang
Version: Firefox 11 → Firefox 12
I'm not seeing this hang in Fennec 10, we should find a regression range for this bug.
tracking-firefox11: --- → ?
Keywords: regression, regressionwindow-wanted
20111130 11.0a1 build is hanging.
20111115 11.0a1 build is not hanging (bug shows bug 704185)
Using 12.0b4 (on Google Play) as well as 12.0b5 (current testing candidate, build #1), I am unable to reproduce this on a Galaxy Nexus (Android 4.0.4), nor having tested on a Galaxy SII (Android 2.3.4). I used cnn.com and nytimes.com.
Ok scratch that, I do see it; it happened on a second attempt this time at bbc.co.uk,

E/ActivityManager(  192): ANR in org.mozilla.firefox_beta (org.mozilla.firefox_beta/.App)
E/ActivityManager(  192): Reason: keyDispatchingTimedOut
E/ActivityManager(  192): Load: 1.03 / 0.78 / 0.4
E/ActivityManager(  192): CPU usage from 5631ms to 0ms ago:
E/ActivityManager(  192):   99% 3911/org.mozilla.firefox_beta: 56% user + 43% kernel

"Firefox Beta is not responding"
20111129 11.0a1 build is not hanging
http://hg.mozilla.org/mozilla-central/rev/bc48009a6bbb

20111130 11.0a1 build is hanging
http://hg.mozilla.org/mozilla-central/rev/cc94a16983b0

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-11-28+10%3A00%3A00&enddate=2011-11-30+03%3A00%3A00

Could this be a regression from bug 704691?
Keywords: regressionwindow-wanted
Andreea, could you perhaps also check if the regression range in comment 7 is correct?
Margaret, this is a regression in XUL Fennec that is causing hangs when using Save As PDF. Do you know if the fix for bug 704691 could be causing this?
(Reporter)

Comment 10

5 years ago
Yes Martijn, I checked and it is correct.
(Assignee)

Comment 11

5 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #9)
> Margaret, this is a regression in XUL Fennec that is causing hangs when
> using Save As PDF. Do you know if the fix for bug 704691 could be causing
> this?

That seems like the likely culprit. So this isn't a problem in fennec native? We changed the fennec native code that depends on the changes from bug bug 704691 in bug 701797, so maybe we need to port the changes from bug 701797 to XUL fennec.
No, this is not a problem in Fennec Native.
(Assignee)

Comment 13

5 years ago
Created attachment 616786 [details] [diff] [review]
patch

The problem is that bug 704691 added another STATE_STOP call to nsPrintData:: DoOnProgressChange, and since we didn't specify the type to listen for in the print listener, we were sending the "Browser:SaveAs:Return" message twice, which ran into problems the second time that message handler was called.
Assignee: nobody → margaret.leibovic
Attachment #616786 - Flags: review?(mark.finkle)
Attachment #616786 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 14

5 years ago
Comment on attachment 616786 [details] [diff] [review]
patch

This only affects XUL fennec. Very low risk and fixes a serious problem with the "Save As PDF" feature.

This was a regression caused by bug 704691, which landed for Firefox 11, so this problem is currently in the released version of XUL fennec. Are we planning on releasing another version of XUL fennec? Should I uplift this to aurora/beta?
Attachment #616786 - Flags: approval-mozilla-central?
Comment on attachment 616786 [details] [diff] [review]
patch

[Approval Request Comment]
Regression: Yes
User impact if declined: Browser hangs
Testing completed (on m-c, etc.): -
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #616786 - Flags: approval-mozilla-central?
Attachment #616786 - Flags: approval-mozilla-central+
Attachment #616786 - Flags: approval-mozilla-beta?
Attachment #616786 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/eec7626671fa
Target Milestone: --- → Firefox 14
(Assignee)

Updated

5 years ago
Blocks: 704691
https://hg.mozilla.org/mozilla-central/rev/eec7626671fa
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 616786 [details] [diff] [review]
patch

[Triage Comment]
Approved for Aurora 13, but denying for Beta 12 since we're not shipping a release product off of that branch currently.
Attachment #616786 - Flags: approval-mozilla-beta?
Attachment #616786 - Flags: approval-mozilla-beta-
Attachment #616786 - Flags: approval-mozilla-aurora?
Attachment #616786 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 19

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/811e3bdaf749

I hope I did these status flags correctly.
status-firefox11: affected → wontfix
status-firefox12: affected → wontfix
status-firefox13: unaffected → fixed
tracking-firefox11: ? → ---
(Assignee)

Updated

5 years ago
Duplicate of this bug: 739053
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.