Fennec build on Win8 crashes in Windows DLL blocklist @ patched_LdrLoadDll

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

({crash})

Trunk
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Bug 694432 added a check in our LdrLoadDll hook for unexpected and unknown bytes passed in in place of the filePath parameter. We're currently bailing when the value is less than 1024, but I just ran into a case where the value was 2049. Clearly byte < 1024 isn't 100% reliable.
(Assignee)

Comment 1

7 years ago
I've reproduced this on a release build as well.
Summary: Debug Fennec build on Win8 crashes in Windows DLL blocklist @ patched_LdrLoadDll → Fennec build on Win8 crashes in Windows DLL blocklist @ patched_LdrLoadDll
(Assignee)

Updated

7 years ago
OS: Windows 7 → Windows 8
Can you provide a crash ID?
Severity: normal → critical
Keywords: crash
(Assignee)

Updated

7 years ago
Blocks: 732518
(Assignee)

Comment 3

7 years ago
Posted patch tmp fixSplinter Review

Comment 4

7 years ago
Comment on attachment 604274 [details] [diff] [review]
tmp fix

Can you please also check to see if the least significant bit of the pointer is set?
(Assignee)

Updated

7 years ago
Blocks: 737975
(Assignee)

Comment 5

7 years ago
(In reply to Ehsan Akhgari [:ehsan] from comment #4)
> Comment on attachment 604274 [details] [diff] [review]
> tmp fix
> 
> Can you please also check to see if the least significant bit of the pointer
> is set?

I've added an assertion to my test repo so next time I hit it I'll check. This doesn't happen on every run for some reason.

Comment 6

7 years ago
jimm says in bug 764039 I might be hitting this. If this is correct I would need help with this to make progress on the Windows 8 testing infrastructure.
I want to get the whole testing infrastructure ready in the next 7 weeks since I will be gone pretty much for the whole August.
(Assignee)

Updated

7 years ago
Assignee: nobody → jmathies
Is this still needed?
(Assignee)

Comment 8

7 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #7)
> Is this still needed?

I haven't seen it in a long time. Might have been fixed by MS. We can close it out for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
No longer blocks: 737975
(Assignee)

Updated

7 years ago
Blocks: elm-merge
You need to log in before you can comment on or make changes to this bug.