Closed Bug 764039 Opened 12 years ago Closed 12 years ago

Elm win8 builds are unsuable

Categories

(Core :: General, defect)

x86
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 703135

People

(Reporter: armenzg, Assigned: jimm)

References

Details

Attachments

(1 file)

Attached file Application event log
I have tried to use the win8 elm builds on a Windows 8 build but they don't start up.

Until that works I can't do any automation work.

For the record, the installer manages to add an icon to the Metro UI but neither through the desktop nor through the metro UI I can get the build started.

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/elm-win32-metro/1338909138/firefox-15.0a1.en-US.win32.installer.exe
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/elm-win32-metro/1338909138/firefox-15.0a1.en-US.win32.zip
Hey Armen, I get a crash in gkmedias.dll. Without symbols though I can't debug this since the stacks are worthless. Is there any way we can get the symbols off the machine that did the build or maybe setup the process of uploading symbols from these builds to our symbol server?
I had forgotten about this since I haven't seen it in a while, but I'm betting this is caused by bug 732589.
I made a comment on bug 732589.
Any chance that you could land the tmp fix on elm just to try it out?

This week I will be full steam and need help to keep things as green as possible.

On another note, something landed recently that is causing the builds to fail:
midlrt : error MIDL4034 : Failed to load a dependency file. Windows.winmd (Invalid path for /metadata_dir switch - "C:\Program Files (x86)\Windows Kits\8.0\References\CommonConfiguration\Neutral")
make[7]: *** [do_interfaces_gen] Error 194
make[6]: *** [export] Error 2
make[5]: *** [export] Error 2
make[4]: *** [export_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
program finished with exit code 2
elapsedTime=526.237000

https://tbpl.mozilla.org/?tree=Elm&jobname=metro

One of these two changesets caused it:
https://hg.mozilla.org/projects/elm/rev/2b6b69538e4a
https://hg.mozilla.org/projects/elm/rev/db49a15bf188
These build failures are a result of the builders using the older visual studio / SDK. How close are we to getting updated to the RC release?
I should have this done by today.
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #5)
> I should have this done by today.

As soon as we get those going I should be able to inject some debug code on elm to see if bug 732589 is the cause of our crashiness. Note this is just a guess on my part, it may be something else. Bug 764120 is still important for us so we can debug issues long term. With those symbols, we'll have valid stacks to look at.
I've disabled jemalloc for the time being on elm until we sort this out.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.