[skiplist] Add MOZ_Crash and MOZ_Assert to irrelevantSignatureRegEx

RESOLVED FIXED in 3

Status

Socorro
Infra
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mccr8, Assigned: laura)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Reporter)

Description

6 years ago
These are assertions, so we really want to know where they are being called from, so if you could please add them to the prefix list thing that would be great.
(Reporter)

Updated

6 years ago
Blocks: 716167
(Reporter)

Updated

6 years ago
Blocks: 717540

Updated

6 years ago
Depends on: 732462

Comment 1

6 years ago
Which skiplist is the right one: the prefix or the ignore one? This bug and bug 732462 are contradictory.

Updated

6 years ago
Blocks: 732346

Updated

6 years ago
Blocks: 731881
(Reporter)

Comment 2

6 years ago
I'm not sure.  CrashInJS appears to be in the prefix list (see signature CrashInJS | JS_AbortIfWrongThread), but JS_Assert appears to be in the ignore list (see signature CrashIfInvalidSlot).  On the other hand, MOZ_Assert calls MOZ_Crash, so it doesn't make sense for MOZ_Assert to be ignored and MOZ_Crash to be prefixed, as that will just make all asserts show up as crashes.  And if they are prefixed, you'll just get a ton of MOZ_Crash | MOZ_Assert | whatever, so maybe ignore makes sense for both of them.

Comment 3

6 years ago
(In reply to Andrew McCreight [:mccr8] from comment #2)
> I'm not sure.  CrashInJS appears to be in the prefix list (see signature
> CrashInJS | JS_AbortIfWrongThread), but JS_Assert appears to be in the
> ignore list (see signature CrashIfInvalidSlot). 
CrashInJS can be moved and JS_Assert is in no list. 
To know current skip lists, see https://github.com/mozilla/socorro/blob/master/scripts/config/processorconfig.py.dist
Blocks: 732243
No longer depends on: 732462
Summary: [skiplist] Add MOZ_Crash and MOZ_Assert to the prefixSignatureRegEx → [skiplist] Add MOZ_Crash and MOZ_Assert to the ignore skip list

Updated

6 years ago
Duplicate of this bug: 732462
FYI this looks like a typo: Blocks: 732243
No longer blocks: 732243

Updated

6 years ago
Blocks: 732343

Comment 6

6 years ago
OK, after talking with some developers, including Andrew, adding MOZ_Crash and MOZ_Assert to irrelevantSignatureRegEx is the way to go. Laura, can you do that?
Summary: [skiplist] Add MOZ_Crash and MOZ_Assert to the ignore skip list → [skiplist] Add MOZ_Crash and MOZ_Assert to irrelevantSignatureRegEx
(Assignee)

Comment 7

6 years ago
In https://github.com/lauraxt/socorro/commit/992415a5d00acdfc1d10f35ece59c2b1b5423499
Assignee: nobody → laura
Target Milestone: --- → 3

Comment 8

6 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/992415a5d00acdfc1d10f35ece59c2b1b5423499
Fixes bug 733235, add MOZ_Crash and MOZ_Assert to the irrelevant list

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Whiteboard: [qa-]

Updated

6 years ago
Blocks: 739027

Comment 9

6 years ago
Commit pushed to stage at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/950cbaa330a339a582607b1553af3a903d2553e0
Fixes bug 733235, add MOZ_Crash and MOZ_Assert to the irrelevant list

Comment 11

6 years ago
Commit pushed to v3-branch at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/950cbaa330a339a582607b1553af3a903d2553e0
Fixes bug 733235, add MOZ_Crash and MOZ_Assert to the irrelevant list
You need to log in before you can comment on or make changes to this bug.