Last Comment Bug 735219 - Cannot login to twitter with Instant messaging
: Cannot login to twitter with Instant messaging
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- major (vote)
: Thunderbird 13.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks: BigFiles 714733
  Show dependency treegraph
 
Reported: 2012-03-13 07:07 PDT by Tetsuharu OHZEKI [:tetsuharu] [UTC+9]
Modified: 2012-03-14 08:31 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed fix (3.35 KB, patch)
2012-03-13 09:05 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
Fix v2 (3.35 KB, patch)
2012-03-13 09:15 PDT, Florian Quèze [:florian] [:flo]
mozilla: review+
Details | Diff | Splinter Review

Description Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-13 07:07:08 PDT
Enviroment:
*Windows 7 (x64)
*http://hg.mozilla.org/mozilla-central/rev/1ca7a94573f2

STR:
1. Open "Add chat account".
2. Select Twitter and add Twitter account.

Result:
I cannot login to Twitter.
The status on the "Instant messaging status" window holds as
"Connection: Initiating...".

If I reconnect it after I disconnected once, 
The following error occurs:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXMLHttpRequest.open]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: resource:///modules/http.jsm :: doXHRequest :: line 13"  data: no]
Comment 1 Mike Conley (:mconley) - (Needinfo me!) 2012-03-13 07:17:44 PDT
I am also experiencing this bug with my local build on Linux.
Comment 2 Florian Quèze [:florian] [:flo] 2012-03-13 08:25:31 PDT
The cause of this problem is that we landed two different files called http.jsm the same day, as BigFiles forket de http.jsm module that was initially part of Instantbird.
The changes made to this module for BigFiles are incompatible :-(.
Comment 3 David :Bienvenu 2012-03-13 08:29:32 PDT
I also forked oauth.jsm (or did you not have that file?) Dropbox's use of oauth is different from twitter's, from what I could tell, so merging http and oath was not trivial for me, but since you wrote the code, it would probably be easier for you.
Comment 4 Florian Quèze [:florian] [:flo] 2012-03-13 08:31:22 PDT
(In reply to David :Bienvenu from comment #3)
> I also forked oauth.jsm (or did you not have that file?)

We don't, our oauth code is part of twitter.js
Comment 5 Ludovic Hirlimann [:Usul] 2012-03-13 08:34:23 PDT
(In reply to Florian Quèze from comment #4)
> (In reply to David :Bienvenu from comment #3)
> > I also forked oauth.jsm (or did you not have that file?)
> 
> We don't, our oauth code is part of twitter.js

Does this mean we have duplicated code ?
Comment 6 David :Bienvenu 2012-03-13 08:48:49 PDT
(In reply to Ludovic Hirlimann [:Usul] from comment #5)
 
> Does this mean we have duplicated code ?

I think you mean more duplicated code. Or more accurately, more forked code.
Comment 7 Florian Quèze [:florian] [:flo] 2012-03-13 09:05:35 PDT
Created attachment 605415 [details] [diff] [review]
Proposed fix

This is the least intrusive fix I've found to resolve this conflict. I have checked that Twitter worked after applying this patch; haven't tested BigFiles.
Comment 8 Florian Quèze [:florian] [:flo] 2012-03-13 09:15:30 PDT
Created attachment 605418 [details] [diff] [review]
Fix v2

Add parentheses as I got the operator priority wrong around the aMethod handling.
Comment 9 David :Bienvenu 2012-03-13 09:27:55 PDT
Comment on attachment 605418 [details] [diff] [review]
Fix v2

dropbox test works in mozmill and in thunderbird, thx!
Comment 10 Florian Quèze [:florian] [:flo] 2012-03-13 10:20:50 PDT
Thanks for the quick review! :)

http://hg.mozilla.org/comm-central/rev/3d368e502399
Comment 11 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-13 14:42:01 PDT
I tried tinderbox-build(http://hg.mozilla.org/mozilla-central/rev/b6627f28b7ec),
after STR, this error message was not shown on error console.

> Error: uncaught exception: [Exception... "Component returned failure code:
> 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXMLHttpRequest.open]"  nsresult:
> "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
> resource:///modules/http.jsm :: doXHRequest :: line 13"  data: no]

But Thunderbird did not show OAuth window for login to twitter immediately after adding twitter account...
(So if I restart Thunderbird once, Thunderbird shows it.)

Does this indicate that this bug is still opened?
Or Should I file an another bug?
Comment 12 Florian Quèze [:florian] [:flo] 2012-03-14 04:57:41 PDT
(In reply to OHZEKI Tetsuharu [:saneyuki_s] from comment #11)

> Thunderbird did not show OAuth window for login to twitter immediately
> after adding twitter account...
> (So if I restart Thunderbird once, Thunderbird shows it.)

I have tried but couldn't reproduce the issue (someone else noticed the same problem though), so there's probably something missing in the steps to reproduce.

> Does this indicate that this bug is still opened?

No, as Twitter is no longer completely unusable.

> Or Should I file an another bug?

Yes please, if possible with more detailed steps to reproduce this specific issue.
Comment 13 Tetsuharu OHZEKI [:tetsuharu] [UTC+9] 2012-03-14 08:31:29 PDT
(In reply to Florian Quèze from comment #12)
> Yes please, if possible with more detailed steps to reproduce this specific
> issue.

I have filed bug 735688.

Note You need to log in before you can comment on or make changes to this bug.