Qt QWS embedding (without-x)

RESOLVED FIXED in mozilla14

Status

Core Graveyard
Widget: Qt
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: prabindh, Assigned: romaxa)

Tracking

2.0 Branch
mozilla14
ARM
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 605686 [details]
patchset_for_bugzilla.tar.gz contains set of patches including config changes that will allow QWS compilation

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build ID: 20120209214325

Steps to reproduce:

Build without-x configuration with a Qt-embedded-QWS target that does not have X11 support (ie, framebuffer based system), and does not use a Linaro filesystem.  The bug relates to below issues already tackled by Oleg Romashin (thanks!), but does not fully resolve no-x compilation issues on non-Linaro builds.

https://bugzilla.mozilla.org/show_bug.cgi?id=734678
https://bugzilla.mozilla.org/show_bug.cgi?id=734667


Actual results:

Compilation errors in lot of places due to

a) Assumption that WIDGET_QT directly maps to X11

b) Assumption that WIDGET_QT maps to MAEMO and to X11

Hence compilation errors.


Expected results:

No compilation errors. 

I am attaching a patchset that adds a separate cairo-qt-qws configuration, and fixes these issues.
(Reporter)

Comment 1

5 years ago
Patchset also available at,

https://github.com/prabindh/mozilla-embedded/tree/master/patches/13Mar

Right now - I am stuck at libxul.so linking stage due to gcc4.3.3 issues. Planning to move to gcc4.5 and will update.

Also refer to https://bugzilla.mozilla.org/show_bug.cgi?id=735594 for a xpconnect bug found while trying to compile without jsd.
(Reporter)

Updated

5 years ago
Hardware: x86 → ARM
(Reporter)

Updated

5 years ago
(Assignee)

Comment 2

5 years ago
part of that patch queue, located in 
bug 703155 (significant Qt port rework and make it compilable with Qt5 environment.) patches with qt5_ prefix

For QWS specific backend we need this patch:
http://hg.mozilla.org/users/romaxa_gmail.com/embedipc_queue/file/7872d7707032/qt_qws_build.diff
and allow to compile EGL provider for Qt/non-maemo build
http://hg.mozilla.org/users/romaxa_gmail.com/embedipc_queue/file/7872d7707032/webgl_glx_fix.diff
(Assignee)

Comment 3

5 years ago
Created attachment 605692 [details] [diff] [review]
Added check for MOZ_X11 before using X11 Window types
Assignee: nobody → romaxa
Attachment #605686 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #605692 - Flags: review?(karlt)
(Assignee)

Updated

5 years ago
Depends on: 703155
(Assignee)

Updated

5 years ago
Depends on: 735602
(Assignee)

Comment 4

5 years ago
Comment on attachment 605686 [details]
patchset_for_bugzilla.tar.gz contains set of patches including config changes that will allow QWS compilation

Oh, did not check patch queue correctly.
But here is some comments about patch queue...
I'm not sure we should create one more cairo-qt-qws configure option, because:
1) Qt5 - is going to be mostly qws by default (no direct X usage)
2) Qt has internal define Q_WS_X11, which could be detected and ifdefed properly.

JSDEBUGGER - need to be posted into separate bug.
Attachment #605686 - Attachment is obsolete: false
Attachment #605692 - Flags: review?(karlt) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
http://hg.mozilla.org/integration/mozilla-inbound/rev/67146677dfa5
Keywords: checkin-needed
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/67146677dfa5
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.