Closed Bug 735622 Opened 11 years ago Closed 3 years ago

menu bar should be on top - not inside tab

Categories

(Thunderbird :: Toolbars and Tabs, defect)

All
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mkmelin, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #732803 +++

The Menu Bar needs to be on top of the tabs - like it is on firefox if you hit alt. IMO it looks very bad below.

Per bug 732803 comment 2 this was because otherwise "menu bar is in the transparent area and then the reactions would be it isn't readable as you can find on TB <11." 

I hadn't had any problems with this for tb10 (on win7), and since firefox can, so can we :)
Duplicate of this bug: 736094
I completely agree with Magnus.

At least give us a "view" option to put the tabs back below the main menu bar, where they always have been and which worked great and logical.

Tabs above the menu bar is not logical neither in Firefox nor in Thunderbird.
Summary: menu bar need to be on top - not inside tab → menu bar should to be on top - not inside tab
Summary: menu bar should to be on top - not inside tab → menu bar should be on top - not inside tab
This is important to me.  The first thing I did after updating Thunderbird to 11.0 was look for a way to move the menu bar back above the tab bar.  Because Firefox provides a "Tabs on top" toggle, I initially that my problem was described by bug 724213.

After reading though the comments there, I realized that I had not even noticed that the toolbar had been moved inside the Inbox tab.  I have no problem with the new toolbar placement, only with the placement of the menu bar (on Windows 7).  Thus this bug (#735622) more accurately describes my issue.

Because the menu bar provides access to global options and the ability to open and close tabs, it makes little sense for it to be visually placed in the context of a single tab.  Additionally, this placement conflicts with the user's expectation that the menu bar be located in the top left.

I didn't notice issues reading the menu bar on previous versions of Thunderbird.  However, I notice that Firefox seems to place a background with lower transparency immediately around the menu bar items, which fits in well with Aero and provides good contrast.



Bug 724213 comment 36 suggests an extension as a workaround, which moves both the menu bar and toolbar above the tab bar.  A simpler workaround via userChrome.css is suggested here: https://getsatisfaction.com/mozilla_messaging/topics/anyway_to_put_tabs_under_the_main_menu_bar_in_new_version

#tabs-toolbar { -moz-box-ordinal-group: 20 !important; }
#mail-toolbar-menubar2 { -moz-box-ordinal-group: 10 !important; }
I've come up with a slightly prettier version of the userChrome.css workaround, based off of Firefox's styling.  It moves the menu bar above the tabs, and puts a semi-transparent background behind the menu items to make them more readable.  I've only tested it on Windows 7 with the default theme.  I notice that when the window doesn't have focus, the menu font color dims, blending into the background. Other than that this seems to work fine.

Add to "chrome\userChrome.css" in your Thunderbird profile directory:
-----
#tabs-toolbar { -moz-box-ordinal-group: 20 !important;}
#mail-toolbar-menubar2 {
  -moz-box-ordinal-group: 10 !important; 
  background: none !important;  
}
#menubar-items  {
  background-color: rgba(255,255,255,0.5);
  border-top-left-radius: 4px;
  border-top-right-radius: 4px;
  border-bottom-right-radius: 4px;
  border-bottom-left-radius: 4px;
}
-----
(In reply to JacksonJoshuaP from comment #3)
> 
> Because the menu bar provides access to global options and the ability to
> open and close tabs, it makes little sense for it to be visually placed in
> the context of a single tab.  Additionally, this placement conflicts with
> the user's expectation that the menu bar be located in the top left.

FWIW, this might change with compose in a tab -- we might switch to customizing menus depending on the tab.
(In reply to Siddharth Agarwal [:sid0] from comment #5)
> FWIW, this might change with compose in a tab -- we might switch to
> customizing menus depending on the tab.

And for those of us who dislike (I'm trying to be kind, or I would use a much stronger word here) tabs in Thunderbird? Please tell me you guys will give us a choice of composing new messages in a new window rather than in a tab? Even most Webmail clients have this as an option.

Is there some place where this is being actively discussed, where users can provide input to the process?
(In reply to Charles from comment #6)
> give us a choice of composing new messages in a new window rather than in a tab?

That's rather a discussion for bug 449299 once that bug gets to the stage where actual work is done, but given recent tendencies in Thunderbird to implement it one specific way and leave it up to add-on contributions or even userChrome.css hacks to provide the "configuration option" this is definitely a valid concern.
(In reply to Siddharth Agarwal [:sid0] from comment #5)
 
> FWIW, this might change with compose in a tab -- we might switch to
> customizing menus depending on the tab.

I understand that this is a possibility, and I'm open to it, depending on how it is done.  However, I think the File, Edit, Tools, and Help menus should probably left as global (leaving Go, Message, [Events and Tasks] as possibly contextual).

At the moment, it is my understanding that the menu bar is only moved on Windows 7 (Aero), and that this was done to improve readability.  I think readability on Aero should be addressed in a different way for now (ie semi-transparent background-color like Firefox uses), until contextual menus are implemented and the menu bar changes, moves, or goes away for everyone.
(In reply to Charles from comment #6)
> (In reply to Siddharth Agarwal [:sid0] from comment #5)
> > FWIW, this might change with compose in a tab -- we might switch to
> > customizing menus depending on the tab.
> 
> And for those of us who dislike (I'm trying to be kind, or I would use a
> much stronger word here) tabs in Thunderbird? Please tell me you guys will
> give us a choice of composing new messages in a new window rather than in a
> tab? Even most Webmail clients have this as an option.

Yes, I'm pretty sure that isn't going to change, especially since we let people read mail inside a new tab.

> 
> Is there some place where this is being actively discussed, where users can
> provide input to the process?

No, not yet (outside of an informal discussion between bwinton and me about UX), since this isn't being actively worked on. It's been proposed as a project for this Google Summer of Code though.

Anyway, off-topic.

(In reply to JacksonJoshuaP from comment #8)
> I understand that this is a possibility, and I'm open to it, depending on
> how it is done.  However, I think the File, Edit, Tools, and Help menus
> should probably left as global (leaving Go, Message, [Events and Tasks] as
> possibly contextual).

Yes, that's pretty much what we agreed on in our discussion.
> Yes, I'm pretty sure that isn't going to change, especially since we let people read mail inside a new tab.

Er, I mean a new window.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.