Last Comment Bug 735642 - We need a Twitter OAuth key for Thunderbird (User-agent/UA name is Instantbird)
: We need a Twitter OAuth key for Thunderbird (User-agent/UA name is Instantbird)
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
: 736004 (view as bug list)
Depends on:
Blocks: 714733
  Show dependency treegraph
 
Reported: 2012-03-14 06:03 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-07-27 13:46 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
fixed


Attachments
Patch (1.65 KB, patch)
2012-07-18 09:40 PDT, Florian Quèze [:florian] [:flo]
clokep: review+
bwinton: approval‑comm‑aurora+
bwinton: approval‑comm‑beta+
Details | Diff | Review
Screenshot of the OAuth dialog when this key is used (173.30 KB, image/png)
2012-07-18 09:44 PDT, Florian Quèze [:florian] [:flo]
bwinton: ui‑review+
Details

Description Florian Quèze [:florian] [:flo] 2012-03-14 06:03:24 PDT
(currently the Twitter accounts use OAuth keys from Instantbird)
Comment 1 Ludovic Hirlimann [:Usul] 2012-03-15 02:17:31 PDT
*** Bug 736004 has been marked as a duplicate of this bug. ***
Comment 2 Blake Winton (:bwinton) (:☕️) 2012-05-29 08:17:56 PDT
I heard somewhere that JB was the person making this happen…
Comment 3 Jb Piacentino 2012-06-25 06:10:22 PDT
What does it specifically take ? Is it just creating a key ?
Comment 4 Florian Quèze [:florian] [:flo] 2012-06-25 06:17:00 PDT
(In reply to Jb Piacentino from comment #3)
> What does it specifically take ? Is it just creating a key ?

So 2 things need to happen to resolve this bug:
- We need a Thunderbird key. I expected you (Jb) to resolve this part as, I think, the twitter folks have answered our/your questions related to this.

- Once I have the key to use for Thunderbird, I will need to do a simple patch so that Instantbird and Thunderbird can use different keys but still share the same twitter code. (My plan for that is to put the key in the mail/app/profile/all-thunderbird.js default preference file for Thunderbird, and the equivalent file for Instantbird, instead of hardcoding the key in twitter.js.)
Comment 5 Florian Quèze [:florian] [:flo] 2012-07-18 09:40:08 PDT
Created attachment 643419 [details] [diff] [review]
Patch
Comment 6 Patrick Cloke [:clokep] 2012-07-18 09:44:40 PDT
Comment on attachment 643419 [details] [diff] [review]
Patch

Looks good. Let's not forget to use a the Instantbird key when applying this to Instantbird! :)
Comment 7 Florian Quèze [:florian] [:flo] 2012-07-18 09:44:40 PDT
Created attachment 643420 [details]
Screenshot of the OAuth dialog when this key is used

And there is a test tweet from the "Thunderbird Chat" application: https://twitter.com/testib/status/225626326386745344
You can see the application name links to "http://www.mozilla.org/thunderbird/"
Comment 8 Blake Winton (:bwinton) (:☕️) 2012-07-18 09:47:29 PDT
Comment on attachment 643420 [details]
Screenshot of the OAuth dialog when this key is used

Awesome!  ui-r=me!
Comment 9 Jb Piacentino 2012-07-19 05:41:07 PDT
See ! That was not complicated.. I wonder why it took soooo long ;-) Must have been me :D

Thanks !
Comment 10 Blake Winton (:bwinton) (:☕️) 2012-07-23 11:43:23 PDT
Comment on attachment 643419 [details] [diff] [review]
Patch

Yeah, I really think we want to have this on aurora/beta.

Note You need to log in before you can comment on or make changes to this bug.