Character input not displayed in input box

RESOLVED DUPLICATE of bug 748048

Status

()

Firefox for Android
General
P3
normal
RESOLVED DUPLICATE of bug 748048
6 years ago
6 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13 affected, firefox14 affected, blocking-fennec1.0 +)

Details

(Whiteboard: [website-compatibilty][GFX][QA!][VKB], URL)

(Reporter)

Description

6 years ago
On load of the bug URL [1], keyboard focus is placed into the 'Origin Account E-Mail' field. Typing anything into this field is seemingly tossed out as character input is not displayed.

[1] http://battlelog.battlefield.com

Tested via a Samsung Galaxy Nexus (Android 4.0.2) and was able to reproduce this; alongside testing on a Samsung Galaxy SII. 

On an HTC Nexus One (Android 2.3.4) while character input was visible; it was drawn at a cost of significant slowdown and delay of 1 -- 2 seconds.

Also tested via the Android stock browser and Google Chrome Beta and could not reproduce this issue on all three devices.

Is this a Galaxy Nexus (ICS) issue going on here?

--
Nightly (03/19)
Mozilla/5.0 (Android; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0a1
Martijn - Can you try to get a reduced testcase of this?
(Reporter)

Comment 2

6 years ago
I just re-tested this and all inputted text is revealed if you pinch-zoom in. This sounds like zooming/GL-Layers issue perhaps.
Component: IME → General
QA Contact: ime → general
Whiteboard: [website-compatibilty] → [website-compatibilty][GFX]
(Reporter)

Updated

6 years ago
Version: unspecified → Trunk
Keywords: qawanted
Almost certainly depends on bug 732016; it's an input field focused on load. Will re-evaluate once that is fixed.
Depends on: 732016
blocking-fennec1.0: ? → +
Priority: -- → P3
Not sure if I'm able to reproduce what Aaron's seeing.  I was able to type just fine on the Galaxy Nexus w/ today's nightly 3/20/12
I can see it now.  Turns out that the form field completion stopped it from entering any characters.  It looks more or less like a form field completion issue?
Slightly reduce test case is located : http://people.mozilla.com/~nhirata/html_tp/reduce_bug737008.html ; clicking on the field ends up removing all the painting, though...
I can always reproduce this issue by performing the following steps:

1. Go to http://goo.gl/vi7z6
2. Tap on username text field
3. Insert a bunch of characters

Expected result:
Input data is visible.

Actual result:
Text field remains blank until a pan or a zoom is performed.

Note: This issue is reproducible both in portrait and landscape mode.

--
Firefox 14.0a1 (2012-03-25)
Devices: Samsung Galaxy S (2.2), Motorola Droid 2 (2.3.3)
Keywords: qawanted
Whiteboard: [website-compatibilty][GFX] → [website-compatibilty][GFX][QA!][VKB]
(Reporter)

Updated

6 years ago
status-firefox13: --- → affected
Clicking into a text field blanks out the screen now.  It's happening even on the simpliest of text boxes.
Depends on: 732089, 732971
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735864
This bug is a dupe of bug 748048, not bug 735864. I can still repro this bug, but not 735864, so they are different.
Duplicate of bug: 748048
You need to log in before you can comment on or make changes to this bug.