Catch vidly upload errors and notify users

VERIFIED FIXED in 1.3

Status

Websites
Firefox Flicks
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mkelly, Assigned: mkelly)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
The site should detect when vid.ly sends an error notification and mark a video as having an error during upload, along with notifying the user that their upload has failed.

chelsea: More copy! Becaue bug 737136 is handling the youtube/vimeo link issue, I think this email should be a bit more generic and mention common issues beyond just linking directly to a youtube page. Other issues I can think of:

- Submitting a video format that vidly can't handle (suggest a known-working format?)

- Submitting a link that vidly can't reach (other bug should handle this, but just in case?)
Copy!

There was an error in processing your video. Please upload your video from a personal server or tool like Dropbox. If you are using Dropbox, please make sure to set your video to public. 

If you continue to have problems uploading, please contact us at firefoxflicks@mozilla.org

Thanks!
-The Firefox Flicks Team
(Assignee)

Comment 2

6 years ago
And the email subject?
There was an error uploading your flick
Sorry, 

There was an error uploading your Firefox Flick
(Assignee)

Comment 5

6 years ago
Code is mostly done, but I'm moving this to 1.3 because it contains string changes and didn't make the string freeze from yesterday. It's not a terribly likely scenario anyway, so there's little risk to the live site from putting this off for another release.
Target Milestone: 1.2 → 1.3
(Assignee)

Updated

6 years ago
Duplicate of this bug: 737079

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Found bug 737660 while testing this.
(Assignee)

Comment 9

6 years ago
Use http://people.mozilla.org/~mkelly/fakevideo.wmv to test this; it's a fake wmv file that will pass the flicks-side tests.
Verified FIXED with the testcase/file in comment 9.
Status: RESOLVED → VERIFIED
Created attachment 614548 [details]
Post-fix screenshot
You need to log in before you can comment on or make changes to this bug.