Closed Bug 737801 Opened 10 years ago Closed 10 years ago

Shaking and flickering on dynamic pages

Categories

(Firefox for Android Graveyard :: General, defect)

14 Branch
ARM
Android
defect
Not set
normal

Tracking

(blocking-fennec1.0 +)

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: valentin, Assigned: kats)

References

Details

(Whiteboard: [gfx])

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Browsed to plus.google.com/ -> redirected to m.google.com/...
Clicked some of the links


Actual results:

Images started shaking and flickering while transitions took place. Flickering seemed to lessen as you browsed.
Hello,

Which Android device, Android version and Fennec build were you testing on?
Samsung Galaxy S2
Android version: 4.0.3
Fennec version: 14.0a1 - 2012-03-20
OS: Windows XP → Android
Hardware: x86 → ARM
I have uploaded a movie of the bug.
The flickering starts 20 seconds into the movie.
https://picasaweb.google.com/lh/photo/IlENENepFPyhnun-vdM7CZG5gDMRPWRAkTl9M47DkcQ?feat=directlink
Thanks Valetin; it was most noticeable near the end of your video. This looks OMTC/layers related; cc'ing couple folks to see if it's a dupe of a known issue or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: omtc
blocking-fennec1.0: --- → ?
Just based on the video I feel this isn't really layers/omtc related. It seems more like tapping on the photos link had a really laggy response, maybe it was doing a bunch of XHR requests and waiting for responses before rendering? And then all the queued-up clicks on the photos link all got processed in quick succession causing the flickering issue. The fact that you were able to pan and see the page while waiting for the photos thing to come up seems to support this theory, since if it was blocked on something with gecko drawing/compositing then you wouldn't have been able to do that.
Assignee: nobody → bugmail.mozilla
blocking-fennec1.0: ? → +
Duplicate of this bug: 739634
Whiteboard: [gfx]
It would be good if we can get some steps to reproduce here.
Keywords: qawanted
I haven't been able to reproduce this, but I wasn't redirected to http://m.google.com either when I did go to http://plus.google.com .

Valentin, do you happen to have an idea why you're getting redirected to m.google.com?

Can you still reproduce this in current trunk build, btw?
I wonder if it has to do with the version of the Android OS?
The bug can still be reproduced on today's build. 
I need to mention that the flickering diminishes the more you browse. 
Also, if I click on a link, I need to scroll the page for the screen to update to the new webpage. I think they are related.
I need to clarify: By link I mean the top sections on g+: About, Posts, Photos 
It think it has something to do with the page changing the content with javascript and not by loading a new page.
Nightly 14.0a1 (2012-04-16) 20120416030739
Devices: Samusung Galaxy SII (Android 2.3.4)
         Samsung Nexus (Android 4.0.2)

I cannot reproduce on plus.google.com this, but I was not redirected to m.google.com.


Trying to reproduce this on other pages I noticed a similar behavior on www.m.220.ro

Steps: 
Open this page and start scrolling down fast

Actual result:
The content will start to flicker when reaching to the bottom of the page

This is reproducible on Galaxy SII. On Nexus works as expected.
(In reply to Valentin Gosu from comment #11)
> I need to clarify: By link I mean the top sections on g+: About, Posts,
> Photos 
> It think it has something to do with the page changing the content with
> javascript and not by loading a new page.

This sounds like it could be related to bug 728983.
removing qawanted keyword per comment 10 and 12
Keywords: qawanted
I also saw the content flickering on m.220.ro.

I also saw flickering when going from m.google.com and typing in plus.google.com

STR: 
1. go to m.google.com
2. go to plus.google.com

Expected: m.google.com does not flicker when transitioning
Actual: m.google.com flickers before transitioning

I think m.220.ro might be a separate issues:
1. go to m.220.ro and wait for load

Expected: during load, m.220.ro does not flicker
Actual: towards the end of the load, m.220.ro flickers
I think there's a bunch of different issues being reported in this bug, and some of them are probably bug 746185.
The issues on google+ seem to be fixed in today's build of fennec.
Can anyone still reproduce?
Keywords: qawanted
I can't reproduce any of the issues described in this bug. The only strange thing I saw was misplaced position:absolute items from the google ads on m.220.ro, which I'll file a separate but for. I'm going to mark this bug closed, please re-open if anybody is still seeing any of these issues.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
no reports of reproducing in the last day from qa.
Keywords: qawanted
No longer blocks: omtc
Blocks: omtc
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.