With unified folders view, message list focus unexpectedly "jumps" away from selected msg, sometimes leaving msg preview pane blank

UNCONFIRMED
Unassigned

Status

Thunderbird
Folder and Message Lists
UNCONFIRMED
6 years ago
10 months ago

People

(Reporter: Dick, Unassigned)

Tracking

11 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Select an email to read in the upper preview pane


Actual results:

The majority of the time the lower preview pane (the email contents) display.  However, sometimes, the upper preview pane jumps from the selection I've made (usually backwards) to a completely new email selection or no email selection at all.  In the later case, the lower preview pane goes blank (which I suppose it does because it thinks I haven't chosen an email to preview yet).  In any case, Thunderbird loses track of the specific email I've selected, jumps to another place.  This started happening (I think) in ver 10.x, and is now still present in 11.0.


Expected results:

The upper pane should stay on the selection I've made and display the email's contents on the lower pane. It should NEVER jump away from the selection I've made.  This is very frustrating since I then have to find out (again) where I was in my list of inbox emails.

Comment 1

6 years ago
(In reply to Dick from comment #0)
This is not normal. In my daily use of Thunderbird I don't see this issue. Try to run Thunderbird without add-ons for a period of time (say 1 week) and check if this appears again.
(Reporter)

Comment 2

6 years ago
OK, will do.  If I don't get back to you (in case I forget) send me a notice, please. Just to be clear, under Tools there are "add-ons" and "Extensions".  When I go into "add-ons", it doesn't list what "add-ons" I might have, only what are available.  If I go into "extensions" I can see the 5 extensions I presently have.  I disabled them all. I assume that you really meant to disable extensions, not add-ons.
(Reporter)

Comment 3

6 years ago
After I disabled the extensions the other day, I just had my inbox "jump" this morning, I had the unified in-box highlighted and was looking in the upper pane at the unified inbox messages.  I single clicked on one of the messages (to look at the contents on the lower pane) and IMMEDIATELY the preview pane "jumped" or changed and my message in the upper preview pane was gone.  When I clicked on the specific inbox, there was the message I was starting to look at.  Hence this "jumping" phenomena might actually be related to the other bug I put into the system the same day, where the unified inbox loses its ability to properly unify all the in-boxes.

Comment 4

6 years ago
(In reply to Dick from comment #3)
> starting to look at.  Hence this "jumping" phenomena might actually be
> related to the other bug I put into the system the same day, where the
> unified inbox loses its ability to properly unify all the in-boxes.

What is the other bug number?
(Reporter)

Comment 5

6 years ago
[Bug 728314] "InBox" does not show all emails in separate accounts
Does this happens when you use unread filters from the quick filter bar ?
(Reporter)

Comment 7

6 years ago
I have never used filters at all.  There are no filters in the system.  However, I did notice that the quick-filters tab was high-lighted even though I am not using it.
(Reporter)

Comment 8

6 years ago
Hello- Still frustrated. I've got version 12.0.1 now and it is still not fixed.  It jumps several times per day. It isn't a function, I believe, of the unified inbox, since the highlighted email can either be in the unified inbox or in a single inbox; doesn't matter.  One second you are previewing an email and the next, the preview box goes blank and you look up at the email list and have no idea where you are.  I then usually have to try to get my bearings and re-scroll down to where I was working and find the email again I was reading, highlight it and look at it again in the preview box.  This bug is so frustrating, I just want to delete the software and go to Microsoft Outlook!!  Please fix it quickly.  Thanks.

PS- I had also entered a bug into the system some time ago that the unified inbox doesn't show all the emails as a summation of each account.  As I mentioned in March, I suspect that this, too, might be involved in this problem.  I think I've seen instances that after the preview box goes blank and I go back to where the email was, I can't find the email in the unified box. I then switch over to the single in-box and there is the email.  I then switch over to the unified box and there is the email.  Hence, I suspect that both of these problems are due to some background re-indexing going on (done improperly) that then becomes visible in this "jumping" phenomena to the user.
(Reporter)

Comment 9

6 years ago
Just downloaded today version 13.0. Problems as described above still exist.

Comment 10

6 years ago
wfm on TB12 / WinXP.

Dick (reporter), are you using laptop with touchpad?
POP or IMAP?
Summary: Inbox upper peview pane selection "jumps" and sometimes leaves lower pane blank → With unified folders view, message list focus unexpectedly "jumps" away from selected msg, sometimes leaving msg preview pane blank
(Reporter)

Comment 11

6 years ago
Answer- no touchpad or laptop.  Dell desktop.  POP.

Dick

Comment 12

6 years ago
I've seen both symptoms (no message selected, and jump to random message) when I check for new mail. I only check for new mail manually, usually with shift-F5.

I've also observed that compacting results in no selected message. Thunderbird prompts me before compacting.

Thunderbird 13.0.1 (and many previous versions) on Ubuntu 12.04. I don't use the unified folder fire, I usually use the unread folders view.
(Reporter)

Comment 13

3 years ago
OK, so how many MORE years do I have to wait for you folks to fix this?  I live with this problem EVERY DAY.

Updated

2 years ago
Duplicate of this bug: 922809

Comment 15

2 years ago
(In reply to Dick from comment #13)
> OK, so how many MORE years do I have to wait for you folks to fix this?  I
> live with this problem EVERY DAY.

Does problem reduce in frequency if you disable automatic compact?
Flags: needinfo?(rcblumen)
(Reporter)

Comment 16

2 years ago
Have never unchecked auto compaction. An added thought. I believe that auto compaction should be triggered, but not acted upon, until there has been no activity or use of the email for a while (say 5 minutes). That way, it won't interfere while I am viewing and/or deleting email. Any keystroke or mouse button hit will reset the compact timer to wait 5 minutes before compacting.

Updated

10 months ago
Flags: needinfo?(rcblumen)
(Reporter)

Comment 17

10 months ago
So here we are 5 years later and I am living with this problem EVERY DAY; that is, this appears to be possibly related to auto compaction. Every day I am looking at the preview pane, and start hitting delete on all the junk mail that comes in.  Within seconds, the position in the pane where I am working changes, the software goes into a compaction process and I've lost my cursor spot.  I then have to wait until it stops moving around and then I have to scroll back to where I was working.  VERY FRUSTRATING.  I don't know why the software can't wait to compact until there is no evidence that I am actively working in the email program; that I've gone on to do something else. BTW - I've always updated my Windows 7 Pro operating system and Thunderbird when notified.
You need to log in before you can comment on or make changes to this bug.