Quotes don't trigger an exact phrase search on ES

REOPENED
Unassigned

Status

support.mozilla.org
Search
P2
normal
REOPENED
6 years ago
4 months ago

People

(Reporter: mkaply, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I want to find all references to my add-on, so I'm searching on:

"Personas Interactive" in quotes

But my results include persona and personas and more.

Putting a search in quotes should search on that phrase and that phrase exactly.
Assignee: nobody → willkg
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Unable to search using a phrase → Quotes don't trigger an exact phrase search on ES
If we switch from a text query to a query_string, then we get the full power of the query parser. I opened up issue 27 in elasticutils to implement support for query_string.

https://github.com/mozilla/elasticutils/issues/27
https://github.com/mozilla/elasticutils/issues/27#issuecomment-6252347

"""
I've already opened a bug in bugzilla. It got turned into this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=738789

Very simply, it's the inability to search on words or phrases. I would like to find any issues related to our Personas Interactive product.

Try searching on "Personas Interactive" on SUMO and compare that to searching site:mozilla.org "Personas Interactive" on google

Or "Brand Thunder"

The inability to search on phrases makes the search effectively useless for anything but single word searches.

Brand Thunder, brand+Thunder and "Brand Thunder" are three different searches. SUMO treats them all the same

Also, compare the results for "Brand Thunder" and "Brand" - they are just about the same search. The second term isn't being used much at all.

Another good term to try is "Yahoo toolbar" and compare SUMO and google site search.
"""
This originally got pushed off, then I dropped it from my list of things to do in the near future. The reason is that users using SUMO search aren't trying to do phrase searches. So instead of working on this, I've been working on other search-related issues which will be more helpful to a larger number of SUMO users.

I did fiddle with implementing query_search in elasticutils and adding support for SUMO, but it creates a series of problems that didn't have obvious answers. One of them being what to do if the search query is malformed. ES kicks up a parsing error. It's non-trivial to redo the query so that it's not a query_string query and try again.

Anyhow, that's why work on this has stalled.
(Reporter)

Comment 4

6 years ago
> The reason is that users using SUMO search aren't trying to do phrase searches.

It's not just phrase searches, though. Any two word searches produce inconsistent results.

When you search on yahoo toolbar, the first search that contains yahoo and toolbar in the title is number 11.

As a matter of fact, if you go through the first 10 entries, you'll find that there is not a mention of yahoo at all on any of the results pages. Only toolbar.

Yet a search on Google:

https://www.google.com/#sclient=psy-ab&hl=en&q=site:support.mozilla.org+yahoo+toolbar

And you'll see that are many more articles that mention yahoo toolbar in the title that should be prioritized higher (and it's not just a date thing - entry number three from Google is only three weeks old).


Maybe that's the core problem here.

Because SUMO displays so many articles that are irrelevant to the search, you don't even see the community questions at the bottom.

Is there some way to tell SUMO that I don't want to search articles, I just want to search questions?
(In reply to Michael Kaply (mkaply) from comment #4)
> > The reason is that users using SUMO search aren't trying to do phrase searches.
> 
> It's not just phrase searches, though. Any two word searches produce
> inconsistent results.

You wrote this bug about "unable to search using a phrase". If you have other problems, please open up additional bugs for them.


> Because SUMO displays so many articles that are irrelevant to the search,
> you don't even see the community questions at the bottom.

That's the thing I've been working on over the last couple of months: reworking how all the bits work to have unified search results rather than the bucketed search results we have where kb articles come first then support forum threads.


> Is there some way to tell SUMO that I don't want to search articles, I just
> want to search questions?

There's an Advanced Search link in the navigation on the right side. If you click on that, there's a Support Questions tab. Using that will only search questions.
support for query_string was implemented on ES. And the search for yahoo toolbar displays the expected results now. Closing this based those observations. Reopen please, if I missed anything.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
We never switched to query_string because there were too many issues. I did add an additional text_phrase query in addition to the existing text query, but that's it.
Thanks for the info, Will. It seems like we fixed the actual problem people had with search, namely that "yahoo toolbar" would produce the same results as just searching for "yahoo". That is clearly not the case anymore.
(Reporter)

Comment 9

4 years ago
It's still not working for me.

A search for "personas interactive" doesn't yield a single result.

I should be seeing these:

http://www.google.com/#output=search&sclient=psy-ab&q=site:support.mozilla.org+%22personas+interactive%22&oq=site:support.mozilla.org+%22personas+interactive%22&gs_l=hp.3...881.11265.0.11424.67.55.10.0.0.0.152.3535.48j7.55.0....0...1c.1.23.psy-ab..61.6.398.6j0zvHbeIXU&pbx=1&bav=on.2,or.r_qf.&bvm=bv.50165853,d.b2I&fp=6aa267eef08cee78&biw=1221&bih=708

personas+interactive doesn't work either.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Mike Kaply (:mkaply) from comment #9)
> It's still not working for me.
> 
> A search for "personas interactive" doesn't yield a single result.

I get 242 results. I don't understand how you get no results at all. Can you try that again?


> I should be seeing these:
> 
> http://www.google.com/#output=search&sclient=psy-ab&q=site:support.mozilla.
> org+%22personas+interactive%22&oq=site:support.mozilla.
> org+%22personas+interactive%22&gs_l=hp.3...881.11265.0.11424.67.55.10.0.0.0.
> 152.3535.48j7.55.0....0...1c.1.23.psy-ab..61.6.398.6j0zvHbeIXU&pbx=1&bav=on.
> 2,or.r_qf.&bvm=bv.50165853,d.b2I&fp=6aa267eef08cee78&biw=1221&bih=708

We'll never have the same results as Google for two reasons:

1. We have a different scoring system that ranks the kb results higher than questions results generally speaking.

2. There are a bunch of things we don't search in a normal search. For example, when you search from the en-US locale, you won't get results from other locales and you won't get question results that are older than 180 days. You do when you search in Google.

I'm not sure that proves or disproves whether this bug is fixed or not.


> personas+interactive doesn't work either.

This works for me, too. I get 242 results.
(Reporter)

Comment 11

4 years ago
Sorry, I didn't mean no results, I meant I don't get any results in the first few pages that actually contain the phrase "personas interactive".

Lots of things that contain "persona" and "personas"

I got to page 6 before I gave up. None of them reference "personas interactive" at all.

I still don't understand why your search is searching for "persona" and personas" when I explicitly said "personas interactive". It's a phrase search.
Just to clarify, this is SUMO search--not *my* search.

As far as I understand it, this use case comes up pretty rarely and mostly from contributors. I suspect that's why it's not built the way you're expecting. Kadir can talk more to that.

I'm game for implementing a light-weight search string parser like I did in Input that handles phrases better. I did the work in bug #874286.
Unassigning it from me.
Assignee: willkg → nobody
I think this will be solved with bug 1100394
Depends on: 1100394

Comment 15

3 years ago
 (In reply to Ricky Rosario [:rrosario, :r1cky] from comment #14)
> I think this will be solved with bug 1100394

Bug 1100394 was implemented for Advanced Search. 

See also Bug 1010975 comment 0
> 3. should we use simple-query-string for both basic and advanced search?
(In reply to Alice Wyman from comment #15)
>  (In reply to Ricky Rosario [:rrosario, :r1cky] from comment #14)
> > I think this will be solved with bug 1100394
> 
> Bug 1100394 was implemented for Advanced Search. 
> 
> See also Bug 1010975 comment 0
> > 3. should we use simple-query-string for both basic and advanced search?

Yep. This is implemented in Advanced Search. The simple search for end users doesn't have it.

Kadir, should we consider implementing this for all users? How often do users search "for phrases"?
Flags: needinfo?(a.topal)

Updated

3 years ago
See Also: → bug 1100394
(Reporter)

Comment 17

3 years ago
> Kadir, should we consider implementing this for all users? How often do users search "for phrases"?

Please please please. Yes people put things in quotes to do searches.

Updated

3 years ago
See Also: bug 1100394

Comment 18

3 years ago
(In reply to Mike Kaply [:mkaply] from comment #17)
> > Kadir, should we consider implementing this for all users? How often do users search "for phrases"?
> 
> Please please please. Yes people put things in quotes to do searches.

bump

Comment 19

2 years ago
Yes please.

Also, bug 1005123 offers an alternative process
Duplicate of this bug: 791250
Duplicate of this bug: 1005123
Priority: -- → P2
You need to log in before you can comment on or make changes to this bug.