Progress throbber shows again when loading about:home on startup

VERIFIED FIXED in Firefox 15

Status

()

defect
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: pretzer, Assigned: mfinkle)

Tracking

unspecified
Firefox 14
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 verified, blocking-fennec1.0 +)

Details

Attachments

(2 attachments)

Bug 718846 and bug 719868 fixed this some time ago, but this regressed again, maybe with the maple merge.
Not maple. The about:home page is loaded into Gecko and showProgress is set to false, so no throbber is shown. BUT then the new tab is selected, to make it active, and Tab (or Tabs) has code to handle Tab:Selected" and it shows the throbber because the page is still loading.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → -
Duplicate of this bug: 743270
renominating to see if this would fall under the new soft-blocking category.
blocking-fennec1.0: - → ?
Posted patch patchSplinter Review
Attachment #613319 - Flags: review?(mark.finkle)
Posted patch patch 2Splinter Review
Attachment #613322 - Flags: review?(blassey.bugs)
Comment on attachment 613319 [details] [diff] [review]
patch

I don't like this because mState is not the same as the return of getState and that could lead to problems.
Attachment #613319 - Flags: review?(mark.finkle) → review-
Attachment #613322 - Flags: review?(blassey.bugs) → review+
blocking-fennec1.0: ? → +
Assignee: nobody → margaret.leibovic
Uh, oops, I took this without looking at it.
Assignee: margaret.leibovic → mark.finkle
Duplicate of this bug: 742693
https://hg.mozilla.org/mozilla-central/rev/423e8d6463ff
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
Throbber doesn't show up anymore on the latest Nightly build, when about:home is loaded at start up. Closing bug as verified fixed on:

Firefox 15.0a1 (2012-05-22)
Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.