InputReader doesn't send motion up events

RESOLVED FIXED in mozilla14

Status

()

Core
Widget
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mwu, Assigned: mwu)

Tracking

({regression})

Trunk
mozilla14
All
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This is an issue now after bug 737199 which gives us our own InputReader. Doesn't seem to happen on nexuss-ics for some reason.
(Assignee)

Comment 1

5 years ago
Created attachment 609530 [details] [diff] [review]
Fix input handling on sgs2

Turns out this is a problem specific to the SGS2's insane multitouch driver and how our new inputreader code doesn't support it anymore.
Assignee: nobody → mwu
Attachment #609530 - Flags: review?(jones.chris.g)
Comment on attachment 609530 [details] [diff] [review]
Fix input handling on sgs2

We need to track these patches to our import so that it's easier for us to update in the future.
Attachment #609530 - Flags: review?(jones.chris.g) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/mozilla-central/rev/18fedd79d6cc

I left a bug number.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Add Steven,
This patch may cause sp8810ea device can't handle touch event.
(Assignee)

Updated

4 years ago
Blocks: 852400

Updated

4 years ago
Blocks: 887486
You need to log in before you can comment on or make changes to this bug.