Last Comment Bug 740803 - Put the debugger in its own compartment again
: Put the debugger in its own compartment again
Status: RESOLVED FIXED
[chrome-debug]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 14
Assigned To: Panos Astithas [:past]
:
Mentors:
Depends on: 749550
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 07:32 PDT by Panos Astithas [:past]
Modified: 2012-04-27 02:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Working patch (15.25 KB, patch)
2012-04-18 09:37 PDT, Panos Astithas [:past]
no flags Details | Diff | Splinter Review
Working patch v2 (17.05 KB, patch)
2012-04-18 10:25 PDT, Panos Astithas [:past]
dcamp: review+
mark.finkle: approval‑mozilla‑central+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2012-03-30 07:32:24 PDT
Bug 703718 removed the sandbox that ensured the debugger was in a separate compartment from the debuggee. We are now ready to support the chrome debugging case and the engine has not yet developed the new protection mechanism that would have made the sandbox approach redundant. Therefore we need to revert the change from bug 703718 in order to move forward with chrome debugging for now.
Comment 1 Panos Astithas [:past] 2012-04-18 09:37:23 PDT
Created attachment 616175 [details] [diff] [review]
Working patch

This should do it.
Comment 2 Dave Camp (:dcamp) 2012-04-18 09:53:09 PDT
At the work week reverting bug 703718 wasn't enough, Jason also had to manually instantiate the jsdebugger component instead of using jsdebugger.jsm.  Do you want to do that here or in a followup?
Comment 3 Panos Astithas [:past] 2012-04-18 09:55:00 PDT
(In reply to Dave Camp (:dcamp) from comment #2)
> At the work week reverting bug 703718 wasn't enough, Jason also had to
> manually instantiate the jsdebugger component instead of using
> jsdebugger.jsm.  Do you want to do that here or in a followup?

Ah, forgot about that. Yeah, I'll do it here.
Comment 4 Panos Astithas [:past] 2012-04-18 10:25:46 PDT
Created attachment 616197 [details] [diff] [review]
Working patch v2

V2, now with the workaround to the jsdebugger.jsm loading issue.
Comment 5 Mozilla RelEng Bot 2012-04-18 14:02:06 PDT
Try run for 166fe9b02435 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=166fe9b02435
Results (out of 60 total builds):
    exception: 25
    success: 12
    failure: 23
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/pastithas@mozilla.com-166fe9b02435
Comment 6 Mozilla RelEng Bot 2012-04-18 18:02:46 PDT
Try run for cc66e1fd5d84 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=cc66e1fd5d84
Results (out of 221 total builds):
    exception: 1
    success: 181
    warnings: 38
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/pastithas@mozilla.com-cc66e1fd5d84
Comment 7 Panos Astithas [:past] 2012-04-18 23:53:40 PDT
(In reply to Mozilla RelEng Bot from comment #5)
> Try run for 166fe9b02435 is complete.
> Detailed breakdown of the results available here:
>     https://tbpl.mozilla.org/?tree=Try&rev=166fe9b02435
> Results (out of 60 total builds):
>     exception: 25
>     success: 12
>     failure: 23
> Builds (or logs if builds failed) available at:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/pastithas@mozilla.
> com-166fe9b02435

Ignore this try run, it was canceled before completion.
Comment 8 Panos Astithas [:past] 2012-04-20 01:22:28 PDT
Comment on attachment 616197 [details] [diff] [review]
Working patch v2

This is a devtools-only change that shouldn't affect Fennec, but since it touches toolkit/ and Fennec has (preffed off) debugger support (bug 739966), lucasr or mfinkle may want to have a look. If people are worried for some reason, I'll also note that we don't need to get this in for Firefox 14, but it would help a lot with the patch queue juggling we are currently doing.
Comment 9 Panos Astithas [:past] 2012-04-22 03:09:43 PDT
https://hg.mozilla.org/integration/fx-team/rev/b9914d4ebc92
Comment 10 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-04-24 08:43:34 PDT
https://hg.mozilla.org/mozilla-central/rev/b9914d4ebc92

Note You need to log in before you can comment on or make changes to this bug.