Last Comment Bug 741536 - IRC and XMPP connections fail when there's a system HTTP proxy
: IRC and XMPP connections fail when there's a system HTTP proxy
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
https://bugzilla.instantbird.org/show...
: 778087 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 13:23 PDT by Ben Bucksch (:BenB)
Modified: 2012-07-31 07:51 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Patch (919 bytes, patch)
2012-07-31 03:36 PDT, Florian Quèze [:florian] [:flo]
clokep: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review

Description Ben Bucksch (:BenB) 2012-04-02 13:23:10 PDT
Reproduction:
1. In GNOME settings | Proxy, enter a HTTP proxy.
2. Create a new TB profile, and start TB from the commandline
3. Create an IRC account, and connect

Actual result:
"Your chat accounts are not connected".
"Show chat status" shows "Lost connection to server".

Error console shows:
irc: Unhandled IRC message: HTTP/1.0 400 Bad Request
irc: Unhandled IRC message: Server: squid/...
irc: Unhandled IRC message: Date: Mon, 02 Apr 2012 20:15:07 GMT
irc: Unhandled IRC message: Content-Type: text/html
irc: Unhandled IRC message: Content-Length: 1221
irc: Unhandled IRC message: Expires: Mon, 02 Apr 2012 20:15:07 GMT
irc: Unhandled IRC message: X-Squid-Error: ERR_INVALID_REQ 0
irc: Unhandled IRC message: X-Cache: MISS from squid.host
irc: Unhandled IRC message: X-Cache-Lookup: NONE from squid.host:1234
irc: Unhandled IRC message: Connection: close

Expected result:
No HTTP proxy used for IRC.
Comment 1 Joe Sabash [:JoeS1] 2012-04-02 18:28:16 PDT
possibly bug 741056 but that's a crasher on windows.
Comment 2 Patrick Cloke [:clokep] 2012-07-24 07:00:20 PDT
We have a similar Instantbird bug on file: https://bugzilla.instantbird.org/show_bug.cgi?id=1347
Comment 3 Florian Quèze [:florian] [:flo] 2012-07-27 05:03:38 PDT
*** Bug 778087 has been marked as a duplicate of this bug. ***
Comment 4 Florian Quèze [:florian] [:flo] 2012-07-31 03:36:16 PDT
Created attachment 647488 [details] [diff] [review]
Patch

I'm proposing with this patch that we just ignore HTTP proxies for now.

I know it should be possible to use some HTTP proxies to tunnel a non-HTTP connection, but I don't know exactly what we need to do for that, and I've no HTTP proxy supporting that to test with, so for now just ignoring the HTTP proxies seems the best thing to do.
Comment 5 Patrick Cloke [:clokep] 2012-07-31 03:40:06 PDT
Comment on attachment 647488 [details] [diff] [review]
Patch

This looks fine. Thanks.
Comment 6 Florian Quèze [:florian] [:flo] 2012-07-31 03:42:30 PDT
Comment on attachment 647488 [details] [diff] [review]
Patch

[Approval Request Comment]
I've seen several reports of people who couldn't connect there chat accounts in Thunderbird because of this, so I think we should take this for Thunderbird 15.
Comment 7 Ben Bucksch (:BenB) 2012-07-31 04:12:18 PDT
> I'm proposing with this patch that we just ignore HTTP proxies for now.

+1

This also allows to use the trick mentioned in bug 741550.

Note You need to log in before you can comment on or make changes to this bug.