Last Comment Bug 742793 - Support vCard based avatars on JS-XMPP
: Support vCard based avatars on JS-XMPP
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 13 Branch
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 16.0
Assigned To: Florian Quèze [:florian] [:flo] (PTO until August 29th)
:
Mentors:
Depends on:
Blocks: 740280
  Show dependency treegraph
 
Reported: 2012-04-05 10:38 PDT by Adam Nemeth
Modified: 2012-07-31 08:04 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (4.59 KB, patch)
2012-06-15 09:59 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
no flags Details | Diff | Splinter Review
Patch (4.59 KB, patch)
2012-06-15 10:02 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
clokep: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Adam Nemeth 2012-04-05 10:38:59 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.50 (KHTML, like Gecko) Version/5.1 Safari/534.50

Steps to reproduce:

My friend didn't have his avatar listed (although he had one in Adium [not through my AB] but not one in Gmail). I told this to him, he changed avatar. 


Actual results:

The avatar didn't change; after logging in and out it did


Expected results:

Changes should've been reflected at runtime
Comment 1 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-15 09:59:52 PDT
Created attachment 633566 [details] [diff] [review]
Patch
Comment 2 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-15 10:02:49 PDT
Created attachment 633568 [details] [diff] [review]
Patch

Same patch, minus a typo.
Comment 3 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-21 03:39:24 PDT
I'm morphing this bug to be a little bit more general, about supporting vCard based avatars on XMPP.

I just checked in:
https://hg.mozilla.org/comm-central/rev/eee6c5a63844 - fetch new vCards when the server notifies us of an update. The patch reviewed here, that fixes the bug reported here.
https://hg.mozilla.org/comm-central/rev/17da70a358e2 - send the user's vCard (including the avatar and the display name). This patch was reviewed in https://bugzilla.instantbird.org/show_bug.cgi?id=1381
Comment 4 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-21 03:41:30 PDT
Comment on attachment 633568 [details] [diff] [review]
Patch

[Approval Request Comment]
I'm putting the approval flag on this attachment, but I'm actually requesting approval aurora for both changesets that landed on comm-central (comment 3).
Comment 5 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-06-28 09:13:42 PDT
I won't land this on aurora immediately as I've heard a user complaining yesterday on IRC ("Hey, your Jabber client is destroying my vcard every time I sign on!") that looks like it's caused by the changes in 17da70a358e2. I filed https://bugzilla.instantbird.org/show_bug.cgi?id=1556 to track this issue.
Comment 6 Mike Conley (:mconley) - (Needinfo me!) 2012-07-16 08:50:26 PDT
Landed in comm-aurora as https://hg.mozilla.org/releases/comm-aurora/rev/faffa1007ffb
Comment 7 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-07-16 08:55:30 PDT
> https://hg.mozilla.org/comm-central/rev/eee6c5a63844 - fetch new vCards when
> the server notifies us of an update. The patch reviewed here, that fixes the
> bug reported here.

Only this part landed on aurora (comment 6).

> https://hg.mozilla.org/comm-central/rev/17da70a358e2 - send the user's vCard
> (including the avatar and the display name). This patch was reviewed in
> https://bugzilla.instantbird.org/show_bug.cgi?id=1381

This seems to be causing a regression (comment 5) that still needs to be investigated.
Comment 8 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-07-31 08:04:48 PDT
(In reply to Florian Quèze from comment #7)

> > https://hg.mozilla.org/comm-central/rev/17da70a358e2 - send the user's vCard
> > (including the avatar and the display name). This patch was reviewed in
> > https://bugzilla.instantbird.org/show_bug.cgi?id=1381
> 
> This seems to be causing a regression (comment 5) that still needs to be
> investigated.

This landed for Thunderbird 15 (now comm-beta) in bug 779117, along with a fix for the regression.

Note You need to log in before you can comment on or make changes to this bug.