The default bug view has changed. See this FAQ.

Import XMPP fixes from Instantbird

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

Trunk
Thunderbird 17.0

Thunderbird Tracking Flags

(thunderbird15 fixed, thunderbird16 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
A few JS-XMPP bugs have been fixed recently for Instantbird, I think we want these fixes for Thunderbird 15:
Bio 1568 - JS-XMPP should handle message type="error" stanzas instead of displaying the messages again in the conversation as incoming, r=clokep.
Bio 1609 - <presence type="subscribe"/> stanzas are ignored when the JID is already in the roster, r=clokep.
Bio 1556 - Download the user's vCard before uploading an avatar, r=clokep.
(Assignee)

Updated

5 years ago
Blocks: 776901
(Assignee)

Comment 1

5 years ago
Created attachment 647519 [details] [diff] [review]
Patch

[Approval Request Comment]
On beta, we need to land https://hg.mozilla.org/comm-central/rev/17da70a358e2 before this attachment. This changeset had already been approved for Tb15 (aurora at the time) in bug 742793 but never landed on aurora, because of a known regression (fixed by a patch in this attachment).
Assignee: nobody → florian
Attachment #647519 - Flags: approval-comm-beta?
Attachment #647519 - Flags: approval-comm-aurora?
Attachment #647519 - Flags: approval-comm-beta?
Attachment #647519 - Flags: approval-comm-beta+
Attachment #647519 - Flags: approval-comm-aurora?
Attachment #647519 - Flags: approval-comm-aurora+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/comm-central/rev/05c45f78b6e4
https://hg.mozilla.org/comm-central/rev/96165102cf13
https://hg.mozilla.org/comm-central/rev/d255ca25b2b9
https://hg.mozilla.org/releases/comm-aurora/rev/3fd1d56ed51c
https://hg.mozilla.org/releases/comm-aurora/rev/333c11dc85ce
https://hg.mozilla.org/releases/comm-aurora/rev/fd4c95f30c97
https://hg.mozilla.org/releases/comm-beta/rev/b700ec636fd2
https://hg.mozilla.org/releases/comm-beta/rev/521da2a5b2d7
https://hg.mozilla.org/releases/comm-beta/rev/f6f3dafe2b14
And there's a forth changeset for comm-beta, as explained in comment 1:
https://hg.mozilla.org/releases/comm-beta/rev/46193e2ce9fb

Updated

5 years ago
Duplicate of this bug: 780172
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-thunderbird15: --- → fixed
status-thunderbird16: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
You need to log in before you can comment on or make changes to this bug.