Last Comment Bug 743102 - Desktop Click to play blocks Silverlight - prompted to Install
: Desktop Click to play blocks Silverlight - prompted to Install
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86_64 Windows 7
: -- major with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.silverlight.net/showcase/2...
: 745378 775418 775907 (view as bug list)
Depends on: 749455
Blocks: 711552 click-to-play
  Show dependency treegraph
 
Reported: 2012-04-05 17:39 PDT by Jim Jeffery not reading bug-mail 1/2/11
Modified: 2012-08-25 00:39 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jim Jeffery not reading bug-mail 1/2/11 2012-04-05 17:39:14 PDT
STR: 
Open about:config 
Enable: plugins.click_to_play
Visit a site with Silverlight - 
http://www.silverlight.net/showcase/2011/10/stock-analysis-charts 
Click Visit now on the Demo Stock Analysis Chart

Note: You are prompted to Install Silverlight, even though its already installed. 

Testing on Win7 x64 using hourly build m-c win32 cset:
https://hg.mozilla.org/mozilla-central/rev/90a4942abf08

Silverlight 5.0.61118.0
Comment 1 Tim Taubert [:ttaubert] 2012-04-06 03:17:30 PDT
Same thing happens for me with Flash on Linux.
http://www.gls-group.eu/276-I-PORTAL-WEB/content/GLS/NL99/EN/1.htm

Should that be another bug? It's probably the same root cause.

This is particularly bad because you can't play this content at all - you're prompted to install the plugin and no click-to-play UI is shown.
Comment 2 Bruce 2012-04-06 07:35:53 PDT
Not working here too on Windows 32 bit.  Adblock Plus and Flashblock are fully removed.

STR:

Open Firefox
Go to this link:  http://www.adobe.com/shockwave/welcome/
Tap here to activate plugin 
No results.
Comment 3 Bruce 2012-04-06 07:44:23 PDT
After re-reading, the Windows 32 bit bug is different and should likely be broken off as a separate bug.
Comment 4 JK 2012-04-06 08:51:33 PDT
Same with Java.

http://www.runescape.com
-> Click the "play free now" button (note: it's a Flash button, hidden by the click to play UI)

Result:

Click here to activate plugins

A plugin is needed to display this content.
Install plugin...
Comment 5 JK 2012-04-06 08:52:49 PDT
I.e. both the click to play and plugin finder service UIs are shown.
Comment 6 Willy_ Foo_Foo 2012-04-06 10:57:25 PDT
Thanks for this! too

i also have traded Flashblock for plugins.click_to_play;true

But by when it will be stable enough to test?
will it have the option to control(enable on demand) for all types of plugins?
& what about say a page has two flash player windows but want to play only the second one
will it be possible ? (flashblock allows this)
Comment 7 Jared Wein [:jaws] (please needinfo? me) 2012-04-19 14:11:00 PDT
*** Bug 745378 has been marked as a duplicate of this bug. ***
Comment 8 Jim Jeffery not reading bug-mail 1/2/11 2012-05-15 08:19:01 PDT
Runescape as noted in comment #4 , and Silverlight are now working OK with Click-to-play.

This bug seems to have been fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=749455
Comment 9 JK 2012-05-16 07:07:25 PDT
RuneScape is not working.

build:
http://hg.mozilla.org/mozilla-central/rev/c00a9c1940c5
Comment 10 Jim Jeffery not reading bug-mail 1/2/11 2012-05-16 07:59:38 PDT
(In reply to JK from comment #9)
> RuneScape is not working.
> 
> build:
> http://hg.mozilla.org/mozilla-central/rev/c00a9c1940c5

Well, darn when I tested using an hourly build bug 749455 was still in the build, its since been backed out and your Runscape is back to asking for a plugin, or it only wants 1.6 u31 java, I have SE7 U4 10.4.0.20
Comment 11 Loic 2012-07-20 14:35:30 PDT
*** Bug 775907 has been marked as a duplicate of this bug. ***
Comment 12 Marcia Knous [:marcia - use ni] 2012-07-24 14:50:54 PDT
*** Bug 775418 has been marked as a duplicate of this bug. ***
Comment 13 Paul Silaghi, QA [:pauly] 2012-08-25 00:39:32 PDT
Click-to-play notification is properly displayed on silverlight pages.
Tested on: http://www.vectorlight.net/games/sandmania.aspx
http://www.silverlight.net/showcase/2011/11/imagesurfnet
http://www.silverlight.net/showcase/2011/10/stock-analysis-charts
Verified fixed on FF 15b6 on Win 7 x64, Mac OS X 10.6.8.

Note You need to log in before you can comment on or make changes to this bug.