apple.com - Apple needs to update QuickTime installer to detect Mozilla and Netscape 6.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: ekrock's old account (dead), Assigned: Arun Ranganathan)

Tracking

({qawanted})

Details

(URL)

(Reporter)

Description

17 years ago
Above page shows this message:

Caution: Netscape 6 users may experience download and installation problems. 
Please use an earlier version of Netscape (4.7x or earlier) or another browser.

Need to figure out whether this is a N6 bug (and if so, whether it's fixed in 
newer builds) or an Apple site bug, and then get the browser or site fixed.
(Reporter)

Comment 1

17 years ago
Here's the apparent issue: Quicktime 5 preview 3 installer fails to detect 
Netscape 6 (or Mozilla, for that matter). It only detects and installs into IE5 
and Nav4.x. Apple needs to update its installer to detect Mozilla and Mozilla-
based browsers such as Netscape 6.

Changed Summary from "QuickTime 5 preview 3 download page reports problems with 
downloading on N6." to "Apple needs to update QuickTime installer to detect 
Mozilla and Netscape 6."
Summary: QuickTime 5 preview 3 download page reports problems with downloading on N6
Whiteboard: Apple needs to update QuickTime installer to detect Mozilla and Netscape 6.
(Reporter)

Comment 2

17 years ago
Moved summary from Status Whiteboard to Summary. ;->
Summary: Apple needs to update QuickTime installer to detect Mozilla and Netscape 6.
Whiteboard: Apple needs to update QuickTime installer to detect Mozilla and Netscape 6.
(Reporter)

Comment 3

17 years ago
FWIW I submitted this report through the QuickTime 5 Preview 3 Feedback form--
presumably to be ignored. Netscape will likely need to contact Apple directly 
to get their attention.

Comment 4

17 years ago
I can try to feed this through my apple contacts. If not, can we get 
someone who can say 'I am blah blah at Netscape' without stretching the 
truth?

Comment 5

17 years ago
can someone please help contact apple?
Keywords: qawanted
Hardware: All → Macintosh

Comment 6

17 years ago
ok. i asked an apple employee to do this, i'll hold blame for this bug.
Assignee: evangelism → timeless

Comment 7

17 years ago
Mozilla should be looking in the System Folder:Internet Plug-Ins folder in Mac
OS, or /Library/Internet Plug-Ins on X for plugins. You probably want to use
FindFolder with kInternetPlugInFolderType.

Comment 8

17 years ago
Final version of Quicktime 5 on Windows also fails to recognize Mozilla. the
only options are IE and NS Navigator (greyed out on my sistem, since i am using
Moz exclusively). 
the original URL is a 404 now. 

Going to Apples QT page and clicking DL crashes trunk 2001-06-20-04/win2k.

timeless, this is pretty high priority. Do you want the evang team to take this
one over?

Comment 10

17 years ago
*** Bug 91860 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
I'm on it.  I've entered RADAR bug #2731538 : 'Windows Installer Fails to
Recognize Mozilla 0.9+' into Apple's system.  I'll ping Andy Warhol (the
screener for installer bugs) about it if there's no bug activity in a day or 2.
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 13

17 years ago
*** Bug 95570 has been marked as a duplicate of this bug. ***

Updated

17 years ago
OS: All → Windows 98
Hardware: Macintosh → PC
timeless, I am giving this to Arun since he is handling the plugin kind of stuff. bc
Assignee: timeless → aruner
Summary: Apple needs to update QuickTime installer to detect Mozilla and Netscape 6. → apple.com - Apple needs to update QuickTime installer to detect Mozilla and Netscape 6.
not crashing on download here (win98, 2001092503).

Comment 16

17 years ago
I am unable to install Quicktime in Mozilla because of this bug (the option is
grayed out because I don't have Netscape 4.7). I think this is a very severe
problem because I can't recommend Mozilla to any of my non-hacker friends if
they can't install Quicktime (and the six month history prevents me from telling
them confidently that this will be fixed shortly).
I just downloaded Netscape 6.2 and when the download is finished I then went
back to the Apple Quicktime site http://www.apple.com/quicktime/ and it detected
it however I'm running Windows ME my build is 20011120009 version 0.9.6. and
when I finished completion of downloading Quicktime went back to the apple
Quicktime site and got this message 

ALERT!

QuickTime
is not
properly
installed.

Please visit the
QuickTime download page to get the latest installer application.

Comment 18

17 years ago
The bug http://bugzilla.mozilla.org/show_bug.cgi?id=111401 may also shed some
light on this. I get the idea that something in the latest hot updates from
apple may break the plugin, even if you fiddle around to get an install working.

Comment 19

17 years ago
plugins
Component: US General → Plugins
QA Contact: zach → mgalli
Keywords: evang500

Comment 20

17 years ago
The ref'd URL above is no longer active. Apparently NOT a problem for Mac OS X users with 
Mozilla  0.9.8 - correctly uses the preinstalled QT plugin in /Library/Internet Plugins.

Comment 21

17 years ago
Michael Spertus: you can still install QT manually. just copy C:\Program
Files\QuickTime\Plugins\* into C:\Program Files\mozilla.org\Mozilla\Plugins (or
wherever your plugindir resists) and restart the lizard.

nevertheless this one certainly is one of the major evangelism stuff and should
be considerable "done" when mozilla 1.0 is there or at least MachV comes out.

Comment 22

17 years ago
note that you don't need to restart mozilla, simply visiting about:plugins and 
clicking reload should work.

Comment 23

16 years ago
Just tested this, it worked fine, and put the plugin in the mozilla plugin
folder by itself. Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 24

15 years ago
SPAM: New Components
Component: Plugins → English US

Comment 25

15 years ago
Could Apple update their separate (also called CD) installers for QuickTime 5
and 4, which would then be able to detect Mozilla and copy files to 

C:\Program Files\mozilla.org\Plugins

*or should the Mozilla installer see if QuickTime exists and then copy files from*

C:\Program Files\QuickTime\Plugins

to

C:\Program Files\mozilla.org\Plugins
?

This would require that QuickTime users install their plugin before Mozilla gets
installed.

The older QT version that at least could be updated in mind is 5... But I am
aware of the fact that Mozilla 1 was released in Mid-2002, while QuickTime 5
still bears the year of 2001, when Mozilla 0.9.x was in the works.
I am not sure if Apple would like to update their old softwrare, though.

If Mozilla could do the plugin file copying, it would resolve the problem of its
not playing the relevant plugin files right away.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.