Build process is stopped : mozilla/build/autoconf/freetype2.m4 is missing.

VERIFIED DUPLICATE of bug 743441

Status

VERIFIED DUPLICATE of bug 743441
7 years ago
7 years ago

People

(Reporter: fredbezies, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120406 Firefox/14.0a1
Build ID: 20120406073117

Steps to reproduce:

Just updated my own version of source code of mozilla Thunderbird trunk code this morning, using python client.py checkout.

After this, I wanted to make it build, so I enter make -f client.mk build.


Actual results:

[fred@fredo-arch src]$ make -f client.mk depend
Adding client.mk options from /home/fred/logs/mail/src/.mozconfig:
    MOZ_OBJDIR=$(TOPSRCDIR)/../objdir-tb
    MOZ_MAKE_FLAGS=-j2
Generating /home/fred/logs/mail/src/configure using autoconf
/usr/bin/m4:./aclocal.m4:10: cannot open `mozilla/build/autoconf/freetype2.m4': No such file or directory
make: *** [/home/fred/logs/mail/src/configure] Error 2



Expected results:

Build process going on.

If it matters, I'm using an archlinux 64 bits distribution. And Mozilla Firefox trunk code is still buildable.

Here is .mozconfig file :

export AUTOCONF=autoconf-2.13
export PYTHON=python2

ac_add_options --enable-application=mail
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../objdir-tb
mk_add_options MOZ_MAKE_FLAGS=-j2

# Options for ‘configure’ (same as command-line options).
ac_add_options --disable-debug
ac_add_options --disable-tests
ac_add_options --disable-crashreporter
ac_add_options --enable-calendar
ac_add_options --with-ccache
ac_add_options --disable-installer
ac_add_options --disable-warnings-as-errors

And it seems to be something was broken in the last 24 hours. Yesterday, source code was buildable.
Mac OS X 32 and 64 bit is also affected.
Building Seamonkey 64-bit now fails as well
Building Seamonkey at about 17.30 UTC on April 7 was good. (a few hours after my comment #2)  It looks like some of the late check-ins fixed this bug
(Reporter)

Comment 4

7 years ago
Well, you're lucky. Still busted here :(

[fred@fredo-arch src]$ date
dim. avril  8 08:04:49 CEST 2012
[fred@fredo-arch src]$ make -f client.mk depend
Adding client.mk options from /home/fred/logs/mail/src/.mozconfig:
    MOZ_OBJDIR=$(TOPSRCDIR)/../objdir-tb
    MOZ_MAKE_FLAGS=-j4
Generating /home/fred/logs/mail/src/configure using autoconf
/usr/bin/m4:./aclocal.m4:10: cannot open `mozilla/build/autoconf/freetype2.m4': No such file or directory
make: *** [/home/fred/logs/mail/src/configure] Erreur 2

Gcc 4.7.0 related ? .mozconfig problem ?
(In reply to Bengt-Erik Soderstrom from comment #3)
> Building Seamonkey at about 17.30 UTC on April 7 was good. (a few hours
> after my comment #2)  It looks like some of the late check-ins fixed this bug

This was a misnomer, a clobber build breaks us, a non-clobber should have worked.

(In reply to Frederic Bezies from comment #4)
> Well, you're lucky. Still busted here :(

Hopefully this will be fixed soon, but I also found: Bug 743441 which as a (reviewed) patch. If you apply that locally you will be able to build.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 743441
(Reporter)

Comment 6

7 years ago
Thanks. And of course, it was a clobber build for my thunderbird source code :(
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.