Last Comment Bug 743441 - Port |Bug 716354 - freetype2 detection doesn't consider cross-compiling| to comm-central
: Port |Bug 716354 - freetype2 detection doesn't consider cross-compiling| to c...
Status: VERIFIED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Mac OS X
: P1 blocker (vote)
: Thunderbird 14.0
Assigned To: Misak Khachatryan
:
Mentors:
: 743422 743437 (view as bug list)
Depends on: 716354
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 05:30 PDT by Serge Gautherie (:sgautherie)
Modified: 2013-10-13 02:16 PDT (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
oneliner (1001 bytes, patch)
2012-04-07 09:53 PDT, Misak Khachatryan
neil: review+
bugspam.Callek: review+
bugzillamozillaorg_serge_20140323: feedback+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2012-04-07 05:30:24 PDT
SeaMonkey and Thunderbird fail with
{
/opt/local/bin/gm4:./aclocal.m4:10: cannot open `mozilla/build/autoconf/freetype2.m4': No such file or directory
}
on OSX 10.6.
Comment 1 Misak Khachatryan 2012-04-07 09:53:59 PDT
Created attachment 613117 [details] [diff] [review]
oneliner

I have built mine with this one line fix.
Comment 2 Serge Gautherie (:sgautherie) 2012-04-07 10:04:05 PDT
Comment on attachment 613117 [details] [diff] [review]
oneliner

Yeah, it looks like c-c doesn't have the involved configure.in line ;-)
Comment 3 Justin Wood (:Callek) 2012-04-07 22:01:23 PDT
Comment on attachment 613117 [details] [diff] [review]
oneliner

Just to mark it with an official c-c build peer r+. Lets land it asap, its burning jobs now.
Comment 4 Justin Wood (:Callek) 2012-04-07 23:17:04 PDT
*** Bug 743422 has been marked as a duplicate of this bug. ***
Comment 5 Philip Chee 2012-04-08 05:08:45 PDT
*** Bug 743437 has been marked as a duplicate of this bug. ***
Comment 6 Philip Chee 2012-04-08 05:33:29 PDT
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/1c784b29d21d

There is a duplicate patch from Matsuura-san from Bug 743437 so I've added him to the commit comment.

Note You need to log in before you can comment on or make changes to this bug.