Entering accented characters on HKB causes mobile.twitter.com to eat subsequent input characters

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

({inputmethod, regression})

12 Branch
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, firefox16 verified, blocking-fennec1.0 +)

Details

(Whiteboard: HKB, )

Attachments

(1 attachment)

STR:
1. With a phone with HKB like the Droid Pro, log into http://mobile.twitter.com
2. In the "What's happening?" input form, type a couple 'a' characters. No problem.
3. Now press and hold the 'a' button for one second.
4. A popup menu of accented 'a' characters will open.
5. Choose any of the accented 'a' characters and it will be displayed in the text input box.
6. Now continue typing other characters.

AR:
Subsequent characters will overwrite the accented character in place.

ER:
Should be able to keep typing.

This bug affects HKB only. VKB works correctly.
Summary: Entering accented characters on HKB causes mobile.twitter.com to eat input characters → Entering accented characters on HKB causes mobile.twitter.com to eat subsequent input characters
Assignee: nobody → cpeterson
We'd like to know how widespread this is - does it affect other sites, or is twitter doing something unique with its text input boxes?
Keywords: qawanted
This is reproducible on other pages that have search fields like google.com or ask.com.
Build: Firefox 14.0a1 (2012-04-12)
Device: Motorola Droid Pro (Android 2.3.4)
Keywords: qawanted
blocking-fennec1.0: ? → +
Any input text field.  http://people.mozilla.com/~nhirata/html_tp/formsninput.html  

This doesn't exhibit an issue using French IME with desktop Mac Firefox using the mobile UA.
Keywords: inputmethod
Status: NEW → ASSIGNED
qawanted to see if this issue is unique to the droid pro
Keywords: qawanted
Works for me using a G2/Desire Z using today's nightly. Leaving qawanted to get a Droid 2/3 or other HKB phone.
Accented characters work correctly in XUL Fennec on my Droid Pro, so this is a new issue for Native Fennec. I need to determine whether this is a regression.
Tested on Motorola Droid 2 (Android 2.3.3) and HTC Desire Z (Android 2.3.3) on Nightly/14.0a1 2012-04-22.

I am seeing the behavior from Bug 747845 but also I can see that the accented character is overwritten by the next character typed and any new character typed replaces the character situated in that position. The user has to use backspace to erase the position in order to continue typing.
On Nightly/12.0a1 2012-01-01 the issue is not reproducible. On Nightly/12.0a1 2012-01-31 the issue in reproducible. This is a regression.
Keywords: qawanted
I believe this regression started with Nightly 2012-01-21:

* 2012-01-01 = PASS
* 2012-01-15 = PASS
* 2012-01-19 = PASS
* 2012-01-20 = PASS
* 2012-01-21 = FAIL
* 2012-01-22 = FAIL
* 2012-01-23 = FAIL
* 2012-01-24 = FAIL
* 2012-01-26 = FAIL
* 2012-01-31 = FAIL
Target Milestone: --- → Firefox 14
Version: Trunk → Firefox 15
Regression range from 1/20 nightly to 1/21 nightly:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5c2bc94d359c&tochange=e46cca506613

Maybe a regression from bug 711648?
Keywords: regression
Target Milestone: Firefox 14 → ---
Version: Firefox 15 → Firefox 12
Yes, I believe this bug is a regression from changeset c53d7932f6b7 ("bug 711648 - Pre-commit underline is not shown for the composing text") related to caret position.
Blocks: 711648
If IME begins an ephemeral composition string, then end it when done.
Attachment #618764 - Flags: review?(blassey.bugs)
Comment on attachment 618764 [details] [diff] [review]
bug-743468-end-ephemeral-composition-string.patch

[Approval Request Comment]
Regression caused by (bug #): bug 711648
User impact if declined: Fennec users with hardware keyboards will not be able to enter accented characters.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Java only. Unlikely risk could include text boxes getting into bad input state with some untested IME.
String changes made by this patch: N/A
Attachment #618764 - Flags: approval-mozilla-aurora?
Attachment #618764 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/620c80e2a024
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 618764 [details] [diff] [review]
bug-743468-end-ephemeral-composition-string.patch

Mobile only.
Attachment #618764 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/6f99e37fc4c1
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Target Milestone: Firefox 15 → ---
oops. I did not intend to change this bug's status/resolution or milestone. Fixing now.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Blocks: 751513
Blocks: 751864
No longer blocks: 751864
Depends on: 751864
Blocks: 751864
No longer depends on: 751864, 752624
Comment on attachment 618764 [details] [diff] [review]
bug-743468-end-ephemeral-composition-string.patch

Removing Aurora approval.  Please re-nom when the fall out is fixed.
Attachment #618764 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora-
Depends on: 756429
This is still an issue on Nightly 15.0a1 2012-05-18 and Aurora 14.0a2 2012-05-18 using both HTC Desire Z (Android 2.3.3) and Motorola Droid Pro (Android 2.3.4). Bug 756429 was logged for tracking the issue.
No longer depends on: 756429
No longer blocks: 751513
Depends on: 751513
Attachment #618764 - Flags: approval-mozilla-aurora- → approval-mozilla-aurora+
Comment on attachment 618764 [details] [diff] [review]
bug-743468-end-ephemeral-composition-string.patch

[Triage Comment]
Attachment #618764 - Flags: approval-mozilla-aurora+ → approval-mozilla-beta+
Verified fixed on Nightly 16.0a1 2012-06-27 and Aurora 15.0a2 2012-06-22 and Firefox Beta 14.0b8 2012-06-22 using HTC Desire Z (Android 2.3.3)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.