Last Comment Bug 743573 - Build warnings in dom/
: Build warnings in dom/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
: 728543 774975 (view as bug list)
Depends on: 781545 781686
Blocks: buildwarning 781058 1068113
  Show dependency treegraph
 
Reported: 2012-04-08 10:04 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2014-09-16 10:17 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (15.38 KB, patch)
2012-04-08 10:04 PDT, :Ms2ger (⌚ UTC+1/+2)
mounir: review+
Details | Diff | Splinter Review
Patch v2 (23.44 KB, patch)
2012-07-10 09:23 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v3 (22.84 KB, patch)
2012-07-18 06:23 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v4 (25.51 KB, patch)
2012-07-23 09:14 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
Patch v5 (27.13 KB, patch)
2012-08-02 14:15 PDT, :Ms2ger (⌚ UTC+1/+2)
mounir: review+
Details | Diff | Splinter Review
More fixes (13.22 KB, patch)
2012-08-06 11:46 PDT, :Ms2ger (⌚ UTC+1/+2)
mounir: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-04-08 10:04:47 PDT
Created attachment 613186 [details] [diff] [review]
Patch v1
Comment 1 Mounir Lamouri (:mounir) 2012-04-10 02:35:22 PDT
Comment on attachment 613186 [details] [diff] [review]
Patch v1

Review of attachment 613186 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsDOMClassInfo.cpp
@@ +8795,5 @@
>    }
>  
> +  nsHTMLDocument* doc = GetDocument(obj);
> +  nsISupports* result = NULL;
> +  nsWrapperCache* cache = NULL;

Could you use nsnull instead?

::: dom/plugins/ipc/PluginModuleParent.cpp
@@ +585,5 @@
>  
>  PluginIdentifierParent*
>  PluginModuleParent::GetIdentifierForNPIdentifier(NPP npp, NPIdentifier aIdentifier)
>  {
> +    PluginIdentifierParent* ident = NULL;

nsnull?
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-07-10 09:23:26 PDT
Created attachment 640633 [details] [diff] [review]
Patch v2

I don't remember what went wrong with the previous patch, but this passes try: <https://tbpl.mozilla.org/?tree=Try&rev=cc52db937c0f>.
Comment 3 Mounir Lamouri (:mounir) 2012-07-10 09:25:42 PDT
Comment on attachment 640633 [details] [diff] [review]
Patch v2

Review of attachment 640633 [details] [diff] [review]:
-----------------------------------------------------------------

Unfortunately, I don't have cycles for that. Moving to khuey hoping he has some.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-07-18 06:23:07 PDT
Created attachment 643349 [details] [diff] [review]
Patch v3
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-07-23 09:14:57 PDT
Created attachment 644953 [details] [diff] [review]
Patch v4
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-08-02 14:15:32 PDT
Created attachment 648484 [details] [diff] [review]
Patch v5
Comment 7 Mounir Lamouri (:mounir) 2012-08-06 08:08:45 PDT
Comment on attachment 648484 [details] [diff] [review]
Patch v5

Review of attachment 648484 [details] [diff] [review]:
-----------------------------------------------------------------

Does that make dom/ fully warning-free? If so, maybe we could add something in the Makfile rules that make dom/ subdirectories warning-free.
Comment 8 :Ms2ger (⌚ UTC+1/+2) 2012-08-06 11:46:22 PDT
Created attachment 649332 [details] [diff] [review]
More fixes

The static assertions are because of clang errors like:

../../../dom/indexedDB/OpenDatabaseHelper.cpp:27:1: error: unused function 'pr_static_assert' [-Werror,-Wunused-function]
PR_STATIC_ASSERT(JS_STRUCTURED_CLONE_VERSION == 1);
^
../../dist/include/prtypes.h:535:17: note: expanded from macro 'PR_STATIC_ASSERT'
    extern void pr_static_assert(int arg[(condition) ? 1 : -1])
                ^
1 error generated.
Comment 9 :Ms2ger (⌚ UTC+1/+2) 2012-08-07 02:34:07 PDT
https://hg.mozilla.org/mozilla-central/rev/1bbc0b65dffb
Comment 10 :Ms2ger (⌚ UTC+1/+2) 2012-08-07 02:39:35 PDT
And I pushed

https://hg.mozilla.org/integration/mozilla-inbound/rev/08b1e1a4b851

with fixes from Aryeh.
Comment 11 Ed Morley [:emorley] 2012-08-07 07:32:58 PDT
https://hg.mozilla.org/mozilla-central/rev/08b1e1a4b851
Comment 12 Jason Duell [:jduell] (needinfo me) 2012-08-07 16:23:22 PDT
This is now causing 

dom/base/nsDOMClassInfo.cpp:9069:29: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]

Casting 32 bit int to void *: tsk, tsk...
Comment 13 Jason Duell [:jduell] (needinfo me) 2012-08-07 16:26:54 PDT
This is on a x86-64 bit linux system.  

I'm confused as to why the buildbots didn't catch this--do we not turn on warnings-as-errors there?
Comment 14 Jason Duell [:jduell] (needinfo me) 2012-08-07 16:33:47 PDT
These too:

dom/plugins/base/nsPluginNativeWindowGtk2.cpp:202:147: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]

dom/plugins/ipc/PluginInstanceParent.cpp:409:48: error: cast to pointer from integer of different size [-Werror=int-to-pointer-cast]
Comment 15 :Ms2ger (⌚ UTC+1/+2) 2012-08-08 00:57:20 PDT
I'll fix those in bug 781058.
Comment 16 :Ms2ger (⌚ UTC+1/+2) 2012-08-08 10:12:34 PDT
*** Bug 774975 has been marked as a duplicate of this bug. ***
Comment 17 :Ms2ger (⌚ UTC+1/+2) 2013-03-16 00:22:59 PDT
*** Bug 728543 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.