Closed Bug 744672 Opened 10 years ago Closed 10 years ago

Update the graphics blocklist to the new AMD/ATI version number scheme

Categories

(Core :: Graphics, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 791742
Tracking Status
firefox16 - ---

People

(Reporter: lh.bennett, Assigned: bas.schouten)

References

Details

(Whiteboard: [Win8][parity-ie])

Attachments

(1 obsolete file)

The Engineering Sample Drivers that are supplied for Windows 8 by Microsoft and AMD for AMD Graphics Processors is detected as older than 10.3.

AMD GPUs that are a part of the AMD Radeon HD 4000 family of chips or lower is not yet supported by the preview driver supplied by AMD which carries the version 8.93.7 RC10 with a date of 3/12/2012. The approved driver supplied by Microsoft has a version number of 8.93.7.0 with a date of 2/17/2012 is intended for those HD 4000 or lower until AMD can get around to it.

Both of these are detected as old, When they are clearly not.

This affects Both stable Firefox and Nightly.
Can you show me the graphics section of about:support?
Graphics
      

Adapter Description: ATI Radeon HD 5700 Series (Engineering Sample - WDDM v1.20)
Vendor ID: 0x1002
Device ID: 0x68be
Adapter RAM: 1024
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.93.7.0Driver Date2-17-2012
Direct2D Enabled: Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled: false (6.2.8250.0)
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 
WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
GPU Accelerated Windows: 0. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
Isn't this simply due to our blacklisting logic not yet recognizing Windows 8? If so, that would be an easy fix.
Oh no, it's very simple actually: from comment 2:

Driver Version: 8.93.7.0

But we require driver version > 8.741.0.0 for AMD cards.

It just seems that the driver version numbering scheme changed in Windows 8 and we need to update our blacklists for it.
Just a heads up for anyone still watching this bug:

AMD's version number scheme seems to have changed for drivers after Catalyst 12.4. (Which is obviously 12.5)

Catalyst 12.3 = 8.951.0 WHQL (March 8th)
Catalyst 12.4 = 8.960.0 BETA (March 15th)

Catalyst 12.5 is listed as 8.97.0 according to the beta leak over at Guru3D. These have a date of April 18th.
(In reply to Benoit Jacob [:bjacob] (on vacation Aug. 16th and 17th) from comment #3)
> Isn't this simply due to our blacklisting logic not yet recognizing Windows
> 8?
It's bug 706908.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 8 → Windows 7
Hardware: x86_64 → All
Summary: Blacklist blocks Windows 8 AMD drivers → Update the graphics blocklist to the new AMD/ATI version number scheme
This fixes the blacklist for Windows 8. But I'm not sure what the versioning system is like on Windows 7 or how we'd fix that.
Assignee: nobody → bas.schouten
Attachment #653530 - Flags: review?(joe)
Attachment #653530 - Flags: review?(joe) → review+
(In reply to Bas Schouten (:bas) from comment #7)
> This fixes the blacklist for Windows 8. But I'm not sure what the versioning
> system is like on Windows 7 or how we'd fix that.
The version numbering system is the same on Windows Vista, 7 and 8. See the VISTA/Win 7 Packaging String column in http://developer.amd.com/download/ccc/pages/default.aspx
For instance, 8.95 is higher than 8.911 and lower than 8.961 while the current gfx blacklisting logic considers 8.961 higher than 8.911 which is higher than 8.95.

Both the current code and patch do the wrong thing.
ugh, they consider it a decimal number?!
Blocks: 783517
Depends on: 706908
Duplicate of this bug: 784788
Whiteboard: [Win8]
We might have to update to properly detect the decimal :s
Attachment #653530 - Attachment is obsolete: true
Attachment #653530 - Flags: review+
Yeah, let's change the blacklist to treat AMD numbers as decimals. (cry cry cry)

Bas, will you do so?
This doesn't appear to block bug 783517 anymore. Is that true? If so, we'll untrack for release. If I'm mistaken, we should target beta 4 for this fix.
(In reply to Alex Keybl [:akeybl] from comment #13)
> This doesn't appear to block bug 783517 anymore. Is that true?
This bug is to unblock D2D for people having a driver version like 8.xx released after June 2010.
If Catalyst 12.9 has a driver version 8.99 or 9.0, it will be blocked. As a result, there will be poor performances compared to IE 10 (not good for benchmarks) and we won't be able to check that AMD drivers work well with Firefox on Windows 8.
Whiteboard: [Win8] → [Win8][ieparity]
Whiteboard: [Win8][ieparity] → [Win8][parity-ie]
Yes, Alex, this can be untracked. In fact, it's addressed by bug 791742, and so I'm just going to dupe it off.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791742
You need to log in before you can comment on or make changes to this bug.