The default bug view has changed. See this FAQ.

add Windows 8 to the OS list for gfx driver blacklisting

RESOLVED FIXED in Firefox 16

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bjacob, Assigned: Joe Drew (not getting mail))

Tracking

unspecified
mozilla18
All
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16+ fixed, firefox17 fixed, firefox18 fixed)

Details

(Whiteboard: [Win8])

Attachments

(3 attachments, 1 obsolete attachment)

Comment hidden (empty)

Updated

5 years ago
Blocks: 711656

Updated

5 years ago
Blocks: 715401

Updated

5 years ago
Blocks: 741105

Updated

5 years ago
OS: All → Windows 8
(Assignee)

Updated

5 years ago
Assignee: nobody → joe
(Assignee)

Comment 1

5 years ago
Created attachment 652858 [details] [diff] [review]
add Windows 8 to the platform list

I presume this is how it'll come up, but lacking Windows 8 I can't test.
Attachment #652858 - Flags: review?(netzen)
(Assignee)

Comment 2

5 years ago
Er, pretend that I added a comma after Windows 7 too.
Comment on attachment 652858 [details] [diff] [review]
add Windows 8 to the platform list

Review of attachment 652858 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with , added :D
Not sure if you care or not, but you have kWindowsServer2003 listed already.
Server 2012 has the same value of 0x60002
Attachment #652858 - Flags: review?(netzen) → review+
(Assignee)

Comment 4

5 years ago
Created attachment 652876 [details] [diff] [review]
support Windows 8 from gfxInfo

This should support Windows 8 (and, incidentally, Mac OS X 10.8). Coming next: some tests.

Benoit, do you remember how we broke the blacklist accidentally in previous Firefox versions? I remember it being about us changing an enumerated value and some comparison being wrong. I just don't want to repeat that!
Attachment #652876 - Flags: review?(bjacob)
(Assignee)

Comment 5

5 years ago
The bug I was referring to is bug 711656.
(Assignee)

Comment 6

5 years ago
Created attachment 652914 [details] [diff] [review]
support windows 8 and os x 10.8 from gfxInfo

Forgot the widgets/cocoa part of the patch.
Attachment #652876 - Attachment is obsolete: true
Attachment #652876 - Flags: review?(bjacob)
Attachment #652914 - Flags: review?(bjacob)
(Assignee)

Comment 7

5 years ago
Created attachment 652915 [details] [diff] [review]
test new OS versions
Attachment #652915 - Flags: review?(bjacob)
(Assignee)

Comment 8

5 years ago
Try: https://tbpl.mozilla.org/?tree=Try&rev=0544152632ca
These patches don't compile for me on Windows 8, due to a missing comma in the gfxWindowsPlatform.h enum.
You have to pretend it's there, see Comment 2 :D
(Reporter)

Updated

5 years ago
Attachment #652914 - Flags: review?(bjacob) → review+
(Reporter)

Updated

5 years ago
Attachment #652915 - Flags: review?(bjacob) → review+

Updated

5 years ago
Blocks: 744672

Updated

5 years ago
tracking-firefox16: --- → +
Whiteboard: [Win8]

Updated

5 years ago
Blocks: 786076
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/02a60618e928
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f74f34beaa4
https://hg.mozilla.org/integration/mozilla-inbound/rev/e938ef11c6d2
Target Milestone: --- → mozilla18
https://hg.mozilla.org/mozilla-central/rev/02a60618e928
https://hg.mozilla.org/mozilla-central/rev/3f74f34beaa4
https://hg.mozilla.org/mozilla-central/rev/e938ef11c6d2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

5 years ago
Comment on attachment 652858 [details] [diff] [review]
add Windows 8 to the platform list

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: Inability for us to block hardware acceleration on Windows 8 at all
Testing completed (on m-c, etc.): On m-c for a while
Risk to taking this patch (and alternatives if risky): Could break all blacklisting, though it *shouldn't* since we have a lot of tests
String or UUID changes made by this patch: none
Attachment #652858 - Flags: approval-mozilla-beta?
Attachment #652858 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 14

5 years ago
Comment on attachment 652914 [details] [diff] [review]
support windows 8 and os x 10.8 from gfxInfo

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #652914 - Flags: approval-mozilla-beta?
Attachment #652914 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Attachment #652915 - Flags: approval-mozilla-beta?
Attachment #652915 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #652858 - Flags: approval-mozilla-beta?
Attachment #652858 - Flags: approval-mozilla-beta+
Attachment #652858 - Flags: approval-mozilla-aurora?
Attachment #652858 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Attachment #652914 - Flags: approval-mozilla-beta?
Attachment #652914 - Flags: approval-mozilla-beta+
Attachment #652914 - Flags: approval-mozilla-aurora?
Attachment #652914 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Attachment #652915 - Flags: approval-mozilla-beta?
Attachment #652915 - Flags: approval-mozilla-beta+
Attachment #652915 - Flags: approval-mozilla-aurora?
Attachment #652915 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 15

5 years ago
remote:   https://hg.mozilla.org/releases/mozilla-beta/rev/2e588425bf78
remote:   https://hg.mozilla.org/releases/mozilla-beta/rev/a6cf6997536f
remote:   https://hg.mozilla.org/releases/mozilla-beta/rev/5020f7413641

remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/6a320ddf2dfe
remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/1b6102284032
remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/22e3efa1a108
status-firefox16: --- → fixed
status-firefox17: --- → fixed
status-firefox18: --- → fixed

Updated

5 years ago
Blocks: 804144
You need to log in before you can comment on or make changes to this bug.