Investigate alternative SSH daemon for Windows

REOPENED
Assigned to

Status

Release Engineering
Platform Support
P4
normal
REOPENED
5 years ago
2 years ago

People

(Reporter: jhopkins, Assigned: Q)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2645] [automation])

(Reporter)

Description

5 years ago
The SSH daemon we're using now (kpym) does not support authorized_keys or scp, two major features of an SSH daemon required for automation.

<catlee-buildduty> it had to work on the ancient talos boxes
<catlee-buildduty> maybe that's not an issue any more

We should investigate other options.  I suggest looking at CopSSH which was easy to install and configure and has the features we need.

Comment 1

5 years ago
Armen is looking at deploying CopSSH with the new w64/win8 platform.
Assignee: nobody → armenzg
Priority: -- → P3
Whiteboard: [automation]
Priority: P3 → P4
Duplicate of this bug: 762537
Not working on this at the moment.
Assignee: armenzg → nobody
(Reporter)

Comment 4

4 years ago
I installed BitVise (http://www.bitvise.com/) at home on Windows 8 and confirmed that it supports public key authentication and scp.  I don't know what licenses cost.

Comment 5

4 years ago
Armen: correct me if I'm wrong, but I thought we were sticking with KpyM because Q could actually make it behave the way we want, i.e. working scp and using authorized_keys?
Flags: needinfo?(armenzg)
This is old. Our current ssh/scp setup works.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(armenzg)
Resolution: --- → INVALID
(Reporter)

Comment 7

4 years ago
Our current SSH daemon still does not support:
- scp
- multi-channel SSH sessions (for better automation)
- having trouble getting passwordless logins and passwords working at the same time

Q has also mentioned that he'd like to upgrade our SSH daemon to something better.  I think we should keep this bug on file.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Should we move it to Relops?
(Reporter)

Comment 9

4 years ago
Q, would you or markco like to take this on?
Flags: needinfo?(q)
(Assignee)

Updated

4 years ago
Assignee: nobody → q
Flags: needinfo?(q)
(Assignee)

Updated

4 years ago
Blocks: 853321
Product: mozilla.org → Release Engineering
Something that supports "exec" would be nice.

Updated

3 years ago
Whiteboard: [automation] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2638] [automation]

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2638] [automation] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2645] [automation]
Do we still care about this?
Flags: needinfo?(q)
(Assignee)

Comment 12

2 years ago
yes
Flags: needinfo?(q)
You need to log in before you can comment on or make changes to this bug.