[traceback] AttributeError: Cannot Install Free Applications on Marketplace Dev

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: lmandel, Assigned: andym)

Tracking

({regression})

Details

I followed Jason's instructions to install a native app on OSX but after clicking the install button no door hangar appeared and the app wasn't installed.

Steps to reproduce:
1. Go to https://marketplace-dev.allizom.org/search/
2. Select the first application on the list "SeeVan's Underworld Adventure!"
https://marketplace-dev.allizom.org/en-US/app/seevans-underworld-adventur/?src=search
3. Click Install. The button changes to "Installing..." and then quickly reverts to "Install". Nothing is installed.

Expected results:
After clicking Install I expect to see a door hangar prompting me to agree to a local installation and for the app to then be installed natively.

Actual results:
No door hangar is shown. The app is not installed natively on OSX.

Nightly 14.0a1 2012-04-19
OSX 10.7.3
Sounds like a marketplace issue.
Component: Web Apps → Public Pages
Product: Firefox → addons.mozilla.org
QA Contact: webapps → web-ui
Version: 14 Branch → unspecified

Updated

6 years ago
Summary: Native app install fails on OSX → Cannot Install SeeVan's Underworld Adventure on Marketplace Dev

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Krupa - Any ideas?
At this point the platform contains all of the functionality that I need to perform the native install, correct? I shouldn't need an add-on?
I think I should also note that this issue is not specific to the "SeeVan's Underworld Adventure!" app. I have the same experience with multiple different apps in the market.
(In reply to Lawrence Mandel [:lmandel] from comment #4)
> I think I should also note that this issue is not specific to the "SeeVan's
> Underworld Adventure!" app. I have the same experience with multiple
> different apps in the market.

Good point. For sanity checking, could you try installing an application from here -https://apps.mozillalabs.com/appdir/? That way we can confirm this isn't a native install issue.
There's some strange behavior going on with the marketplace dev server right now. I just saw it switch to the developer hub as the default starting location.

Updated

6 years ago
Summary: Cannot Install SeeVan's Underworld Adventure on Marketplace Dev → Cannot Install Free Applications on Marketplace Dev

Comment 7

6 years ago
This looks very similar to bug 744999
(In reply to Jason Smith from comment #6)
> There's some strange behavior going on with the marketplace dev server right
> now. I just saw it switch to the developer hub as the default starting
> location.

That's because that's what's in production at marketplace.mozilla.org - we're not serving consumer pages yet, and we were doing regression testing last night in preparation for today's push.
(Assignee)

Updated

6 years ago
Assignee: nobody → amckay
Error: AttributeError, 'WSGIRequest' object has no attribute 'get'
URL: https://arecibo-phx.mozilla.org/view/2393550/
Keywords: regression
Summary: Cannot Install Free Applications on Marketplace Dev → [traceback] AttributeError: Cannot Install Free Applications on Marketplace Dev
(In reply to Jason Smith from comment #5)
> (In reply to Lawrence Mandel [:lmandel] from comment #4)
> > I think I should also note that this issue is not specific to the "SeeVan's
> > Underworld Adventure!" app. I have the same experience with multiple
> > different apps in the market.
> 
> Good point. For sanity checking, could you try installing an application
> from here -https://apps.mozillalabs.com/appdir/? That way we can confirm
> this isn't a native install issue.

Install from here was successful.
(Assignee)

Comment 11

6 years ago
https://github.com/mozilla/zamboni/commit/3ac3c8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 747252
Note - On FF 12 and Chrome, I am still seeing this bug occur with https://marketplace-dev.allizom.org/en-US/app/the-boston-globe/?src=search. Should we reopen this bug?
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.