The default bug view has changed. See this FAQ.

Build fails in TestMailCookie.cpp

RESOLVED FIXED in Thunderbird 14.0

Status

MailNews Core
Build Config
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

Trunk
Thunderbird 14.0
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.11 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Pulled a few times in the last couple of days from trunk and done clobber builds but it keeps failing in TestMailCookie.cpp with the following error:
/usr/bin/ld: ../../../mozilla/dist/lib/libmozglue.a(double-conversion.o): undefined reference to symbol '__cxa_guard_acquire@@CXXABI_1.3'
/usr/bin/ld: note: '__cxa_guard_acquire@@CXXABI_1.3' is defined in DSO /usr/lib64/libstdc++.so.6 so try adding it to the linker command line
/usr/lib64/libstdc++.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[6]: *** [TestMailCookie] Error 1
make[6]: Leaving directory `/home/gizmo/central/sm-opt/mailnews/base/test'
make[5]: *** [tools] Error 2

After issuing the following command:
/usr/bin/python2.7 /home/gizmo/central/comm-central/mozilla/config/pythonpath.py -I../../../mozilla/config /home/gizmo/central/comm-central/mozilla/config/expandlibs_exec.py --uselist --  /usr/bin/ccache gcc  -pedantic -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -fno-strict-aliasing -pthread -pipe  -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -finline-limit=50 -fomit-frame-pointer -o TestMailCookie TestMailCookie.o  -lpthread    -Wl,-rpath-link,/home/gizmo/central/sm-opt/mozilla/dist/bin:/usr/lib:/usr/local/lib:/lib -Wl,-rpath-link,/usr/local/lib  -Wl,--whole-archive /home/gizmo/central/sm-opt/mozilla/dist/lib/libmozglue.a -Wl,--no-whole-archive -rdynamic  -L../../../mozilla/dist/bin -L../../../mozilla/dist/lib /home/gizmo/central/sm-opt/mozilla/dist/lib/libxpcomglue_s.a -L/home/gizmo/central/sm-opt/mozilla/dist/bin -lxpcom -lmozalloc -L/home/gizmo/central/sm-opt/mozilla/dist/bin -lxpcom -lmozalloc -lxul  -L/home/gizmo/central/sm-opt/mozilla/dist/bin -lxpcom -lmozalloc -lxul  `/home/gizmo/central/sm-opt/mozilla/dist/sdk/bin/nspr-config --prefix=/home/gizmo/central/sm-opt/mozilla/dist --libdir=/home/gizmo/central/sm-opt/mozilla/dist/lib --libs`  -ldl -lm 

This happens on both Fedora 16 64-bit and Fedora 14 64-bit
(Assignee)

Comment 1

5 years ago
I've tried building both SM and TB with the same failure.
My .mozconfig for each application has the following common lines in:
ac_add_options --enable-debugger-info-modules="yes"
ac_add_options --enable-optimizer="-O2 -gstabs+"
mk_add_options MOZ_MAKE_FLAGS="-j4"
ac_add_options --with-ccache=/usr/bin/ccache

Comment 2

5 years ago
Mine too, Fedora 16 64-bit and Fedora 17 Beta 64-bit

Comment 3

5 years ago
<https://dev.openwrt.org/ticket/9235>
"the problem is caused by newer versions of gcc/binutils, which are trying to fix a potential pitfall by disallow implicit -l. (more detail here:  http://fedoraproject.org/wiki/UnderstandingDSOLinkChange ) Specifically, 'cc1-dummy' requires libstdc++, but doesn't reference it. Older versions of ld would "steal" libstdc++ via libgmpxx; newer versions, however, are disallowing that."

<http://lists.debian.org/debian-devel-announce/2011/02/msg00011.html>
(Assignee)

Comment 4

5 years ago
cc'ing some m-c people that might know if a similar issue has been fixed there (or needs to be)
See bug 743988 and bug 744444
(Assignee)

Comment 6

5 years ago
Created attachment 617091 [details] [diff] [review]
Port bug 743988 [Checked in: Comment 7]

rs=Callek via IRC

Just building to make sure it definitely fixes though before checkin
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #617091 - Flags: review+
(Assignee)

Comment 7

5 years ago
Comment on attachment 617091 [details] [diff] [review]
Port bug 743988 [Checked in: Comment 7]

http://hg.mozilla.org/comm-central/rev/b080eb5a2993 (incorrect checkin message)
http://hg.mozilla.org/comm-central/rev/cb9827f38e5e (backed out)
http://hg.mozilla.org/comm-central/rev/aa0c1a3d11f5 (correct checkin message)
Attachment #617091 - Attachment description: Port bug 743988 → Port bug 743988 [Checked in: Comment 7]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
status-seamonkey2.11: --- → fixed
Target Milestone: --- → Thunderbird 14.0
Depends on: 743988
Flags: in-testsuite-
(Assignee)

Updated

5 years ago
Blocks: 754065
You need to log in before you can comment on or make changes to this bug.