If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"New mail" tray icon does not automatically disappear when all messages are read

RESOLVED DUPLICATE of bug 748997

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 748997
6 years ago
6 years ago

People

(Reporter: antimatter, Unassigned)

Tracking

12 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When new mails arrive a new mail icon appears in the system tray. When all mails are read, this icon should disappear. But it does not. Only changing to a new mail folder makes the icon disappear.

On April 24th 2012, I upgraded Thunderbird to the new version 12. Before, this bug was not present. So I assume, this bug was introduced with version 12 of Thunderbird.

Comment 1

6 years ago
(In reply to antimatter from comment #0)
Can you tell us what version you use? You can get this info from Help ➯ Troubleshooting Information.
(Reporter)

Comment 2

6 years ago
If you refer to the section "General Information" (or similar; I use the German localization), the version is this:

Version: 12.0
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120420 Thunderbird/12.0
Build-ID: 20120420153905

Comment 3

6 years ago
If you are using a POP account with messages set to be left on the server, let's dupe this report against bug 749282, which is more recent but has already some discussion and dependencies set up. In general, the issue apparently was caused by the new pluggable mailstores feature introduced with 12.0 (bug 402392).
(Reporter)

Comment 4

6 years ago
Yes, I am using POP with messages set to be left on the server.

Furthermore, I'd like to add some more information, as I have ran some tests regarding the bug. These are my observations:
When one or more new messages arrive in the inbox, the systray icon shows up. This is ok. Now, when I click one of those messages, the icon suddenly goes away although there are unread messages in the inbox. I'm not quite sure, how this was with version 11, but I guess the tray icon should not go away until all new messages are read.

And second (more important), after a while, the tray icon shows up again even if all new messages are read. The moment the icon shows up is the same moment, when Thunderbird next checks for new mails on the server. But there aren't any new messages. Besides the falsely displayed icon, the "Local folder" item in the tree has a blue font color and the statusbar says "1 message downloaded" (or similiar in english).
To make things stranger, this bug (falsely displayed icon) apparently only happens if a single mail was downloaded (for real) during the last server check. It doesn't happen with 2 or more mails.

I don't know, why this is happening differently now as described in the initial comment.

Note, that all addons were disabled while I made these observations.

But as you already mentioned, my report is related to the other report you mentioned above, as they probably have the same bug that's causing these effects.

Comment 5

6 years ago
(In reply to antimatter from comment #4)
> When one or more new messages arrive in the inbox, the systray icon shows
> up. This is ok. Now, when I click one of those messages, the icon suddenly
> goes away although there are unread messages in the inbox.

I think this has been the way it works in earlier versions as well, where I'm using IMAP but not POP myself. The account would stay bolded as long as there are new messages, but the new-mail icon in the tray disappears once the first one is read.

> And second (more important), after a while, the tray icon shows up again
> even if all new messages are read. The moment the icon shows up is the same
> moment, when Thunderbird next checks for new mails on the server.

This looks more like bug 748997 now than the initial one I've guessed, which has already a patch posted for review (and may fix both issues). Thus, I'm marking your report as a duplicate and hope that the proposed fix will work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748997
You need to log in before you can comment on or make changes to this bug.