Save name in all locales provided in manifest during submission

RESOLVED DUPLICATE of bug 893855

Status

RESOLVED DUPLICATE of bug 893855
6 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: robhudson)

Tracking

Points:
---

Details

(Whiteboard: p=1)

(Reporter)

Description

6 years ago
If an app manifest specifies multiple locale support, we should extract that info.
(In reply to krupa raj 82[:krupa] from comment #0)
> If an app manifest specifies multiple locale support, we should extract that
> info.

Extract and do what with it?
Component: Public Pages → Developer Pages
Product: addons.mozilla.org → Marketplace
Version: unspecified → 1.0
(Assignee)

Comment 2

6 years ago
At least for the app cron that fetches manifests nightly, we extra all the locales and add/update the translations for the app if we support the locale. That was bug 828737.

I quick look at the code during app submission, we are only saving the default_locale.

Would this bug then be to save all supported locales during app submission?
(Assignee)

Updated

6 years ago
Summary: Extract locale information from manifest → Save name in all locales provided in manifest during submission
(Assignee)

Updated

6 years ago
Assignee: nobody → robhudson.mozbugs
can you fill in points?
Flags: needinfo?(robhudson.mozbugs)
Whiteboard: p=
(Assignee)

Updated

6 years ago
Whiteboard: p= → p=1
(Assignee)

Comment 4

5 years ago
Added points. Adding a comment to clear the needinfo flag.

We should probably fix this some day.
Flags: needinfo?(robhudson.mozbugs)
Had not seen this bug before starting working on bug 893855, mine has more info and associated commits so I'll dupe this one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893855
You need to log in before you can comment on or make changes to this bug.