Bidi: Unicode Arabic text in table not connected

RESOLVED INVALID

Status

()

Core
Layout: Text
P2
normal
RESOLVED INVALID
18 years ago
10 years ago

People

(Reporter: Maha Abou El-Rous, Assigned: smontagu)

Tracking

({intl})

Trunk
Future
x86
Windows 98
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    00000000 - Bidi build dated 20010404

Arabic Unicode text is displayed disconnected (not properly shaped) in file 
Ken.htm

Reproducible: Always
Steps to Reproduce:
1.Open file Ken.htm


Actual Results:  Arabic text is displayed disconnected all in Middle character 
shapes

Expected Results:  View same file on IE5 for correct character shapes
(Reporter)

Comment 1

18 years ago
Created attachment 29938 [details]
Unicode text in table

Comment 2

17 years ago
focus on landing IBMBIDI without breaking Latin and CJK on moz0.9. move bidi 
functional bug to moz0.9.1
Target Milestone: --- → mozilla0.9.1

Comment 3

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang

Comment 4

17 years ago
mark it as assign
Status: NEW → ASSIGNED

Comment 5

17 years ago
decommit other bidi issue until we land IBMBIDI default on.

Updated

17 years ago
Target Milestone: mozilla0.9.1 → ---

Comment 6

17 years ago
reassign to simon@softel.co.il
Assignee: ftang → simon
Status: ASSIGNED → NEW

Comment 7

17 years ago
Changing QA contact to mahar@eg.ibm.com.
QA Contact: andreasb → mahar

Updated

17 years ago
Keywords: intl
(Assignee)

Updated

17 years ago
Depends on: 81194

Comment 8

17 years ago
Ftang - Is this a beta stopper, or will Arabic support not be complete for nsbeta1?
Keywords: nsbeta1

Comment 9

17 years ago
Marking as nsbeta1-. Arabic support will not be in until M0.9.2 window
Keywords: nsbeta1 → nsbeta1-

Comment 10

17 years ago
Assigning M0.9.2 | P2. I think we need this for RTM.
Keywords: rtm
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2

Comment 11

17 years ago
Setting dependency on Shaping (82383) to have correct shaping and Bidi UI 
(85420) to set text type visual/logical for correct order.
Depends on: 82383, 85420
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 12

17 years ago
Ftang - Does it look like Arabic will be supported in the final release?
(Assignee)

Comment 13

17 years ago
I'm not sure why this has a milestone but is dependent on bugs that don't.
Resetting component while I'm here.
Component: Internationalization → BiDi Hebrew & Arabic
Target Milestone: mozilla0.9.3 → ---

Comment 14

17 years ago
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: mahar → zach

Comment 15

17 years ago
arabic contact to maha.
QA Contact: zach → mahar
(Assignee)

Comment 16

17 years ago
Created attachment 48281 [details]
Reduced testcase in logical UTF-8
(Assignee)

Comment 17

17 years ago
Can someone confirm whether the testcase in attachment 48281 [details] is in fact valid?
It seems to me that the characters are wrong in the source file. For example the
word for "Arabic" in the "Native Language" column is always spelt with character
FE90; ARABIC LETTER BEH FINAL FORM, but I believe it should be FE91; ARABIC
LETTER BEH INITIAL FORM.

Apart from that and some other cases, the display seems correct to me (tested on
Bidi enabled and US Windows NT), and I think this can be marked FIXED.

Comment 18

17 years ago
True there are some characters having the wrong shapes, but this was not the problem 
reported. the output was displayed in a totally different manner than IE5 which was the 
reference in this case. IE5 handles UTF-8 as a visual charset. we need to define it as 
such.
Adjusting dependency on 81664 to have correct display on Bidi & non-Bidi systems.
Attaching a fix to define UTF-8 as visual charset.  
Depends on: 81664
No longer depends on: 81194, 82383, 85420

Comment 19

17 years ago
Created attachment 49003 [details] [diff] [review]
patch to set UTF-8 as a visual codepage
(Assignee)

Comment 20

17 years ago
Maha: This bug is separate from the problem with the ordering of UTF-8, which is
bug 75004. That was closed as invalid after I commented:

>The Arabic Hebrew and Farsi text in this example are in visual order (which is
>incorrect for UTF-8) so Mozilla's behaviour here is correct.
>
>On selecting Bidi Options | Text Type | Visual, the text is displayed as >expected.
>
>The Arabic and Farsi are displayed correctly in IE5 because two errors are
>cancelling one another out: the visual order and the fact that IE5 doesn't
>classify Bidi characters in the FExx range as right-to-left. Note that the
>Hebrew text is displayed reversed in IE5 and AFAIK there is no way in the UI to
>correct this.

Notice that UTF-8 pages with Arabic in the 06xx range are displayed as logical
in both IE and Mozilla, for example http://www.unicode.org/iuc/iuc10/x-utf8.html

Comment 21

17 years ago
Simon, you are right, the example got me confused. 
As far as this bug is concerned we only need patch in bug# 81664 in order to have similar 
display on Bidi & non-Bidi systems. Please disregard the latest patch I attached.
We also need the Bidi options present so we have correct display by forcing the TextType 
visual, adding dependency on #85420
Depends on: 85420

Updated

17 years ago
Blocks: 115713
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Target Milestone: --- → Future

Comment 22

16 years ago
Kindly be informed that Ahmad A. Abu-Taha (ahtaha@eg.ibm.com) from IBM Egypt is 
replacing Maha Abou El-Rous (mahar@eg.ibm.com) in monitoring and receiving 
notifications of Mozilla bugs regarding Arabic.
Resolving as INVALID given the comments above (and the fact that we no longer support Win98, and that if there ever was a real problem reported here, it's long gone).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: mahar → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.