Closed Bug 81194 Opened 19 years ago Closed 19 years ago

need to clean up Arabic shaping code in nsBidiUtilsImp.cpp

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: ftang, Assigned: smontagu)

References

Details

(Keywords: meta)

The Arabic shaping code in nsBidiUtilsImp.cpp is currently not working since we 
#ifdef FULL_ARABIC_SHAPING
the issue is we have a lot of array boundary violation in that code. 
simon- can you forward this to the right person (ahmed?) to work on ?
It will be nice if they can explain what they try to do there. I can help them 
to write that routine since I code the origional one in the GFX.

Also, see 80167
make sure we test 75026 before turn FULL_ARABIC_SHAPING on.
Blocks: 26371
Blocks: 75009
Changing QA contact to mahar@eg.ibm.com.
QA Contact: andreasb → mahar
ok, there are different shaping code in nsBidiUtils, some are used for display 
and some are used for copy&paste. I think the priority are differents. Also, 
the quality of the current code quality are different in these routines. Some 
are better than the other, therefore, I break it down into 4 bugs 
82089 nsBidiUtilsImp::ArabicShaping should be turn on 
82093 bidi: arabic: Conv_FE_06 in intl/unicharutil/src/nsBidiUtils 
82096 bidi- arabic- need to turn on nsBidiUtilsImp::Conv_FE_06_WithReverse
82097 bidi- arabic- need to turn on nsBidiUtilsImp::Conv_06_FE_WithReverse

I think 82089 is important than others since it is used for non BIDI system 
Arabic display. The other three are used by copy&paste and form code

change this bug to meta bugs and reassign back to ftang
Assignee: simon → ftang
Depends on: 82089, 82093, 82096, 82097
Keywords: meta
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
remove milestone.
Target Milestone: mozilla1.0 → ---
reassign to simon
Assignee: ftang → simon
Status: ASSIGNED → NEW
depends on 82383 new ICU shaping
Depends on: 82383
Blocks: 82356
This bug has been superseded by bug 97297
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
There is no bug 97297. You should mean bug 92797.
Thanks for the correction, Roozbeh. Bug 92797 is what I meant.
No longer blocks: 75009
You need to log in before you can comment on or make changes to this bug.