Implement reading list navigation at the bottom of reader view articles

RESOLVED WONTFIX

Status

()

P2
normal
RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: lucasr, Unassigned)

Tracking

(Blocks: 1 bug, {uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
The initial idea is that you'd have 2 ways of going to next and previous item in your reading list while in the reader (about:reader).

1. Toolbar with next/previous buttons (toolbar would show when user taps on the screen and fade away after a timeout)
2. Swipe right/left
(Reporter)

Updated

7 years ago
Component: General → Reader Mode
(Reporter)

Comment 2

7 years ago
Ian, we can use this bug to track design and implementation work on the "proper" access to reading list from reader mode.
(Reporter)

Updated

7 years ago
Priority: -- → P2
(Reporter)

Comment 3

6 years ago
Ian, any thoughts in terms of UI here?
Flags: needinfo?(ibarlow)
I have some, yes. I plan to have a more comprehensive set of Reader updates towards the end of next week.
Flags: needinfo?(ibarlow)
Blocks: 866766
(Reporter)

Updated

6 years ago
Keywords: uiwanted
(Reporter)

Updated

6 years ago
Blocks: 917884
(Reporter)

Updated

6 years ago
No longer blocks: 696921, 866766
Yuan, I know you've been working on some updated reader mode designs. Have you thought about this at all?
Flags: needinfo?(ywang)
I also just commented in bug 871593, since that seems very similar to this bug. If they are indeed separate issues, we should make a design that includes both aspects :)

Updated

4 years ago
Duplicate of this bug: 871593

Updated

4 years ago
Summary: Reader Mode: Implement reading list navigation in the reader → Implement reading list navigation at the bottom of reader view articles
Attaching updated design.
(In reply to Anthony Lam (:antlam) from comment #8)
> Created attachment 8582535 [details]
> prev_endofarticle1.png
> 
> Attaching updated design.

Sweet. We should make a trello card for this to get it in the funnel.

To implement this, we'll need to pass a message to Java to ask for the next item in the reading list. We already send a message to ask whether or not the item is in the reading list, so maybe we could just piggy-back that next article data into the result for that.

We'll have to bit a bit careful, since the about:reader JS/HTML is shared with desktop, but we can easily hide elements that aren't used on desktop (we already do this with some of the platform-specific toolbar buttons).
We're not going to continue investing in the reading list, so we shouldn't fix this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.