The default bug view has changed. See this FAQ.

Network geolocation provider fails to get wifi data

RESOLVED FIXED in Firefox 14

Status

()

Core
Geolocation
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: reuben, Assigned: dougt)

Tracking

({regression})

Trunk
mozilla15
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
While testing with http://html5demos.com/geo, a friend was getting weird values for the location on Linux. I can reproduce it on OSX. On https://mxr.mozilla.org/mozilla-central/source/dom/system/NetworkGeolocationProvider.js#194 |accessPoints| is always null, and thus we fallback to Google's IP-based lookup. When testing in my own debug build everything works as expected, though.
(Assignee)

Updated

5 years ago
Assignee: nobody → doug.turner
(Assignee)

Comment 1

5 years ago
i don't see this in my local builds either, but it is clearly busted in the nightly.

Components.interfaces.nsIWifiMonitor isn't defined in the nightly.


Reuben,

Could you (and your friend) try one of these builds?  https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dougt@mozilla.com-32c03fc9fda6/
(Reporter)

Comment 2

5 years ago
(In reply to Doug Turner (:dougt) from comment #1)
> Reuben,
> 
> Could you (and your friend) try one of these builds? 
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dougt@mozilla.com-
> 32c03fc9fda6/

Works as expected for me.
Aurora is affected by this so you might wanna land that patch there as well.
(Reporter)

Updated

5 years ago
status-firefox14: --- → affected
(Assignee)

Comment 3

5 years ago
Created attachment 621110 [details] [diff] [review]
patch v.1
Attachment #621110 - Flags: review?(ted.mielczarek)
Attachment #621110 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c675215939ef
(Assignee)

Comment 5

5 years ago
.
(Assignee)

Updated

5 years ago
tracking-firefox14: --- → ?
https://hg.mozilla.org/mozilla-central/rev/c675215939ef
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
(Assignee)

Comment 7

5 years ago
we do want this on 14.

Comment 8

5 years ago
Sounds good - please nominate for Aurora 14.
tracking-firefox14: ? → +
(Reporter)

Comment 9

5 years ago
Comment on attachment 621110 [details] [diff] [review]
patch v.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Geolocation regression
User impact if declined: Geolocation is not accurate.
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): none (?)
String or UUID changes made by this patch: none
Attachment #621110 - Flags: approval-mozilla-aurora?
Comment on attachment 621110 [details] [diff] [review]
patch v.1

[Triage Comment]
Approved for Aurora 14.
Attachment #621110 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/38cf9bdc6fea
status-firefox14: affected → fixed
Blocks: 739132, 769655
Keywords: regression
You need to log in before you can comment on or make changes to this bug.