Last Comment Bug 739132 - --disable-necko-wifi causes "Error: package error or possible missing or unnecessary file: bin/components/necko_wifi.xpt"
: --disable-necko-wifi causes "Error: package error or possible missing or unne...
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Landry Breuil (:gaston)
:
:
Mentors:
Depends on: 751597
Blocks: 479898 713132 745998
  Show dependency treegraph
 
Reported: 2012-03-25 22:25 PDT by Joseph Felps
Modified: 2012-07-03 15:31 PDT (History)
6 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
package necko_wifi.xpt only if NECKO_WIFI is set (1.00 KB, patch)
2012-04-07 01:46 PDT, Landry Breuil (:gaston)
khuey: review+
bugzillamozillaorg_serge_20140323: feedback+
Details | Diff | Splinter Review

Description Joseph Felps 2012-03-25 22:25:05 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0a1
Build ID: 20120322012233

Steps to reproduce:

When trying to make install from a trunk build I now get this error:

bin/comError: package error or possible missing or unnecessary file: bin/components/necko_wifi.xpt (package-manifest, 145).

This seems to be recent error, because I had a clean install 2-3 weeks ago.  Don't know if it helps but I build with ac_add_options --disable-necko-wifi.
Comment 1 Landry Breuil (:gaston) 2012-04-07 01:46:20 PDT
Created attachment 613078 [details] [diff] [review]
package necko_wifi.xpt only if NECKO_WIFI is set
Comment 2 Serge Gautherie (:sgautherie) 2012-04-07 05:47:10 PDT
Comment on attachment 613078 [details] [diff] [review]
package necko_wifi.xpt only if NECKO_WIFI is set

I assume that should be it.
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-10 08:40:14 PDT
Please verify that NECKO_WIFI is actually defined when appropriate here.
Comment 4 Landry Breuil (:gaston) 2012-04-10 08:50:43 PDT
https://tbpl.mozilla.org/?tree=Try&rev=dd6725b05966
Comment 5 Landry Breuil (:gaston) 2012-04-10 23:10:04 PDT
All green on try (besides a spurious unrelated win64 failure, retriggered); setting checkin-needed.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-04-11 05:03:27 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/83b64bb97f25
Comment 7 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-11 06:00:06 PDT
(In reply to Landry Breuil from comment #5)
> All green on try (besides a spurious unrelated win64 failure, retriggered);
> setting checkin-needed.

You didn't run the unit tests ...
Comment 8 Landry Breuil (:gaston) 2012-04-11 06:12:08 PDT
Isnt packaging done in the regular build step ?

Note You need to log in before you can comment on or make changes to this bug.