Last Comment Bug 752117 - Icons with 96x96 or 512x512 icon size in manifest results in no icon generated on win 7 on app install
: Icons with 96x96 or 512x512 icon size in manifest results in no icon generate...
Status: RESOLVED WONTFIX
: dev-doc-complete
Product: Firefox Graveyard
Classification: Graveyard
Component: Web Apps (show other bugs)
: 15 Branch
: x86_64 Windows 7
: P3 normal
: ---
Assigned To: Nobody; OK to take it and work on it
: Jason Smith [:jsmith]
Mentors:
Depends on:
Blocks: 1111077
  Show dependency treegraph
 
Reported: 2012-05-04 17:27 PDT by Jason Smith [:jsmith]
Modified: 2016-02-04 15:00 PST (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
No Chrome Directory with Multiple Icons (287.25 KB, image/png)
2012-05-04 17:27 PDT, Jason Smith [:jsmith]
no flags Details

Description Jason Smith [:jsmith] 2012-05-04 17:27:36 PDT
Created attachment 621227 [details]
No Chrome Directory with Multiple Icons

Steps:

1. Install an application that contains references to icons that are (16x16, 32x32, 48x48, 64x64, 96x96, 128x128, 256x256, 512x512)

Expected:

The desktop shortcut and start menu items should contain an icon. %APPDATA% should also have a chrome directory with the appropriate icon to use for the desktop shortcut and start menu.

Actual:

No icon is generated. Checking %APPDATA% - Looks like no chrome directory was generated. The result - No icon for desktop shortcut or start menu item.

Sample manifest I used:

{
	"name": "Pipedrive Multi",
	"description": "Simple and powerful sales pipeline management tool",

	"launch_path": "/testcases/fancybox.html",

	"installs_allowed_from": ["*"],
	
	"icons": {
		"16": "/appinstall/_pipedrive_16x16.png",
		"32": "/appinstall/_pipedrive_32x32.png",
		"48": "/appinstall/_pipedrive_48x48.png",
		"64": "/appinstall/_pipedrive_64x64.png",
		"96": "/appinstall/_pipedrive_96x96.png",
		"128": "/appinstall/_pipedrive_128x128.png",
		"256": "/appinstall/_pipedrive_256x256.png",
		"512": "/appinstall/_pipedrive_512x512.png"
	},
	
	"developer":
	{
		"url": "http://quality.mozilla.org",
		"name": "Mozilla QA"
	}
}

Example Test App from Marketplace: https://marketplace.mozilla.org/en-US/app/pipedrive-crm/
Comment 1 Jason Smith [:jsmith] 2012-05-04 17:32:04 PDT
Random Question - What is our algorithm for choosing an icon from a list of icons?
Comment 2 Jason Smith [:jsmith] 2012-05-04 17:34:30 PDT
Tested also the same marketplace app on Mac - This does not happen on Mac. This is a windows-specific bug.
Comment 3 Jason Smith [:jsmith] 2012-05-04 17:50:31 PDT
Felipe explained to me that the largest icon is chosen when there are multiple icons. Also, this may be a problem with what icon sizes we support. I'll dig into this to figure out a matrix of icons that work and that do not work.
Comment 4 Jason Smith [:jsmith] 2012-05-04 18:05:02 PDT
Test Results:

- 16x16: Pass
- 32x32: Pass
- 48x48: Pass
- 64x64: Pass
- 96x96: Fail
- 128x128: Pass
- 256x256: Pass
- 512x512: Fail
Comment 5 Jason Smith [:jsmith] 2012-05-09 15:44:23 PDT
We need to define what icon sizes we intend to support. Flagging dev-doc-needed.
Comment 6 Mark Giffin [:markg] 2012-06-28 15:17:05 PDT
Manifest doc is fixed.

https://developer.mozilla.org/en/Apps/Manifest#Fields
Comment 7 Daniel 2015-01-15 11:36:46 PST
Still an issue with Firefox 35 on both Windows 7 and 8. Linux and Mac has no issue. Confirmed with my own manifest and with a handful of manifests from the Marketplace.

All web app documentation everywhere claims 512px icons are required. Which would lead to a lot of iconless app installs for Windows users.
Comment 8 Myk Melez [:myk] [@mykmelez] 2016-01-25 14:01:00 PST
Per bug 1238079, we're going to disable the desktop web runtime and remove it
from the codebase, so we won't fix these bugs in the integration between Firefox and the runtime.

Note You need to log in before you can comment on or make changes to this bug.