can't make liveconnect calls from javascript to applet's method

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Calvin Cheung, Assigned: johns)

Tracking

({regression, testcase})

unspecified
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14+ unaffected, firefox15+ unaffected, firefox16 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 621789 [details]
liveconnect (javascript calling applet's method) testcase 1

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E; BRI/2; .NET CLR 2.0.50727)

Steps to reproduce:

Using the nightly 15.0a1 (2012-05-07) from http://nightly.mozilla.org/.
Tested on windows XP with JRE 7u4 (downloaded from java.com).

Ran some liveconnect (javascript calling into applet's method) testcases.

I'm attaching 2 testcases.
Both are liveconnect calls from javascript into applet's method.
The class files were compiled with jdk7.

StringTest - calls into applet's method upon "OnLoad"
JSJavaTest1 - calls into applet's method upon clicking on the javascript
button.

My observation is that the java plugin module (npjp2.dll) wasn't loaded when
running the above tests.




Actual results:

Nothing happened.


Expected results:

Liveconnect calls should be successful.
(Reporter)

Comment 1

5 years ago
Created attachment 621790 [details]
liveconnect (javascript calling applet's method) test case 2

Updated

5 years ago
Assignee: nobody → joshmoz

Updated

5 years ago
Assignee: joshmoz → nobody
Blocks: 748343
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: untriaged → general
Requesting tracking for the regression.
tracking-firefox15: --- → ?

Comment 3

5 years ago
Assigning back to Josh
Assignee: nobody → joshmoz

Comment 4

5 years ago
My debugging indicates that this is failing because we fail to create a Java plugin instance because we don't have an object frame. This makes me think this is a regression from bug 90268 or its follow-up fixes, not from the DOM object removal. The fact that this bug exists on Aurora, where we didn't remove the DOM object support, confirms my theory.

Comment 5

5 years ago
This works in the current Firefox 13 Beta, but not the current Firefox 14 Aurora or Firefox 15 Nightly.

This means bug 748343 isn't the regressing bug, removing it from the deps.
No longer blocks: 748343

Updated

5 years ago
Summary: fix for 748343 prevents liveconnect calls from javascript to applet's method → can't make liveconnect calls from javascript to applet's method

Updated

5 years ago
Version: 15 Branch → 14 Branch

Updated

5 years ago
tracking-firefox14: --- → ?
Duplicate of this bug: 753280
Tracking for 14, can we get a regression range here?
status-firefox14: --- → affected
status-firefox15: --- → affected
tracking-firefox14: ? → +
tracking-firefox15: ? → +
Keywords: regressionwindow-wanted

Updated

5 years ago
Keywords: testcase

Comment 8

5 years ago
From hg bisect:

The first bad revision is:
changeset:   87974:1e4675fb8fc9
user:        John Schoenick <jschoenick@mozilla.com>
date:        Mon Feb 27 13:58:00 2012 -0800
summary:     Bug 406541 - Ensure we agree with java on applet codebase, and run security checks for file: codebase URIs. r=jst
Depends on: 406541
(Assignee)

Updated

5 years ago
Depends on: 745030
(Assignee)

Comment 9

5 years ago
406541 exposed several issues in the objectloadingcontent code, 745030 should fix this
Assignee: joshmoz → jschoenick
Status: NEW → ASSIGNED
Component: DOM → Plug-ins
Keywords: regressionwindow-wanted
OS: Windows XP → All
QA Contact: general → plugins
Hardware: x86 → All
(Assignee)

Comment 10

5 years ago
Note that 406541 is going to be backed out from 14 due to all the issues depending on 745030, which will be too big a change for backporting

Comment 11

5 years ago
This bug blocks bug 406541 and doesn't depend on it. Can someone change the dependency?
Blocks: 406541
No longer depends on: 406541
(In reply to John Schoenick [:johns] from comment #10)
> Note that 406541 is going to be backed out from 14 due to all the issues
> depending on 745030, which will be too big a change for backporting

John - are you planning to fix this for FF14 (shipping in 4 weeks), or would you like to make the case for untracking? We haven't seen a status update here in a while.
(Assignee)

Comment 13

5 years ago
This is a similar regression to bug 736965, so my comments there apply - bug 745030 is the proper fix for this, but 406541 will be backed out of the affected versions until 745030 is ready (a rather large patch). 

This could probably be duped against bug 736965, but I'd like to keep it open to make sure we've covered all known regression issues. It is probably redundant to track it, however
status-firefox14: affected → unaffected
status-firefox16: --- → affected
Version: 14 Branch → 15 Branch
(Assignee)

Comment 14

5 years ago
Bug 406541 has been backed out of all branches, so this regression should be no more
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox15: affected → unaffected
status-firefox16: affected → unaffected
Resolution: --- → FIXED
Version: 15 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.