Closed Bug 753673 Opened 8 years ago Closed 6 years ago

In-content preferences Navigation broken after clearing History

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: ge3k0s, Unassigned)

References

Details

When you have the preferences or the add-on manager open and "you clean recent history" the the backward-forward arrows aren't working anymore. They are still click-able, but make nothing. Preferences and Add-on manager shouldn't be part of browsing history and you should be able to navigate even while cleaning history.
Blocks: 718011
I confirm this bug at Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120621 Firefox/15.0a2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [testday-20120622]
Version: unspecified → Trunk
Splitting this up: Bug 769901 is for the AOM Case now.
Summary: In-content preferences and Add-on manager not navigable anymore after cleaning history → In-content preferences Navigation broken after clearing History
Whiteboard: [testday-20120622] → [testday-20120622] p=0
Duplicate of this bug: 872957
Whiteboard: [testday-20120622] p=0 → p=0
Whiteboard: p=0 → p=8
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Since the in-content pages are now treated as normal pages (ie URL bar is always visible) I think this bug isn't valid anymore.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: p=8 → p=0 s=it-31c-30a-29b.3 [qa?]
Florin, please make sure this gets tested.
QA Contact: florin.mezei
Whiteboard: p=0 s=it-31c-30a-29b.3 [qa?] → p=0 s=it-31c-30a-29b.3 [qa+]
QA Contact: florin.mezei → camelia.badau
As Guillaume C. said in comment 4, the bug isn't valid anymore because the in-content pages (in-content preferences) are normal pages, with URL bar always visible. 

I tested with the latest Nightly 31.0a1 on Windows 7 X64,on Ubuntu 13.10 x86 and on Mac OS X 10.9.
Whiteboard: p=0 s=it-31c-30a-29b.3 [qa+] → p=0 s=it-31c-30a-29b.3 [qa!]
(In reply to Guillaume C. [:ge3k0s] from comment #4)
> Since the in-content pages are now treated as normal pages (ie URL bar is
> always visible) I think this bug isn't valid anymore.

It's rather invalid since changing panes does not affect browsing history anymore at all, not because of having a URL bar per se.

The AOM also has a URL bar (in Firefox; in Thunderbird it doesn't) but is still affected - see Bug 769901.
Resolution: WORKSFORME → INVALID
Flags: firefox-backlog+
Whiteboard: p=0 s=it-31c-30a-29b.3 [qa!] → [qa!]
Flags: firefox-backlog-
Whiteboard: [qa!]
You need to log in before you can comment on or make changes to this bug.