Danish, Finnish and Japanese are not localized in the Multi locale nightly

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

14 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

1. install nightly multilocale
2. switch android os to Japanese
3. launch nightly

Expected: Japanese
Actual: English

See : https://wiki.mozilla.org/QA/Fennec/SingleToMultiLocaleNative
Note: Aurora looks fine.

Comment 1

6 years ago
I see we added both da and ja successfully to the multilocale build via the logs.
I'm not sure about this.

Comment 2

6 years ago
mozilla-central l10n repos:

 http://hg.mozilla.org/l10n-central/da/
 last change: 2011-04-25 10:22 +0200

 http://hg.mozilla.org/l10n-central/fi/
 last change: 2011-07-08 15:16 +0300

 http://hg.mozilla.org/l10n-central/ja/
 last change: 2011-05-21 10:49 +0900


mozilla-aurora l10n repos:

 http://hg.mozilla.org/releases/l10n/mozilla-aurora/da/
 last change: 2012-05-11 02:43 +0200

 http://hg.mozilla.org/releases/l10n/mozilla-aurora/fi/
 last change: 2012-05-02 21:36 +0300

 http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/
 last change: 2012-05-10 16:37 -0700


I know some localizers have abandoned mozilla-central in favor of only localizing mozilla-aurora.  It looks like that's true of these three locales.

I'm not sure if that means we want a different set of multilocale locales for m-c than m-a, or if we want to point those users to the aurora apk, or what, but from a RelEng perspective, things appear to be working as designed.
explains a lot... maybe we should pass to pike?

Comment 4

6 years ago
Resolving WORKSFORME.

There's a bigger bug about what to do with locales not working on nightlies anymore, and if we'd clean up all-locales this would go away.

Not sure if there'd be similar problems for doing this for mobile as for desktop.

Resolving this worksforme, though there should be localized strings in some corners of the product, like error console messages. Like things that are old and far away from the native UI.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Just wondering, is there a bug number for the bigger bug?

I'm comfortable with the WFM.
(In reply to Naoki Hirata :nhirata from comment #5)
> Just wondering, is there a bug number for the bigger bug?
> 
> I'm comfortable with the WFM.

Bug#655129 track the first batch of locales no longer being actively developed on m-c. Bug#713159 tracks the next batch of locales.

As requested by l10n, RelEng continues to generated these localized nightly builds on m-c until we have custom updates to migrate any desktop users of those locales to mozilla-aurora. Bug#657789 tracks the custom update work.
You need to log in before you can comment on or make changes to this bug.