Add Windows XP to OS list

VERIFIED FIXED

Status

()

VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: bugzilla, Assigned: myk)

Tracking

Details

(Reporter)

Description

18 years ago
Need to add Windows XP.
Target Milestone: --- → Bugzilla 2.16
(Reporter)

Comment 1

18 years ago
Some people (like me) are already using Windows XP for bug reporting.  This is 
easily fixed, no?
site-specific -> mozilla.org
Assignee: tara → endico
Component: Bugzilla → Bugzilla: Other moz.org Issues
Product: Webtools → mozilla.org
QA Contact: matty → myk
Target Milestone: Bugzilla 2.16 → ---
Version: Bugzilla 2.10 → other

Comment 3

18 years ago
Convince me that Windows is XP and I'll do it.
I'm not convinced we should add an OS that is not released yet.

Comment 5

18 years ago
Likewise, I would appreciate having XP on the OS list since I'm running it. 
Matty: Didn't we have OS X on the OS list before it went gold?
(Reporter)

Comment 6

18 years ago
Yes, and we had Windows ME as well.  Evidently the resistance in this case 
(from Dawn, at least) is partly that the operating system's name dilutes the 
meaning of XP.  Unfortunately, this _is_ the name Microsoft has chosen (and 
yes, the entire Office XP suite is already out), so I don't see what the 
trouble is.
(Reporter)

Comment 7

18 years ago
Windows is going to be called Windows XP.  It just is. I'm on the latest build 
now.  Office XP is out.  The operating system is called Windows XP, and us 
refusing to add it to our bug tracking system won't change that.

So now that I've got an XP-only bug in hand with no true way to report it, can 
we please just add this operating system?

Comment 8

18 years ago
*** Bug 90549 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Please add this.  We are getting bugs filed which are specific to Windows XP and 
there is not a good way to track those bugs via query.  We probably want to make 
sure Mozilla continues to get testing against Windows XP (before Windows XP) 
ships to make sure Mozilla is compatible with this OS and providing the choice 
of Windows XP in the OS field helps to categorize these specific bugs to WinXP.
*** Bug 92765 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
This is a valid request. Expecially since some of us who bang on Mozilla as a 
hobby are doing so under WinXP, and there is already a WinXP meta tracking bug. 
Bug 67221

Resistance or not, this is a valid request, and saying because it's not out yet 
is silly. Sure, it's not retail yet, neither is Mozilla. Ever think that people 
are using Moz on WinXP to test?

Comment 12

17 years ago
*** Bug 97221 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
XP has now gone gold. It will be released for sale in October, but will be 
loaded on new PCs before that.

Comment 14

17 years ago
bug 62663 detailed setting up moz to give an NT5.1 useragent string for WinXP so
bug 98999 was reported as OS: Windows NT

This is decidedly confusing and this clearly shows that soon we will have lots
of people installing WinXP and reporting bugs under WinNT(because of the UA
String), Win2k(because they know XP is 2kV2) or Other(because they know it
doesn't fit under the existing categories and that's what other is for).

If there is opposition to the use of the term XP it could be Win eXPerienced (Yuk)

Comment 15

17 years ago
While I agree Microsoft shouldn'thave chosen XP as it's even more meaningless
than ME, it was supposed to stand for eXPerience, as though the Windows
experience was so wonferful that it was a religious event, if someone has a
problem with it, tough. They named it Windows XP, and so that's what we need to
add to track it. We've got Win95, 98, ME was added when they shoved that on
shelves, and Win2k as well. I'm sorry if someone objects to it, but facts are
facts. Microsoft has never been one to follow a logical numbering/naming scheme
for their applications, and it's just something that we have to live with.

Now, thinking ahead, someone is going to say "If we add Windows XP then people
will think that it means Cross Plaform, meaning all windows platforms".
Solution: Label it Windows XP/NT5.1 or something. Any way you cut it, it's going
to need to be added. I've already seen issues peculiar to XP during the beta
cycle of XP, and I can guarantee you we'll see them on the RTM version.

And I don't think waiting till October is a good thing to do either. It's been
RTMed, as well as released to OEMs for preloading. You'll be able to buy a box
with XP preloaded sooner than you'll be able to buy XP in stores.

Just be thankful no one is yelling bout changing the OS to say "GNU/Linux". ;)
Myk, maybe this is something you can do quickly?
*** Bug 108008 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
i've added Windows XP to the localconfig file. There is a bugzilla upgrade
happening real soon. XP will get picked up then. 

I'm reluctant to run checksetup.pl since i'm not sure there aren't any
nasty surprises waiting for me. Reassigning to Myk since he's the one
doing the update and the one who did the last update so he'll probably
know the state of the tree and know whether its ok to run checksetup.pl
now.
Assignee: endico → myk
*** Bug 108141 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

17 years ago
This will get taken care of in the b.m.o. upgrade scheduled for Wednesday,
November 7.
.
Depends on: 103885
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
No longer depends on: 103885
this is fixed... XP is in the OS list.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
Verified XP is on the OS list
Status: RESOLVED → VERIFIED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.