The default bug view has changed. See this FAQ.

[Mac] crash in nsAccUtils::IsTextInterfaceSupportCorrect()

RESOLVED FIXED in mozilla15

Status

()

Core
Disability Access APIs
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: hub, Assigned: hub)

Tracking

({crash})

Trunk
mozilla15
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This crash occur since changeset 9b7bea577a43 for bug 750191. It is caused by the use of a deleted nsAccessible*, and only occur in DEBUG.

Patch coming.
(Assignee)

Comment 1

5 years ago
Created attachment 626895 [details] [diff] [review]
Check for expired. Make sure expire do the right thing. r=
(Assignee)

Updated

5 years ago
Attachment #626895 - Flags: review?(trev.saunders)
(Assignee)

Comment 2

5 years ago
setting block as it is triggered by testing bug 750612
Blocks: 750612
Comment on attachment 626895 [details] [diff] [review]
Check for expired. Make sure expire do the right thing. r=

> #ifdef DEBUG
>   NS_ASSERTION(nsAccUtils::IsTextInterfaceSupportCorrect(mGeckoAccessible),
>                "Does not support nsIAccessibleText when it should");
> #endif

btw you could remove the ifdef since sserts are a nop in opt builds
Attachment #626895 - Flags: review?(trev.saunders) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/43ee60cc0ee1
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla15

Comment 5

5 years ago
Comment on attachment 626895 [details] [diff] [review]
Check for expired. Make sure expire do the right thing. r=

Review of attachment 626895 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/src/mac/mozAccessible.mm
@@ +632,2 @@
>    mIsExpired = YES;
> +  mGeckoAccessible = nsnull;

since you null out mGeckoAccessible then you don't need mIsExpired member. Please file follow up bug on this.
https://hg.mozilla.org/mozilla-central/rev/43ee60cc0ee1
Assignee: nobody → hub
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

5 years ago
> since you null out mGeckoAccessible then you don't need mIsExpired member.
> Please file follow up bug on this.

Filed as bug 758799
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Severity: normal → critical
Keywords: crash
You need to log in before you can comment on or make changes to this bug.