Validator fails to parse apparently valid install.rdf

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: jorgev, Assigned: basta)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
I noticed this in the latest compatibility validation:
https://addons.mozilla.org/en-US/developers/addon/biblionru-toolbar/validation-result/110818

I get 2 errors:

Cannot Parse install.rdf
Error: The install.rdf file could not be parsed.
install.rdf
Add-on missing install.rdf.

Error: All add-ons require an install.rdf file.

The file is still there because I can download it, and the install.rdf looks normal enough:
https://addons.mozilla.org/en-US/firefox/files/browse/89130/

Comment 1

6 years ago
We are getting this same error. Install.rdf seems fine but we get the same could not be parsed error message.
(Assignee)

Comment 2

6 years ago
The Biblion.ru Toolbar add-on does indeed have a syntactically incorrect install.rdf file. The <em:localized> element cannot exist outside of a <Description> tag. The error probably wouldn't mean much anywhere else, but this is rdflib failing ungracefully again. Unfortunately, rdflib also doesn't give us any means of tracing the error or providing the dev with a line number. Unless there's something else that I'm not seeing, this looks like it's just a broken install.rdf.

> We are getting this same error.

If you can attach your add-on, I'll have a look and see what might be the problem :)
(Reporter)

Comment 3

6 years ago
(In reply to info from comment #1)
> We are getting this same error. Install.rdf seems fine but we get the same
> could not be parsed error message.

This is bug 766178, which is a recent and unrelated problem.
(Reporter)

Comment 4

6 years ago
Closing this bug based on comment #2.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.