If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Application error on shutdown "the memory could not be read" when telemetry is enabled

RESOLVED DUPLICATE of bug 763361

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 763361
5 years ago
5 years ago

People

(Reporter: JoeS1, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
System specs:
Pentium m 1500
Winxp fully updated

This is my work laptop which I update daily.
Somewhere around 20120519 the restart to update began giving me this:
Application error
The instruction at "ox0103efa3" referenced memory at "0x0103efa3"
The memory could not be read.

This happens on any shutdown, not just the update. Safe mode same result.
With the same system same profile running Earlybird, I do not get this error.

So something has changed in trunk to produce this.
xref bug 758089 seems to have started about that same time.

BTW I do not get this error running on my home systems (Different PC architectures)
So it seems this might be hardware dependent.
(Reporter)

Comment 1

5 years ago
The error goes away if "Submit performance data" (telemetry)is unchecked.
Also the error does not occur on build 20120301 (noticed when regression testing another bug)

Comment 2

5 years ago
interesting - that fixes my crash on shutdown in nightly builds as well.

Comment 3

5 years ago
I've been experiencing what seems to be the same crash on exit described by Joe on Win 7 x64 with the nightly 32-bit builds (zip and installer). There is a twist in my case. With a clean profile I get no crash. It is only after setting a master password and restarting the application does the crashing upon exit start. If I then turn off the master password the crashing continues.

If the crashing is occurring and I do as Joe suggests in comment #1 (turning telemetry off), the crashing stops.
Summary: Application error on shutdown "the memory could not be read" → Application error on shutdown "the memory could not be read" when telemetry is enabled
tracking-thunderbird16: --- → +
(Reporter)

Comment 4

5 years ago
Note to self: see if this is fixed by 
https://hg.mozilla.org/mozilla-central/rev/393a38baf9fc
bug 763361
tracking-thunderbird16: + → ---
Component: General → Folder and Message Lists
(Reporter)

Comment 5

5 years ago
sorry about the flag Mark, bugzilla strikes again
tracking-thunderbird16: --- → ?
(Reporter)

Comment 6

5 years ago
Testing with 20120709030555
Fixed by core checkin comment 4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-thunderbird16: ? → ---
Component: Folder and Message Lists → General
Resolution: --- → FIXED

Comment 7

5 years ago
Hi ,
any hope to resolve this bug in 15.0 Beta ?

Comment 8

5 years ago
(In reply to patclash from comment #7)
> Hi ,
> any hope to resolve this bug in 15.0 Beta ?

See Bug 763361 comment 17
Resolution: FIXED → DUPLICATE
Duplicate of bug: 763361
You need to log in before you can comment on or make changes to this bug.