Bug 759206 (SilentStart)

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

NEW
Unassigned

Status

()

enhancement
7 years ago
a year ago

People

(Reporter: dan_500, Unassigned)

Tracking

(Depends on 1 bug, {uiwanted})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120526030945

Steps to reproduce:

I sometimes close Firefox and some seconds later I decide to start Firefox again. Sometimes I click on the Firefox icon several times.

It is very easy to reproduce with Firefox, because it happens very often, but I do not have such problems with Mozilla Thunderbird.


Actual results:

In both cases I got the message: "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."


Expected results:

Firefox is supposed to start silently without any irritating message.
Reporter

Comment 1

7 years ago
Steps to reproduce:

1. Close Firefox
2. Enter the following command into your favourite unix shell:

firefox -safe-mode & firefox -safe-mode

3. Simulate some other time race conditions.

Comment 2

7 years ago
The error-message tells you what's going on : the old Firefox executable is still running, as it takes a while to close the various databases, add-ons, etc ... Thunderbird has less stuff to close, that's why it's faster. There's no magic bullet that speed this up immediately, except for the various improvements that have been made over the years, or will be made in the future.

As your steps to reproduce in comment 1 : well, you're starting the browser twice (which is not what you report in comment 0), that's why you get the message. If you wait a while between the 2 instances, the second one will not really start a new browser, but will silently open a window in the first one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662444
Reporter

Comment 3

7 years ago
You might say that's because Firefox is slow. But I say even if Firefox is slow it doesn't need this message. At least it should provide an "Please wait while Firefox is starting" message or something like that. I don't want to click on "OK" on that window. I don't want to confirm a message about a technical problem I am not interested in.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

7 years ago
I pointed you to the bug where currently work is being done to make the shutdown process faster. If you don't want to hear about it ... be my guest to provide a different solution.

Firefox can NOT start when another copy is still running (various files and database can not be shared, etc ...), and when it's not possible to open a window in that copy (it's busy during the shutdown). You will always have the warning. The only improvement that can be made here, is to make the shutdown process faster.
Reporter

Comment 5

7 years ago
"You will always have the warning. The only improvement that can be made "

mental disease, I suppose.
there is zero possibilty that the message will be removed and the process changed to silently start.  It is reasonable to assume that bug 662444 will help reduce the possibility of getting the message
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 662444

Comment 7

7 years ago
First off, I assume you guys are oversimplifying for someone who apparently doesn't understand. Still, I don't see why there is a 0% chance the message can change. It is factually incorrect and rather user-unfriendly. In this specific use case, Firefox has already been closed, it simply hasn't exited. The WM_CLOSE or its equivalent has been sent to the OS, and the window is no longer available. The user can no more close Firefox after this point than you can kill something that is already dead. Plus restarting the computer is almost always overkill.

A much more accurate and effective message would be something like this:
"Firefox is still running, but not responding. If you have recently closed Firefox, it may still be in the middle of shutting down. Please wait a short amount of time and try starting Firefox again. If, after several minutes, this still does not work, you may need to manually end the Firefox process or restart your computer."
Reporter

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Reporter

Updated

7 years ago
Alias: SilentStart
Component: Untriaged → Startup and Profile System
Keywords: uiwanted
Product: Firefox → Toolkit
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 13 Branch → Trunk
I see this on friends/family PCs and it is a poor UX.

My strawman:  For the first (say) 5 seconds, a simple dialog saying "Waiting for {something worded nicely} - <button label="Cancel>"".  While displayed, the code continuously checks if the "problem" is resolved and closes the dialog and starts FF if it can.  After the timeout we just revert to the existing messagebox.
>there is zero possibilty that the message will be removed and the process changed 
>to silently start. 

This doesn't make any sense. The error message is terrible UX: it's both *lying*, unhelpful and unneeded.

Comment 8 has a reasonable solution. Moreover, invoking this dialog after a reasonable delay is a great hook to detect the unwanted situation where we deadlocked on shutdown.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #9)
> >there is zero possibilty that the message will be removed and the process changed 
> >to silently start. 
> 
> This doesn't make any sense. The error message is terrible UX:

To be fair, the original comment was saying that removal of *a* UI isn't going to happen - not that *the* UI can't change.

I'm confident a good alternative UI would be welcome - all we need is a patch ;)

Comment 11

6 years ago
Firefox Mozilla browser won't open no matter what I do, this   "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." won't go away.
The solution suggested is not available.  Do you have direct directions to find the bin or associated folder to stop the browser that cannot be found?

Comment 12

6 years ago
The error is here 95% of the time, even after 10 minutes... 
The error doesn't show up if I use "File :  EXIT"
only when I click on the X top right corner.
It's been here for over a year now and it doesn't go away with one of the updates  :-(
I love firefox for the extentions I can use (and do use), but having to open task manager each time to close down the process is... no fun!
Hugo or anyone else who sees this regularly, could you please run http://benjamin.smedbergs.us/crashfirefox.exe when this happens? This will crash Firefox in a way that should generate a crash report. If you could then use about:crashes to get the crash report ID and file a new bug with the details, I can diagnose the problem from there (please cc me!). This meta-bug is probably not the best place to do that since there are certainly multiple possible causes for the problem.
Benjamin, it would be impressive if anyone could do that quickly enough to catch Firefox before it finished quitting. And even if they did, very often (at least until bug 662444 is fixed) the crash report would merely show you Firefox in the middle of an ordinary shutdown. It is true that there are many possible causes for the error message, but this report (contra comment 11 and 12) is about just one of them: trying to launch Firefox while it is quitting.

Updated

6 years ago
Depends on: 921046
@mpt, I'll definitely consider a short retry loop for the startup code which tries to get the profile lock; filed bug 921046. My impression is this issue is far more serious for users who are seeing either very long (60+ second) shutdowns or permanent deadlocks.

Also working on creating a logging solution that will let us track this and provide user support. No bug# for that yet.
Duplicate of this bug: 936337
Comment hidden (me-too)

Comment 18

5 years ago
On Windows 8 (now 8.1), I have received this message intermittently with past versions of Firefox, but since I installed v29 I have been getting it with increasing regularity. Even if I wait 30 seconds or more, I will get the error, and the only "solution" I've found is to go into Task Manager and end the process.

THIS ERROR REALLY WORRIES ME because not all users are saavy enough to use Task Manager, and while it is annoying to me, I can see this as a DEALBREAKER for less technical users.

As Chrome increases in market share, Firefox continues to be the biggest loser, and with poor UX like this, I can only imagine more FF users jumping ship and the browser fading into oblivion. I would hate for this to happen! Why would someone want to restart their computer all of the time just to use FF again, when they can install Chrome and NEVER have this problem?  PLEASE make fixing this a priority!
AMA3, this is a pretty generic bug. If you are seeing a particular problem, I encourage you to file a new bug and cc me. Also please use the instructions at https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox to kill the "hung" Firefox in a way that will give us some useful stacks/debugging info.
You're seeing this error because something in your Firefox installation is fucked up. While this bug discusses some ways to avoid the message, they are but workarounds for whatever the underlying problem is.  

I'd suggest heading to https://support.mozilla.org/en-US/ and seeing if you can get it sorted out. Removing all add-ons/plugins and seeing if that makes the problem disappear is probably a good start.

Let me repeat that: this bug is not about whatever problem you're having that causes it, it's about providing a way out in case Firefox is busted beyond recovery. Obviously we're not expecting users to get into that state in the first place, and they're far better off by fixing the problem itself rather than hoping for this bug to provide an automatic "nuke the thing from orbit" option.
Opera 12 had a repeating check and an option to kill the existing executable in this dialog. Something like this:

"opera is still exiting. please wait.
[kill existing instance and start opera] [cancel]"

if at any time the existing instance closed down before you could click anything, the dialog would automatically disappear and opera start.

I don't see any reason firefox couldn't have the same functionality.

Updated

5 years ago
Flags: needinfo?(nobody)

Updated

5 years ago
Flags: needinfo?(nobody)
See Also: → 1303187
You need to log in before you can comment on or make changes to this bug.