Closed Bug 759689 Opened 7 years ago Closed 7 years ago

[adbe 3210913] Flash content is not loaded using Flash 11.3 Beta

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

x86
Windows 7
defect
Not set

Tracking

(firefox13-, firefox14-)

RESOLVED DUPLICATE of bug 763459
Tracking Status
firefox13 - ---
firefox14 - ---

People

(Reporter: simona.marcu, Unassigned)

Details

(Keywords: qawanted)

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0

Flash content is not loaded on Firefox having Flash 11.3 beta installed. Reproduced this on Windows 7 having no Service Pack installed. On Windows 7 SP 1 this is not reproducible. 

Reproducible: always

Steps to reproduce:
1. Install Flash 11.3 Beta from:
http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11-3/
2. Navigate to http://www.youtube.com/ and play a video of your choice.
3. Navigate to http://www.miniclip.com/games/major-miner/en/ and play the game.

Expected results:
Both the video and the game can be played properly.

Actual results:
The flash content is not loaded, neither for the video from step 2 or the game from step 3.
The video and the game are properly working on Opera 11.64 using Flash 11.3 Beta.
Can you see if this is reproducible in any previous versions of Firefox? Also Aurora 14 and Nightly 15?
Reproducible on the previous versions, tested on -  Firefox 3.6.16, Firefox 4.0.1, Firefox 7.0.1. Firefox 12:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

Reproducible also on the latest Aurora and latest Nightly:

Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120530 Firefox/14.0a2
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/15.0 Firefox/15.0a1
This could be a problem with Flash, but the fact that this can't be reproduced in Win 7 SP1 might make this WONTFIX.
Including Hitomi and Sal to help file bugs on the Adobe side and get this resolved prior to release. There are enough Firefox users on original installs of Win7 to warrant this getting fixed.
Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/16.0 Firefox/16.0a1

Issue is also reproducible on Windows Vista SP1.
Summary: Flash content is not loaded using Flash 11.3 Beta → Flash content is not loaded using Flash 11.3 Beta on Win7 GM
Summary: Flash content is not loaded using Flash 11.3 Beta on Win7 GM → Flash content is not loaded using Flash 11.3 Beta
(In reply to Simona B [QA] from comment #5)
> Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/16.0 Firefox/16.0a1
> 
> Issue is also reproducible on Windows Vista SP1.

Thanks for the additional information - can you also use the instructions at http://forums.adobe.com/thread/1018071?tstart=0 to see if disabling protected mode helps?
Keywords: qawanted
Assignee: nobody → benjamin
I'm not able to reproduce this bug on Vista with Flash 11.3 in Firefox 13.0. Simona, please test this when you get a chance. Thanks
(In reply to Alex Keybl [:akeybl] from comment #9) 

Just going through some of the websites listed:
 * Youtube.com -> video
 * Engadget.com -> video and interactive banners
 * myscene.everythinggirl.com -> video and games
 * Skydrive -> upload, download, drag&drop

Have not been able to reproduce this bug. Simona, please help if you can.
Alex, what would you like me to do with this bug? I don't have personal access to a Windows box this week, and probably not to a Win7 non-XP1 box except in the QA lab. Are you looking for a diagnosis of why Flash is not working?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #11)
> Alex, what would you like me to do with this bug? I don't have personal
> access to a Windows box this week, and probably not to a Win7 non-XP1 box
> except in the QA lab. Are you looking for a diagnosis of why Flash is not
> working?

When I first reached out, it appeared that this was specific to certain versions of Windows. Now it appears more scoped than that. I think we need to help you take a look at Simona's affected machines, if we can't reproduce in MV.
we are attempting to reproduce and confirm on our side...
unfortunately, i have not been able to reproduce on Win 7 GM (without service pack).  i have tested a few machines in our lab and with different flash upgrade scenarios and flash works and videos play as expected.  please let us know if there's something specific to Simona's machines, so we may attempt on something similar.  thanks...
Bug 763459 may be related, if the RealPlayer Browser Record plugin is installed then Flash stops working completely.
Summary: Flash content is not loaded using Flash 11.3 Beta → [adbe 3210913] Flash content is not loaded using Flash 11.3 Beta
(In reply to Alex Keybl [:akeybl] from comment #6)
> Thanks for the additional information - can you also use the instructions at
> http://forums.adobe.com/thread/1018071?tstart=0 to see if disabling
> protected mode helps?

Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0

Disabling the protected mode helps - Flash content is loaded on all the machines that I could initially reproduce this issue.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #15)
> Bug 763459 may be related, if the RealPlayer Browser Record plugin is
> installed then Flash stops working completely.

Flash content loads if the protected mode remains enabled and if I uninstall the Real Player plugin. Once again, I tested this behavior on all the machines where I was able to initially reproduce the problem.
Sounds like this is a dupe of bug 763459 then.

Note that the 'RealPlayer plugin' is really an extension that's causing the problem, not a plugin.
(In reply to Thomas B. Rücker from comment #18)
> Sounds like this is a dupe of bug 763459 then.

I agree. It's a real player related issue and not a win 7 SP1/non SP1 one (I can reproduce it on Win 7 SP1).
(In reply to Simona B [QA] from comment #17)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #15)
> > Bug 763459 may be related, if the RealPlayer Browser Record plugin is
> > installed then Flash stops working completely.
> 
> Flash content loads if the protected mode remains enabled and if I uninstall
> the Real Player plugin. Once again, I tested this behavior on all the
> machines where I was able to initially reproduce the problem.

Simona - can you confirm that you had the RealPlayer add-on installed?
For what it's worth, the customer feedback we've received from the field so far indicates that this is specific to the RealPlayer plug-in.  

See 759689, 763459, 764210 for the latest
(In reply to Alex Keybl [:akeybl] from comment #20) 
> Simona - can you confirm that you had the RealPlayer add-on installed?

On all the machines that I could reproduce this issue I had RealPlayer add-on installed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763459
Here are the Browser Record Plugin files located at C:\ProgramData\Real\RealPlayer. As far as I can tell the Firefox extension files are actually located a bit deeper at C:\ProgramData\Real\RealPlayer\BrowserRecordPlugin\Firefox\Ext
Looking at the add-on code, this is what it does:

* It loads nprpffbrowserrecordext.dll using JS-ctypes for Firefox 4 and above, and as a binary XPCOM component for older versions. The DLL is loaded as a component in all cases, though. The component presumably does most of the work, since the JS in the extension doesn't do much more.

* It replaces all <video> tags on the web with their HTML5 plugin (RealPlayer HTML5VideoShim Plug-In, I suppose).

I can't see how it interacts with the other plugins, or whether it does at all.
Our understanding is that the HTML re-writing is done in order to allow realplayer to invoke itself instead of Flash Player.  Their binary then invokes Flash Player, masquerading as Firefox.  This gives them the ability to capture the video stream that we're playing and write it to disk.

The security enhancements introduced by Protected Mode intended to prevent malware from abusing Flash Player also prevent the kinds of interception that Real was previously accomplishing.  It's unclear if the issues is that the interfaces have simply changed (it's been a few months since they've shipped an update), or if the additional hardening prevents the methods by which they were previously able to wrap us.
There is nothing I can do for this bug, de-assigning.
Assignee: benjamin → nobody
Nothing new here suggests issues unrelated to RealPlayer.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763459
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 13.x → unspecified
You need to log in before you can comment on or make changes to this bug.