Last Comment Bug 764210 - Blocklist RealPlayer Download Plugin add-ons
: Blocklist RealPlayer Download Plugin add-ons
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: Marcia Knous [:marcia - use ni]
Mentors:
Depends on: 768234
Blocks: 763459 771802
  Show dependency treegraph
 
Reported: 2012-06-12 16:32 PDT by Alex Keybl [:akeybl]
Modified: 2016-03-07 15:30 PST (History)
27 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of issue (365.44 KB, image/png)
2012-07-02 17:58 PDT, Marcia Knous [:marcia - use ni]
no flags Details
Going to the EXACT SAME URL as the attachment shown on report page. Loads video, downloads video, no error. (430.29 KB, image/png)
2013-03-07 19:05 PST, caucow98
no flags Details
Going to the EXACT SAME URL as the attachment shown on report page. Loads video, downloads video, no error. (451.25 KB, image/png)
2013-03-07 19:17 PST, caucow98
no flags Details

Description Alex Keybl [:akeybl] 2012-06-12 16:32:03 PDT
Plugin name: RealPlayer Download Plugin
Plugin versions to block: <=15.0.4.53
Applications, versions, and platforms affected: Windows
Block severity: hard

How does this plugin appear in about:plugins?
     File: nprpplugin.dll
     Version: 15.0.4.53
     Description: RealPlayer Download Plugin

Reasons: bug 763459 – RealPlayer Browser record plugin breaks Youtube since Fx13
Comment 1 Jorge Villalobos [:jorgev] 2012-06-12 16:56:06 PDT
The block is now staged: https://addons-dev.allizom.org/en-US/firefox/blocked/p91
QA, please test and confirm that it works.
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-12 17:17:21 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #1)
> The block is now staged:
> https://addons-dev.allizom.org/en-US/firefox/blocked/p91
> QA, please test and confirm that it works.

Juan has volunteered to test this. Over to him.
Comment 3 Alex Keybl [:akeybl] 2012-06-12 17:19:30 PDT
Once Juan signs off, let's push to production. Thanks guys.
Comment 4 juan becerra [:juanb] 2012-06-12 17:26:55 PDT
During investigation, I would disable this plugin manually, and afterwards I would be able to play youtube videos, but with the blocklist, the plugin is disabled but aftwards I still cannot play videos.

Looking at the list of extensions, there is a:

"RealPlayer Browser Record Plugin 15.0.4"

Disabling that is what actually makes Flash 11.3 work again.

I must have done something wrong during testing earlier, when disabling the plugin made things work.

So, we should blocklist the extension.
Comment 5 Jorge Villalobos [:jorgev] 2012-06-12 17:30:30 PDT
(In reply to juan becerra [:juanb] from comment #4)
> So, we should blocklist the extension.

Only the extension, or the extension and the plugin? Does disabling the extension also disable any/all of the plugins?
Comment 6 juan becerra [:juanb] 2012-06-12 17:38:17 PDT
Only the extension.

Disabling the extension does not disable any of the plugins.
Comment 7 Jorge Villalobos [:jorgev] 2012-06-12 17:41:16 PDT
This is limited to Windows, right?
Comment 8 Jorge Villalobos [:jorgev] 2012-06-12 17:46:00 PDT
I just staged the block: https://addons-dev.allizom.org/en-US/firefox/blocked/i92

ID: {97E22097-9A2F-45b1-8DAF-36AD648C7EF4}
OS: Windows
Versions: 0-1.5.0.4
Level: soft block
Comment 9 Jorge Villalobos [:jorgev] 2012-06-12 17:48:21 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #8)
> ID: {97E22097-9A2F-45b1-8DAF-36AD648C7EF4}

I took this id from bug 763459 comment #6, but it might be wrong. The id I see from our top add-on usage stats is {ABDE892B-13A8-4d1b-88E6-365A6E755758}.

Marcia, Juan, can you please verify?
Comment 10 juan becerra [:juanb] 2012-06-12 18:05:08 PDT
The id I see in about:support is {97E22097-9A2F-45b1-8DAF-36AD648C7EF4}

This works in staging, and it disables the add-on. I've just tested the staged extension blocklist, and I get a dialog to disable the extension and after I restart I can play youtube videos. The plugins remain enabled.
Comment 11 Jorge Villalobos [:jorgev] 2012-06-12 18:12:10 PDT
The extension is now blocked in production: https://addons.mozilla.org/en-US/firefox/blocked/i106
Comment 12 juan becerra [:juanb] 2012-06-12 19:07:21 PDT
I've verified this in production. A dialog that allows you to disable the add-on comes up and prompts you to restart. After you restart you are able to play videos (I tried different sites) using Flash 11.3.x
Comment 13 Alex Keybl [:akeybl] 2012-06-12 19:20:36 PDT
Thanks guys. https://support.mozilla.org/en-US/kb/flash-crashes-or-does-not-load-firefox-13?s=flash+realplayer&r=0&e=es&as=s includes instructions for our users in case they accidentally decline the blocklist.
Comment 14 mionnie 2012-06-13 14:08:43 PDT
can't play videos in youtube even i already disabled this plugin..need some help please..thanks a lot..I'm using Firefox 12.0
Comment 15 Martyn 2012-06-13 14:35:19 PDT
The problem as I know it is not this plugin, but the newly introduced protected mode of Adobe Flash. Status therefore is not fixed, although the problem may be Adobe's.
To turn off protected mode see here:
http://techlogon.com/2012/06/10/early-problems-with-flash-player-protected-mode-in-firefox-13/

The plugin works fine for me - always has!
Comment 16 saveriofanelli 2012-06-13 23:30:10 PDT
can't play videos in youtube even i already disabled this plugin..need some help please..thanks a lot..I'm using Firefox 13.0
Comment 17 Simona B [:simonab] 2012-06-14 08:57:51 PDT
(In reply to mionnie from comment #14)
> can't play videos in youtube even i already disabled this plugin..need some
> help please..thanks a lot..I'm using Firefox 12.0

(In reply to saveriofanelli from comment #16)
> can't play videos in youtube even i already disabled this plugin..need some
> help please..thanks a lot..I'm using Firefox 13.0

Did you restarted Firefox after disabling the RealPlayer extension?
Comment 18 smadayag 2012-06-14 09:44:34 PDT
(In reply to mionnie from comment #14)
> can't play videos in youtube even i already disabled this plugin..need some
> help please..thanks a lot..I'm using Firefox 12.0

disabling the plugin didn't work for me.  i needed to completely uninstall Real Player and restart firefox to get it to work.  would you try that first?  thanks...
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-14 09:59:13 PDT
I think there may be some confusion here with terminology. When you install RealPlayer it actually installs several Plugins (see about:plugins) and one Add-on (see about:addons). This bug only blocked the "RealPlayer Browser Record Plugin" Add-on. However, this still left the other RealPlayer plugins intact.

@smadayag, the fact that completely uninstalling RealPlayer resolved this for you implies that the problem still lies with RealPlayer but may lie in one of the Plug-ins that were not disabled by this block. Would you be able to reinstall RealPlayer and disable the plug-ins one by one until the problem disappears? That would help us identify if there is a single RealPlayer plugin causing the issue.
Comment 20 juan becerra [:juanb] 2012-06-14 10:01:33 PDT
For the people who reported that disabling the plugin didn't fix the problem: Did you disable the extension or the plugin? Disabling the one in the Extensions section is what fixed it for me. Disabling the one in the Plugins area did not fix it for me.
Comment 21 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-14 10:03:10 PDT
Just to reiterate, RealPlayer 15 installs...

In about:addons:
 * RealPlayer Browser Record Plugin

In about:plugins:
 * RealJukebox NS Plugin
 * RealNetworks Chrome Background Extension Plugin
 * RealPlayer Download Plugin
 * RealPlayer G2 LiveConnect-enabled Plugin
 * RealPlayer HTML5VideoShim Plugin
Comment 22 Marcia Knous [:marcia - use ni] 2012-06-14 10:16:32 PDT
Also would be helpful to know which Windows versions everyone is testing on. Using Win Vista I had an existing Firefox profile where everything was disabled (plugins and extensions) and it still did not work for me. That was tested using the lastest version of RealPlayer 15.
Comment 23 Jorge Villalobos [:jorgev] 2012-06-14 13:52:47 PDT
We are extending the block to include the id in comment #9.
Comment 24 Jeromie Clark 2012-06-14 13:55:05 PDT
Disabling the RealPlayer Browser Recorder Plug-In is not adequate to solve this issue.  

You must complete *all* of the following steps: 
    Launch RealPlayer
    Click the RealPlayer icon in the upper left corner of the window and choose Preferences.
    Choose Download & Recording from the left hand panel
    Uncheck "Enable Web Download & Recording for these installed browsers"
    Click OK and close RealPlayer
    Restart Firefox

If this issue is not resolved by the following steps, please launch firefox in Safe Mode (firefox.exe --safe-mode) and see if the issue is resolved.  If so, please provide a list of all of the installed Add-Ons and Extensions on your system so that we can test for any possible compatibility issues.
Comment 25 Jorge Villalobos [:jorgev] 2012-06-14 13:56:00 PDT
Done: https://addons.mozilla.org/en-US/firefox/blocked/i107

QA, please verify.
Comment 26 juan becerra [:juanb] 2012-06-14 14:41:34 PDT
The steps in comment #24 work for me as well, and what that does is to remove the extension, not just disables it. All five RealPlayer plugins remain listed in the Plugins section in about:addons.
Comment 27 Jorge Villalobos [:jorgev] 2012-06-14 14:55:08 PDT
Can you attach the extension to this bug? It might be that there is something else going on, like an injected DLL, and the extension is just one part of the feature.
Comment 28 Benjamin 2012-06-15 08:30:32 PDT
Hey, I disabled the extension and I still couldn't play flash content. However, when I turned off protected mode for Flash, videos started playing again. I turned the extension back on, and it works fine.
Comment 29 michelle munn, realnetworks 2012-06-16 13:46:15 PDT
Mozilla folks, can you confirm the blocklist for Real plugins (as related to this bug) is the following ids:

97E22097-9A2F-45b1-8DAF-36AD648C7EF4
ABDE892B-13A8-4d1b-88E6-365A6E755758

We are working on a mitigation for the issue and want to confirm blocklist scope.
Thanks
Comment 30 Alex Keybl [:akeybl] 2012-06-16 20:15:26 PDT
(In reply to michelle munn, realnetworks from comment #29)
> Mozilla folks, can you confirm the blocklist for Real plugins (as related to
> this bug) is the following ids:
> 
> 97E22097-9A2F-45b1-8DAF-36AD648C7EF4
> ABDE892B-13A8-4d1b-88E6-365A6E755758
> 
> We are working on a mitigation for the issue and want to confirm blocklist
> scope.
> Thanks

I can confirm that we're blocklisting these two add-ons. I know we're blocking 

97E22097-9A2F-45b1-8DAF-36AD648C7EF4

for versions above 15.0.4.53, and believe we're doing the same for

ABDE892B-13A8-4d1b-88E6-365A6E755758

but Jorge will be able to confirm.
Comment 31 Jorge Villalobos [:jorgev] 2012-06-17 18:05:38 PDT
Both ids are blocked for the 0 to 15.0.4 version range, on Windows only. If there's any information you can give us to refine these blocks, that's much appreciated.
Comment 32 Kazuki 2012-06-17 20:37:37 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #31)
> Both ids are blocked for the 0 to 15.0.4 version range, on Windows only. If
> there's any information you can give us to refine these blocks, that's much
> appreciated.

------------


Is there -anyway- at all, that you can allow certain versions of
realplayer? / Make it only for certain builds of firefox? Say from...
11.0+?

 Or advise people to go back a version on flash? --anything at all?

Because the case seems to be with newer flash / newer realplayer
versions / firefox versions. Neither one have effected me, I'm still running an older version
of flash and a VERY old version of real player, youtube, and other such
sites have worked fine and there has -never- been a problem with either one
on my end.

And FF 2 users do not get the option to keep realplayer running it seems through the addons manager. 

As seen:  https://support.mozilla.org/en-US/questions/929840#answer-343603
Comment 33 Jorge Villalobos [:jorgev] 2012-06-17 20:50:08 PDT
(In reply to Kazuki from comment #32)
> And FF 2 users do not get the option to keep realplayer running it seems
> through the addons manager. 

We don't officially support anything older than Firefox 4 now, and no versions older than 3.6 support soft-blocking. For most users we can recommend they go to the Add-ons Manager and re-enable the extension, but that is not an option for you. The only thing you could do is disable blocklisting, which I don't know how to do for such old versions.
Comment 34 michelle munn, realnetworks 2012-06-18 09:51:45 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #31)
> Both ids are blocked for the 0 to 15.0.4 version range, on Windows only. If
> there's any information you can give us to refine these blocks, that's much
> appreciated.

Tx Jorge. That's what we needed. Confirming....that range is 15.0.0 thru 15.0.4, correct? For which appID? 
We're working the mitigation as Pri1/Sev1.  Will get back to you w block refinements when known.
Comment 35 Jorge Villalobos [:jorgev] 2012-06-18 10:41:43 PDT
The range is for versions 15.0.4 and older, so this is also blocking versions older than 15.0.0. There is no appID limitation, so it should be working for all applications that support our blocklist. As far as I know those should be Firefox, Thunderbird and SeaMonkey.

As for add-on ids, both ids (97E22097-9A2F-45b1-8DAF-36AD648C7EF4 and ABDE892B-13A8-4d1b-88E6-365A6E755758) are blocked for the same version range, though we don't have any samples for the second id, so we don't know if this is the correct range to be blocking.
Comment 36 michelle munn, realnetworks 2012-06-26 19:10:02 PDT
Tomorrow, Jun27, we will release a mitigation for the Adobe Flash v11.3/Firefox issue as RealPlayer v15.0.5 (tentatively 15.0.5.109).

The mitigation deactivates RealPlayer plugin when Adobe Flash v11.3 is in Protected Mode. 

Outcome: Video Download is no longer available to the customer.
Adobe Flash v11.3 Protected Mode plays in Firefox.
Comment 37 Sugarbomb613 2012-06-29 16:57:26 PDT
I have realplayer and adobe on my add-ons list and until a few days ago, I've been having issues with all the players no matter what site they're from and games just don't load. I've noticed that RealPlayer is disabled and it has the warning of why, but is having RealPlayer downloaded the main cause of why the players and games wont load? Or is this a completely different issue? Please help. Thank you.

-Sincerely-
SugarBomb613
Comment 38 Sugarbomb613 2012-06-29 17:05:27 PDT
(In reply to Sugarbomb613 from comment #37)
> I have realplayer and adobe on my add-ons list and until a few days ago,
> I've been having issues with all the players no matter what site they're
> from and games just don't load. I've noticed that RealPlayer is disabled and
> it has the warning of why, but is having RealPlayer downloaded the main
> cause of why the players and games wont load? Or is this a completely
> different issue? Please help. Thank you.
> 
> -Sincerely-
> SugarBomb613

I'd also like to add that because of the player and game loading problems is a reason that I switched over to SeaMonkey, Mozilla's off brand of FireFox. I never have any problems with players or games while running SeaMonkey.
Comment 39 Marcia Knous [:marcia - use ni] 2012-07-02 15:33:34 PDT
Hi Michelle - I have been testing this new version in a Windows 7 VM with the following results using Firefox 13.0.1:

1. Install the latest version of real Player Version: 15.0.5.109
2. Start FF 13.0.1 with a new profile and confirm in about:plugins that the plugin is installed.
3. Go to youtube.com and play a video (Running Flash Version: 11.3.300.262 - I have done nothing to protected mode so it is enabled)
4. I still get an Error message when trying to play the video and I do not see any deactivation of the Real Player plugin.

(In reply to michelle munn, realnetworks from comment #36)
> Tomorrow, Jun27, we will release a mitigation for the Adobe Flash
> v11.3/Firefox issue as RealPlayer v15.0.5 (tentatively 15.0.5.109).
> 
> The mitigation deactivates RealPlayer plugin when Adobe Flash v11.3 is in
> Protected Mode. 
> 
> Outcome: Video Download is no longer available to the customer.
> Adobe Flash v11.3 Protected Mode plays in Firefox.
Comment 40 michelle munn, realnetworks 2012-07-02 16:51:45 PDT
Marcia, can you provide us with this additional information so we can reproduce on our end.
1. link to video(s) you are using
2. text/screen shot of error message
3. confirm that is is the Extension, not the Plugin we're talking about here.
Thanks, Michelle
Comment 41 Marcia Knous [:marcia - use ni] 2012-07-02 17:58:39 PDT
Created attachment 638556 [details]
Screenshot of issue

1. http://www.youtube.com/watch?v=Naf8Npwnjhg&feature=g-logo-xit
2. Attached.
3. From about:support RealPlayer Browser Record Plugin15.0.5 true {C3949AC2-4B17-43ee-B4F1-D26B9D42404D}

Oddly in one instance I was able to get one video to play. Also experienced some crashes on hulu.com - https://crash-stats.mozilla.com/report/index/bp-2f45eba3-84d4-41fe-a4e5-0c7752120702
Comment 42 Marcia Knous [:marcia - use ni] 2012-07-02 18:12:58 PDT
The testing in Comment 41 was done in a Win 7 VM but I repeated the same steps with regular Windows 7 hardware, with the same result.

The only way I was able to successfully play videos without the error was to disable the RealPlayer Browser Record Plugin and then restart Firefox. 

Michelle: Your comment mentions deactivating RealPlayer plugin when Adobe Flash v11.3 is in Protected Mode - so I assume somehow this is supposed to be happening when the flash video starts playing?
Comment 43 Martyn 2012-07-03 01:00:28 PDT
The default setting for Flash is protected mode. 

To disable protected Mode, add the following line to your mms.cfg file located in:

Windows 32bit: C:\windows\system32\macromed\flash

Windows 64bit: C:\windows\syswow64\macromed\flash

ProtectedMode=0
Comment 44 Dave Herrera 2012-07-03 15:18:23 PDT
Hi Marcia,

I'm the QA Manager for the RealPlayer Engineering team and will your primary contact until Michelle is back from vacation.

We have been unable to reproduce the issue you are seeing. On clean machines with RealPlayer 15.0.5.109, FF 13.0.1, and Flash Version 11.3.300.262, the Youtube video you linked plays without error.

As a note, we don't disable the extension in protected mode, but, instead, unhook Flash when protected mode is detected, leaving the extension enabled. 

I have a few questions for you:
1. Is the machine you are testing on clean, with no previous version of RealPlayer, Firefox, or Flash installed; or, were any of the components over-installed? If so, which ones (RealPlayer, Firefox, Flash)?

2. With the machine that reproduces the issue, in Flash's protected mode and our extension enabled, are you able to play Youtube Flash videos after...
a) ...a Firefox restart?
b) ...a System restart?
c) ...disabling Flash's protected mode?

3. In order to more quickly isolate the issue you are seeing, would you allow one of our engineers to set up a remote connection to the VM where the issue is reproduced? Logmein.com provides an easy way to set this up. Due to the holiday, Thursday the 6th seems like the next opportunity.

Regards,

Dave Herrera
Comment 45 Marcia Knous [:marcia - use ni] 2012-07-03 18:06:39 PDT
Dave:

1. The Win 7 machine (real hardware - HP Pavilion dm1) I tested with is definitely not clean, having had many versions of Firefox, Real Player and Flash installed. This is probably much more indicative of what you would see in the real world with a browser user so I tend to test with my machines in this state. 

2. When looking back I think on the Win 7 real hardware I was actually testing with the latest Firefox beta instead of 13.0.1.

I will look into the other questions on Thursday, and we can certainly set up a remote connection if that would help. I will also check some of my other lab machines to see if I get the same results.


(In reply to Dave Herrera from comment #44)
> Hi Marcia,
> 
> I'm the QA Manager for the RealPlayer Engineering team and will your primary
> contact until Michelle is back from vacation.
> 
> We have been unable to reproduce the issue you are seeing. On clean machines
> with RealPlayer 15.0.5.109, FF 13.0.1, and Flash Version 11.3.300.262, the
> Youtube video you linked plays without error.
> 
> As a note, we don't disable the extension in protected mode, but, instead,
> unhook Flash when protected mode is detected, leaving the extension enabled. 
> 
> I have a few questions for you:
> 1. Is the machine you are testing on clean, with no previous version of
> RealPlayer, Firefox, or Flash installed; or, were any of the components
> over-installed? If so, which ones (RealPlayer, Firefox, Flash)?
> 
> 2. With the machine that reproduces the issue, in Flash's protected mode and
> our extension enabled, are you able to play Youtube Flash videos after...
> a) ...a Firefox restart?
> b) ...a System restart?
> c) ...disabling Flash's protected mode?
> 
> 3. In order to more quickly isolate the issue you are seeing, would you
> allow one of our engineers to set up a remote connection to the VM where the
> issue is reproduced? Logmein.com provides an easy way to set this up. Due to
> the holiday, Thursday the 6th seems like the next opportunity.
> 
> Regards,
> 
> Dave Herrera
Comment 46 Paul Silaghi, QA [:pauly] 2012-07-04 05:34:35 PDT
(In reply to Marcia Knous [:marcia] from comment #39)
> Hi Michelle - I have been testing this new version in a Windows 7 VM with
> the following results using Firefox 13.0.1:
> 
> 1. Install the latest version of real Player Version: 15.0.5.109
> 2. Start FF 13.0.1 with a new profile and confirm in about:plugins that the
> plugin is installed.
> 3. Go to youtube.com and play a video (Running Flash Version: 11.3.300.262 -
> I have done nothing to protected mode so it is enabled)
> 4. I still get an Error message when trying to play the video and I do not
> see any deactivation of the Real Player plugin.

I'm not able to reproduce on Win XP x86 and Win 7 64-bit. The machines were not clean.
Comment 47 Simona B [:simonab] 2012-07-04 07:23:01 PDT
Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0.1

I could reproduce the issue described in Comment 41.
 
For me the issue is reproducible when I remove the file mms.cfg from the Flash folder (C:\windows\system32\macromed\flash), if I copy the file back and disable the protected mode flash content loads fine. If I do not disable the protected mode and I just copy the mms.cfg file in the Flash folder then flash content does not load. 
Please note that flash content loaded fine with protected mode enabled until I deleted the mms.cfg file for the first time. I tried this on a clean OS. 

Reproduced the issue on Win Vista and on Win 7x64-bit, with Shockwave Flash 11.3.300.262 and the enabled extension RealPlayer Browser Record Plugin 15.0.5.
Comment 48 Paul Silaghi, QA [:pauly] 2012-07-04 07:27:28 PDT
(In reply to Paul Silaghi [QA] from comment #46)
> (In reply to Marcia Knous [:marcia] from comment #39)
> > Hi Michelle - I have been testing this new version in a Windows 7 VM with
> > the following results using Firefox 13.0.1:
> > 
> > 1. Install the latest version of real Player Version: 15.0.5.109
> > 2. Start FF 13.0.1 with a new profile and confirm in about:plugins that the
> > plugin is installed.
> > 3. Go to youtube.com and play a video (Running Flash Version: 11.3.300.262 -
> > I have done nothing to protected mode so it is enabled)
> > 4. I still get an Error message when trying to play the video and I do not
> > see any deactivation of the Real Player plugin.
> 
> I'm not able to reproduce on Win XP x86 and Win 7 64-bit. The machines were
> not clean.

Reproducible 100% on a Win 7 x86 machine.
Comment 49 Paul Silaghi, QA [:pauly] 2012-07-04 07:31:48 PDT
(In reply to Simona B [QA] from comment #47)
> Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0.1
> 
> I could reproduce the issue described in Comment 41.
>  
> For me the issue is reproducible when I remove the file mms.cfg from the
> Flash folder (C:\windows\system32\macromed\flash), if I copy the file back
> and disable the protected mode flash content loads fine. If I do not disable
> the protected mode and I just copy the mms.cfg file in the Flash folder then
> flash content does not load. 
> Please note that flash content loaded fine with protected mode enabled until
> I deleted the mms.cfg file for the first time. I tried this on a clean OS. 
> 
> Reproduced the issue on Win Vista and on Win 7x64-bit, with Shockwave Flash
> 11.3.300.262 and the enabled extension RealPlayer Browser Record Plugin
> 15.0.5.

I cannot exactly reproduce this, but indeed there is something strange happening here. Firefox totally freezes after removing the mms.cfg file and trying to play youtube.com.
Comment 50 Paul Silaghi, QA [:pauly] 2012-07-04 07:42:50 PDT
* Firefox totally freezes on Win XP x86 and Win 7 64-bit after removing the mms.cfg file and trying to play youtube.com.
Comment 51 Dave Herrera 2012-07-05 10:28:19 PDT
Paul,
So, are you saying that the only time you are seeing an error is when you remove the mms.cfg file without replacing it?

I would not expect either Flash to work properly, or our extension to work properly when the mms.cfg file is removed completely.

I would recommend putting the mms.cfg file in one of two formats (must edit with editor run as admin with UAC on):

Protected mode on:
AutoUpdateDisable=0
SilentAutoUpdateEnable=1

Protected mode off:
AutoUpdateDisable=0
SilentAutoUpdateEnable=1
ProtectedMode=0

With the mms.cfg file set as above, and the environment of RP 15.0.5, FF 13.0.1, Flash 11.3.300.262, you should see this behavior:

Protected mode on:
Flash content should play without error, but our extension will not work in FF. It will not be disabled though, we just unhook flash.

Protected mode off (I suggest shutting down FF while editing):
Flash content should play without error and our extension should work.

Outside of these two use cases, such as with an invalid or missing mms.cfg, I can't guarantee that either Flash or our Downloader extension will work properly. If you see any crashes of our plugin with the mms.cfg missing, I'd of course like to know about that, as we should handle the situation gracefully.
Comment 52 Dave Herrera 2012-07-05 12:44:33 PDT
Simona and Paul, 

As an update we have reproduced the freeze when mms.cfg is removed completely and are tracking this internally as a separate bug. In addition, we are seeing some issues even after replacing with a valid mms.cfg file once we are in the above state, which might explain why you are seeing the inconsistent behavior above. When you edit the mms.cfg in place, the freeze issue shouldn't occur, and perhaps will resolve any related Flash playback issues.

In order to get out of the state above, I recommend re-installing RealPlayer.
Comment 53 Marcia Knous [:marcia - use ni] 2012-07-05 17:13:22 PDT
Dave: I am still able to reproduce the issue both in a clean Windows 7 Pro VM and on another Sony Vaio machine running Windows 7. Here are my exact steps in each instance:

VMWare Fusion - Windows 7 Pro Virtual Machine - 32 Bit OS

1. Start VM in a clean state with no versions of Firefox, Real Player or Flash installed.
2. Install Real Player from your site, which installs RealPlayer Browser Record Plugin 15.0.5
3. Install Firefox 13.0.1 from www.mozilla.com site.
4. Install Flash 11.3.300.262 (Windows 32-bit) version
5. Enable the Real Player addon since when I start Firefox it is disabled (requires browser restart)
6. Launch Firefox and play a youtube.com video or any other flash video.
7. Receive an error similar to the screenshot previously attached.
8. Firefox browser restart does not resolve the issue.
9. System restart does not resolve the issue.

Sony Vaio (Running Windows 7 Professional, SP 1/64 Bit OS/Mobile Intel HD Graphics Card)

1. Start Firefox 14 Beta with a clean profile.
2. Install Real Player from your site, which installs RealPlayer Browser Record Plugin 15.0.5 (This machine did not have any previous version of Real Player installed)
3. Install Flash 11.3.300.262 (Windows 32-bit) version
4. Enable the Real Player addon since when I start Firefox it is disabled (requires Firefox browser restart)
5. Launch Firefox and play a youtube.com video or any other flash video.
6. Receive an error similar to the screenshot previously attached.
7. Firefox browser restart does not resolve the issue.
8. System restart does not resolve the issue.

Paul states in Comment 48 he can reproduce as well, so something is definitely going on. So far it has not worked on all of the machines I have tested on.
Comment 54 Dave Herrera 2012-07-05 23:28:14 PDT
Thank you for the detailed steps, we'll run through the exact scenarios first thing in the morning.
Comment 55 Dave Herrera 2012-07-06 13:48:01 PDT
Marcia, we can now reproduce what you are seeing. As of yesterday, neither QA, nor Dev could reproduce the playback error. Today, every machine regardless of install order reproduces the issue.

Our current theory is that something changed shortly after our release. Our mitigation fix relies on several external variables (besides Firefox and Flash's version) and we should know shortly what changed.

We have a concurrent project under way that has a full fix for the Download and Flash playback issues. That implementation has fewer dependencies (I'll make sure that FF 14 gets tested as well). We'll be in contact by early next week with updated information.

Thank you to everyone who lent assistance.
Comment 56 Julian Adler [:CheckMate] 2012-07-09 17:06:16 PDT
(In reply to Dave Herrera from comment #55)
> Marcia, we can now reproduce what you are seeing. As of yesterday, neither
> QA, nor Dev could reproduce the playback error. Today, every machine
> regardless of install order reproduces the issue.
> 
> Our current theory is that something changed shortly after our release. Our
> mitigation fix relies on several external variables (besides Firefox and
> Flash's version) and we should know shortly what changed.
> 
> We have a concurrent project under way that has a full fix for the Download
> and Flash playback issues. That implementation has fewer dependencies (I'll
> make sure that FF 14 gets tested as well). We'll be in contact by early next
> week with updated information.
> 
> Thank you to everyone who lent assistance.

(In reply to Dave Herrera from comment #54)
> Thank you for the detailed steps, we'll run through the exact scenarios
> first thing in the morning.
 
Hi Dave: I had read your explanation of the mitigation unhooking from Flash and not disabling the extension. I had reverted back to 10.3 but when I realized why you were doing that, especially combined with the next step, to disable Protected Mode, I tried it,last Thur. even though Marcia had said she still was reproducing the issue.

HP Pavillion DV7t Select Edition running Windows 7 Home Premium 64bit OS
Here are my steps. 

1. Uninstall Adobe Flash 10.3 with Adobe uninstaller to remove all versions (previous current version of RealPlayer 15.0.5.109 and Firefox 13.0.1 left intact for a real world test.
2.Restart Windows
3.Install Flash plugin 11.3.300.262 from Adobe's site.
4.Install Flash Active X for Internet Explorer (I did this specifically for this test because some users have complained getting pop ups from RealPlayer needing to have Adobe Flash installed in Internet Explorer.)
5.Launch Firefox and try to play video on youtube.
6.Immediately see the video. Other videos played as well. On June 21 I could not see videos with the 11.3.300.262- now I can with your mitigation. According to the mms.cfg file, Protected Mode is on.
7.Open Firefox Addons Manager and Extensions to confirm status of the Record Plugin extension. Still enabled. The mitigation worked.(but of course, can't download)
8.Follow RealPlayer's video instructions to disable Protected Mode by adding the command line in the mms.cfg file with Note Pad running as Administrator (did not remove the file)
10. Launch Firefox and try to play video on youtube. Instantly, the download button appeared and worked and is still working.

  I noticed Marcia never mentioned installing the Active X for IE on a clean state machine. That's the only difference, except 32bit vs 64bit.

 I don't know if this is useful information, but I thought it might be.

Thanks,
 Julian Adler
Comment 57 caucow98 2013-03-07 18:42:19 PST
I think this bug is caused by a program other than RealPlayer. I have had RealPlayer for a few years and the only problem I have ever had is the internal browser in the actual program not connecting to the internet (which is my actually my fault). The in-browser recording plugin has always worked perfectly. As for the attachment in this report, that should be reported to YouTube, not Mozilla. There was a period of about 2 or three months where sometimes I would get this error, but simply reloading the page ALWAYS fixed it.
It could also be an internet connection error.

I am running Windows XP SP3 with the RealPlayer Browser Record Plugin 15.0.4 and have no problems.
Comment 58 caucow98 2013-03-07 19:05:54 PST
Created attachment 722611 [details]
Going to the EXACT SAME URL as the attachment shown on report page. Loads video, downloads video, no error.

I have never had persistent problems with the RealPlayer Browser Record Plugin that couldn't be fixed by reloading the page or restarting firefox in normal mode (or restarting my computer when there is a severe problem, but that is almost always system-wide)
I have actually been able to (IN FIREFOX) go to YouTube, load a video (so that the time bar in the YouTube video is full), shut off my WLAN card and remove ethernet cables (so I should have NO internet connection), and record 3 YouTube videos to the hard drive from memory. After saving the videos they worked in realplayer and could be trimmed, converted, etc.


My stats:
Microsoft Windows XP Professional SP3
Dell Laptop Model: VOSTRO 1510
RealPlayer Browser Record Plugin 5.0.14
100 Mbps Ethernet connection speed to router.
54 Mbps Wireless connection speed to router.
3-4 Mbps upload speed to internet.
20-25 Mbps download speed to internet.
Comment 59 caucow98 2013-03-07 19:17:24 PST
Created attachment 722615 [details]
Going to the EXACT SAME URL as the attachment shown on report page. Loads video, downloads video, no error.
Comment 60 caucow98 2013-03-07 19:28:39 PST
Comment on attachment 722615 [details]
Going to the EXACT SAME URL as the attachment shown on report page. Loads video, downloads video, no error.

I have never had issues that could be linked to this plugin. I have even been able to load YouTube videos into memory (into browser memory), turn off my WLAN card and remove ethernet cables (so there is absolutely no internet connection), then use the RealPlayer Browser Record Plugin to save the videos from memory.

My computer's stats:
OS: Microsoft Windows XP Professional SP3
Dell Laptop Model: VOSTRO 1510
RAM: 2 GB
CPU: 3.6 GHz (Intel Duo Core Processer, 1.8 GHz per core)
100 Mbps connection speed to router using ethernet cable.
54 Mbps connection speed to router using Wireless.
3-6 Mbps upload speed to ISP
20-35 Mbps download speed from ISP
Comment 61 caucow98 2013-03-07 21:20:43 PST
Oh, wow sorry about comment spam everyone, I thought my computer screwed up a few times, didn't notice the comments added at bottom of page.

Note You need to log in before you can comment on or make changes to this bug.