Closed Bug 763459 Opened 8 years ago Closed 7 years ago

RealPlayer Browser record plugin breaks Youtube since Fx13

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox13 - ---
firefox14 - ---

People

(Reporter: thomas, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

On irc.mozilla.org we have a stunningly high number of people coming in to #firefox.de asking for help with Youtube being broken 'Since Fx13 update'.

We were able to fix ALL of those by removing the so called 'RealPlayer Browser record plugin' from their profiles.


Actual results:

YouTube doesn't work (videos don't play).
Either white box or error message appears.


Expected results:

YouTube videos play normally.

Suggestion: Blacklist the RealPlayer extension.
We should contact them before blocklisting it.
Component: Untriaged → Blocklisting
Product: Firefox → addons.mozilla.org
QA Contact: untriaged → blocklisting
Version: 13 Branch → unspecified
Confirmed in a Win 7 VM. Even after disabling the plugin I still was getting the error. Launching with a clean profile seems to resolve it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
See also bug 759689
(In reply to Marcia Knous [:marcia] from comment #2)
> Confirmed in a Win 7 VM. Even after disabling the plugin I still was getting
> the error. Launching with a clean profile seems to resolve it.

What versions of Flash/RealPlayer/Firefox does this reproduce with? Preferably a blocklist would only be used in this instance if it was a RealPlayer regression.
I was able to reproduce it by downloading the latest version from realplayer.com which installs:

        RealPlayer Browser Record Plugin
        15.0.4
        true
        {97E22097-9A2F-45b1-8DAF-36AD648C7EF4}

This screenshot shows a list of other plugins which for some reason don't show in about:support.
I can confirm by disabling the addon in Comment 6 and restarting Firefox, I can get flash functionality back.
i haven't had a chance to try, but is this specific to a Flash Player version?
i can confirm the issue only happens with the protectedmode flash player version, 11,3,300,257.  i cannot reproduce with the previous release 11,2,202,235.  we are tracking the issue internally in #3211210
Status: NEW → ASSIGNED
We debugged this a couple years back, and found that RealPlayer was doing the following: 

1) Adds a browser helper object to intercept all html before it goes to the browser.  Rewrite that html so that all flash instances appear to be realPlayer instances instead.

2) RealPlayer instance loads Flash plugin, provides the npapi or ActiveX host api to it.  It passes through all params from the original html.  We think we are running in the browser, but its actually RealPlayer that is our host.

Our assumption is that the interfaces provided by RealPlayer no longer work with ProtectedMode because they're either no longer consistent with the NPAPI as implemented in current versions of Firefox (the latest GA RealPlayer appears to be from 11/2011), or maybe it's failing some of the security checks in place to mitigate spoofing IPC communication.

Regardless, this kind of approach and the resulting impact seems like bad citizenship.
(In reply to smadayag from comment #9)
> i can confirm the issue only happens with the protectedmode flash player
> version, 11,3,300,257.  i cannot reproduce with the previous release
> 11,2,202,235.  we are tracking the issue internally in #3211210

Do you all have a path to resolution on your end? Perhaps protected mode can be temporarily disabled when Flash is hosted by RealPlayer. Advising users to disable the current release of RealPlayer isn't a long term solution for us - we'd like to know your plans so we can make arrangements accordingly. Thanks!
(In reply to smadayag from comment #9)
> i can confirm the issue only happens with the protectedmode flash player
> version, 11,3,300,257.  i cannot reproduce with the previous release
> 11,2,202,235.  we are tracking the issue internally in #3211210

Flash 11.3 beta is also not working with older versions of Real Player (12.0.1.669, 15.0.0.198).
Adding qawanted to help understand what functional regressions our users will see if we decide blocklist Real Player.
Keywords: qawanted
The latest version of Real Player installs five plugins including the "RealPlayer Download Plugin." Disabling that by itself allows you to play content that uses Flash 11.3.x. You need a Firefox restart for this to take effect.

I tried installing a few older versions of Real Player, but I could not reproduce the problem with versions that did not come with this download plugin.

This is the latest version for example:

File: nprpplugin.dll
Version: 15.0.4.53
RealPlayer Download Plugin
Depends on: 764210
Based upon the success of disabling the RealPlayer Download Plugin w/r/t resolving this issue, and the user experience once disabled, we've decided to move forward with the block in bug 764210.
Duplicate of this bug: 759689
15.0.2 {ABDE892B-13A8-4d1b-88E6-365A6E755758} seen in the wild causing the problem.

Also the inflow of users reporting the problem on #firefox.de doesn't seem to be getting smaller after the block? (I've seen also the supposedly blocked UUID)
Is this supposed to take longer to take effect?
(In reply to Thomas B. Rücker from comment #17)
> 15.0.2 {ABDE892B-13A8-4d1b-88E6-365A6E755758} seen in the wild causing the
> problem.

Can you confirm that disabling this add-on did fix the problem? We blocked another UUID associated with the RealPlayer Browser Record Plugin.

> Also the inflow of users reporting the problem on #firefox.de doesn't seem
> to be getting smaller after the block? (I've seen also the supposedly
> blocked UUID)
> Is this supposed to take longer to take effect?

It shouldn't take more than 24-48 hours for users to receive the block. For all users that come into the channel with problems, please:

* Find out whether they've got the RealPlayer Browser Record Plugin installed
* Find out whether they've disabled the RealPlayer Browser Record Plugin
* Find out the UUID of the add-on, if it was still enabled when they were having the problem.

We may need to reopen bug 759689 based upon your feedback.
In our testing, we found that simply disabling the RealPlayer Browser Record plug-in was not enough to resolve this issue.  

Completing *all* of the following steps were required: 
    Launch RealPlayer
    Click the RealPlayer icon in the upper left corner of the window and choose Preferences.
    Choose Download & Recording from the left hand panel
    Uncheck "Enable Web Download & Recording for these installed browsers"
    Click OK and close RealPlayer
    Restart Firefox
(In reply to Alex Keybl [:akeybl] from comment #18)
> (In reply to Thomas B. Rücker from comment #17)
> > 15.0.2 {ABDE892B-13A8-4d1b-88E6-365A6E755758} seen in the wild causing the
> > problem.
> 
> Can you confirm that disabling this add-on did fix the problem? We blocked
> another UUID associated with the RealPlayer Browser Record Plugin.

Sadly the user quit and didn't confirm. I was hoping to get a proper confirmation.

> > Also the inflow of users reporting the problem on #firefox.de doesn't seem
> > to be getting smaller after the block? (I've seen also the supposedly
> > blocked UUID)
> > Is this supposed to take longer to take effect?
> 
> It shouldn't take more than 24-48 hours for users to receive the block. For
> all users that come into the channel with problems, please:

> * Find out whether they've got the RealPlayer Browser Record Plugin installed
> * Find out whether they've disabled the RealPlayer Browser Record Plugin
> * Find out the UUID of the add-on, if it was still enabled when they were
> having the problem.

Yeah, I'm trying to get exactly that out of them. Not everyone is patient or skilled enough though to go through all the motions, eventhough we have very detailed instruction pages prepared (e.g. about pastebinning about:support).

I'll keep you posted.
Duplicate of this bug: 759689
This is not a Firefox issue, so no need to track for future releases.
The Flash Content is still not loaded, even if Real Player is uninstalled, on all Firefox versions before 9.0.1. If protected mode is disabled then flash content is loaded.
(In reply to Simona B [QA] from comment #23)
> on all Firefox versions before 9.0.1.

These versions are not supported anymore anyway, hence of no interest.
Andre, I think all Simona was trying to point out is that this was not a regression in Firefox 13, which is something important to know. Thanks Simona for testing.
Ah! Sorry Simona, I obviously didn't get your intention. :(
Thanks for adding this piece of information then!
Duplicate of this bug: 763235
Depends on: 771802
The latest versions of RealPlayer and RealDownloader offered through real.com are working for me. The latest version of the former is 15.0.6 and I compared that functionality to that of a pre-release version provided by the folks at Real that has the name version number and both worked fine. Earlier versions do not allow me to play videos on youtube.

It looks like the latest version works. I will continue testing on other machines, but so far it looks like it is working.
Our testing confirms the same results.
I've now tested on Win7, Vista, XP using Fx13 and Fx14 with Flash 11.3...257-268 using the common scenario where a user installs the new version of RealPlayer, and content on YouTube plays normally. I tried other sites that use Flash like Vimeo and Hulu and everything seems to be working fine.
Calling this fixed.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Confirmed. Youtube works fine with Flash 11.7.700.224/Real Player 16.0.2.232, FF 21, 24.0a1 (2013-06-19)
Status: RESOLVED → VERIFIED
Keywords: qawanted
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.