Closed Bug 760023 Opened 8 years ago Closed 8 years ago

Firefox default browser option from installer and preferences does not work

Categories

(Firefox :: Installer, defect)

13 Branch
All
Windows 8
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: pauly, Unassigned)

References

Details

1. Set FF as the default browser
2. Click on the mail button in Yahoo Messenger (right top)

Actual results:
IE opens the mailbox

Expected results:
FF should open the mailbox

Note: I'm also not able to set Google Chrome as the default browser
Summary: Firefox doesn't behave as the default browser → [win8] Firefox doesn't behave as the default browser
You have to set FF as the default browser at install time through the windows popup or control panel.  I think we have to remove the prompt and ability from the UI in Win 8 and beyond.
Blocks: 737833
Summary: [win8] Firefox doesn't behave as the default browser → [win8] Firefox default browser option from installer and preferences does not work
On a new win8 RC machine I set the the default browser checkbox on in the installer, and also manually tried to set the default browser in options.  Firefox thinks it is the default browser, but if I invoke a URL inside the Run dialog (Start menu button + R), it invokes the URL in Internet Explorer.

This UI is no longer functional in Windows 8 (even for Desktop) and should be removed or replaced with an option that invokes the control panel equivalent. 

I would like someone to independently verify my claims from this comment though before we start disabling UI.
Summary: [win8] Firefox default browser option from installer and preferences does not work → Firefox default browser option from installer and preferences does not work
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> I would like someone to independently verify my claims from this comment
> though before we start disabling UI.

I freshly install Win8 RC on my laptop, and I confirm:

Installed lastest Nightly, checked the box "Set Nightly as my default browser" > the pref is set to true, but the links in other apps are opened with IE.
No longer blocks: 737833
Depends on: 760671
Depends on: 760679
Depends on: 760680
Depends on: 760694
Depends on: 760729
Depends on: 763455
Depends on: 764515
Duplicate of this bug: 686760
Why are we duping old bugs to new bugs if the new bugs have no patches?
The work is being handled here, and there are patches in the bugs tracked by this bug. Duplicates should be marked even if there are no patches by the way.  

I generally dupe to the older bug, but when a newer bug happens to have better info or makes more sense in the current context, I dupe to the newer bug.
Can this and bug 760694 be closed out?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.